aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/py-fastaudio/Makefile2
-rw-r--r--audio/py-fastaudio/files/patch-fastaudio.pyx6
-rw-r--r--audio/py-fastaudio/files/patch-mysndfile.h6
3 files changed, 7 insertions, 7 deletions
diff --git a/audio/py-fastaudio/Makefile b/audio/py-fastaudio/Makefile
index 02b6f3e4ddb7..d51e2d36202b 100644
--- a/audio/py-fastaudio/Makefile
+++ b/audio/py-fastaudio/Makefile
@@ -48,7 +48,7 @@ do-extract:
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
- ${WRKSRC}/setup.py ${WRKSRC}/mysndfile.h
+ ${WRKSRC}/setup.py ${WRKSRC}/mysndfile.h ${WRKSRC}/fastaudio.pyx
# Borrowed from the portaudio port, fixes obsolete path
@${REINPLACE_CMD} -e 's|machine\/soundcard.h|sys\/soundcard.h|' \
${PORTASRC_DIR}/pa_unix_oss/pa_unix_oss.c
diff --git a/audio/py-fastaudio/files/patch-fastaudio.pyx b/audio/py-fastaudio/files/patch-fastaudio.pyx
index 61a27468816a..8f097b13b3f0 100644
--- a/audio/py-fastaudio/files/patch-fastaudio.pyx
+++ b/audio/py-fastaudio/files/patch-fastaudio.pyx
@@ -1,11 +1,11 @@
---- fastaudio.pyx.orig Sat Mar 3 10:53:45 2007
-+++ fastaudio.pyx Sat Mar 3 11:03:03 2007
+--- fastaudio.pyx.orig 2004-06-15 20:37:39.000000000 +0900
++++ fastaudio.pyx 2009-06-06 18:54:52.000000000 +0900
@@ -92,7 +92,7 @@
#@+node:portaudio.h
# portaudio-specifics
-cdef extern from "../pa_common/portaudio.h":
-+cdef extern from "/usr/local/include/portaudio.h":
++cdef extern from "%%LOCALBASE%%/include/portaudio.h":
ctypedef int PaError
cdef enum PA_ERRORS:
diff --git a/audio/py-fastaudio/files/patch-mysndfile.h b/audio/py-fastaudio/files/patch-mysndfile.h
index c29917b9e512..2fbd3032941b 100644
--- a/audio/py-fastaudio/files/patch-mysndfile.h
+++ b/audio/py-fastaudio/files/patch-mysndfile.h
@@ -1,9 +1,9 @@
---- mysndfile.h.orig Tue Jun 15 13:37:39 2004
-+++ mysndfile.h Sat Mar 3 11:53:57 2007
+--- mysndfile.h.orig 2009-06-06 18:51:14.000000000 +0900
++++ mysndfile.h 2009-06-06 18:51:38.000000000 +0900
@@ -1,5 +1,5 @@
#ifdef WIN32
#include "sndfile-win32.h"
#else
-#include "sndfile.h"
-+#include "/usr/local/include/sndfile.h"
++#include "%%LOCALBASE%%/include/sndfile.h"
#endif