aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_php3/Makefile6
-rw-r--r--www/mod_php4/Makefile13
-rw-r--r--www/mod_php5/Makefile13
3 files changed, 20 insertions, 12 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index 8764c5014374..1fa644893745 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -27,8 +27,8 @@ PATCHFILES= mime.c.diff-3.0.gz
MAINTAINER= dirk@FreeBSD.org
.if !defined(STANDALONE)
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
.endif
PATCH_DIST_ARGS= -d ${WRKSRC}/functions
@@ -36,6 +36,8 @@ PATCH_DIST_ARGS= -d ${WRKSRC}/functions
PHP_DISTDIR= distributions
SLAVEDIRS= lang/php3
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+APXS?= ${LOCALBASE}/sbin/apxs
USE_SUBMAKE= yes
GNU_CONFIGURE= yes
diff --git a/www/mod_php4/Makefile b/www/mod_php4/Makefile
index c1acd078bea1..27264d970100 100644
--- a/www/mod_php4/Makefile
+++ b/www/mod_php4/Makefile
@@ -23,13 +23,10 @@ DISTNAME= php-${PORTVERSION}
MAINTAINER= dirk@FreeBSD.org
.if !defined(STANDALONE)
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
.if defined(WITH_APACHE2)
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
LIB_DEPENDS= pth.14:${PORTSDIR}/devel/pth
-.else
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
.endif
.endif
@@ -40,6 +37,12 @@ SLAVEDIRS= lang/php4
USE_BZIP2= yes
USE_SUBMAKE= yes
USE_AUTOCONF_VER=213
+.if defined(WITH_APACHE2)
+APACHE_PORT?= ${PORTSDIR}/www/apache2
+.else
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+.endif
+APXS?= ${LOCALBASE}/sbin/apxs
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index c1acd078bea1..27264d970100 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -23,13 +23,10 @@ DISTNAME= php-${PORTVERSION}
MAINTAINER= dirk@FreeBSD.org
.if !defined(STANDALONE)
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
.if defined(WITH_APACHE2)
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
LIB_DEPENDS= pth.14:${PORTSDIR}/devel/pth
-.else
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
.endif
.endif
@@ -40,6 +37,12 @@ SLAVEDIRS= lang/php4
USE_BZIP2= yes
USE_SUBMAKE= yes
USE_AUTOCONF_VER=213
+.if defined(WITH_APACHE2)
+APACHE_PORT?= ${PORTSDIR}/www/apache2
+.else
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+.endif
+APXS?= ${LOCALBASE}/sbin/apxs
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes