aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/zabbix2-agent/Makefile1
-rw-r--r--net-mgmt/zabbix2-frontend/Makefile5
-rw-r--r--net-mgmt/zabbix2-proxy/Makefile1
-rw-r--r--net-mgmt/zabbix2-server/Makefile29
-rw-r--r--net-mgmt/zabbix2-server/pkg-plist1
-rw-r--r--net-mgmt/zabbix2-server/pkg-plist.agent3
6 files changed, 18 insertions, 22 deletions
diff --git a/net-mgmt/zabbix2-agent/Makefile b/net-mgmt/zabbix2-agent/Makefile
index 244ef25fb79b..6422d0ba1a80 100644
--- a/net-mgmt/zabbix2-agent/Makefile
+++ b/net-mgmt/zabbix2-agent/Makefile
@@ -13,6 +13,5 @@ OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
OPTIONS_DEFINE= IPV6
OPTIONS_DEFAULT= IPV6
-NO_STAGE= yes
.include <bsd.port.options.mk>
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix2-frontend/Makefile b/net-mgmt/zabbix2-frontend/Makefile
index 63dbe46facee..2cf34a1f9ca4 100644
--- a/net-mgmt/zabbix2-frontend/Makefile
+++ b/net-mgmt/zabbix2-frontend/Makefile
@@ -20,7 +20,6 @@ OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
OPTIONS_DEFAULT= MYSQL MYSQLI
MYSQLI_DESC= MySQLI backend
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -45,7 +44,7 @@ CONFIGURE_ARGS+= --with-oracle
.endif
do-install:
- @${INSTALL} -d ${WWWDIR}
- @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${WWWDIR}
+ @${INSTALL} -d ${STAGEDIR}${WWWDIR}
+ @cd ${WRKSRC}/frontends/php/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix2-proxy/Makefile b/net-mgmt/zabbix2-proxy/Makefile
index 6ecf8579605b..d5cc6a47672f 100644
--- a/net-mgmt/zabbix2-proxy/Makefile
+++ b/net-mgmt/zabbix2-proxy/Makefile
@@ -6,5 +6,4 @@ PKGNAMESUFFIX= -proxy
MASTERDIR= ${.CURDIR}/../zabbix2-server
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/zabbix2-server/Makefile b/net-mgmt/zabbix2-server/Makefile
index f448525dc3aa..2a9d792f62c2 100644
--- a/net-mgmt/zabbix2-server/Makefile
+++ b/net-mgmt/zabbix2-server/Makefile
@@ -26,11 +26,8 @@ ZABBIX_BUILD= ${PKGNAMESUFFIX:S/^-//}
.if ${ZABBIX_BUILD} != "frontend" # frontend only needs the version/distribution settings
.if ${ZABBIX_BUILD} != "agent"
-MAN8+= zabbix_${ZABBIX_BUILD}.8
USE_RC_SUBR= zabbix_${ZABBIX_BUILD}
.else
-MAN1+= zabbix_get.1 zabbix_sender.1
-MAN8+= zabbix_${ZABBIX_BUILD}d.8
USE_RC_SUBR= zabbix_${ZABBIX_BUILD}d
.endif
@@ -61,8 +58,8 @@ CONFIGURE_ARGS+= --enable-${ZABBIX_BUILD} \
--datadir=${ETCDIR}
.if ${ZABBIX_BUILD} != "agent"
-LIB_DEPENDS= netsnmp:${PORTSDIR}/net-mgmt/net-snmp \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libnetsnmp.so:${PORTSDIR}/net-mgmt/net-snmp \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
SUB_FILES= pkg-message
@@ -89,7 +86,6 @@ OPTIONS_SINGLE= DB ODBC
OPTIONS_SINGLE_DB= MYSQL PGSQL SQLITE ORACLE
OPTIONS_SINGLE_ODBC= IODBC UNIXODBC
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
@@ -116,7 +112,7 @@ CONFIGURE_ARGS+= --with-oracle
.endif
.if ${PORT_OPTIONS:MCURL}
-LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-libcurl
.endif
@@ -126,12 +122,12 @@ CONFIGURE_ARGS+= --with-ldap
.endif
.if ${PORT_OPTIONS:MIPMI}
-LIB_DEPENDS+= OpenIPMI:${PORTSDIR}/sysutils/openipmi
+LIB_DEPENDS+= libOpenIPMI.so:${PORTSDIR}/sysutils/openipmi
CONFIGURE_ARGS+= --with-openipmi
.endif
.if ${PORT_OPTIONS:MJABBER}
-LIB_DEPENDS+= iksemel:${PORTSDIR}/textproc/iksemel
+LIB_DEPENDS+= libiksemel.so:${PORTSDIR}/textproc/iksemel
CONFIGURE_ARGS+= --with-jabber
.endif
@@ -140,17 +136,17 @@ RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
.endif
.if ${PORT_OPTIONS:MSSH}
-LIB_DEPENDS+= ssh2:${PORTSDIR}/security/libssh2
+LIB_DEPENDS+= libssh2.so:${PORTSDIR}/security/libssh2
CONFIGURE_ARGS+= --with-ssh2
.endif
.if ${PORT_OPTIONS:MIODBC}
-LIB_DEPENDS+= iodbc:${PORTSDIR}/databases/libiodbc
+LIB_DEPENDS+= libiodbc.so:${PORTSDIR}/databases/libiodbc
CONFIGURE_ARGS+= --with-iodbc
.endif
.if ${PORT_OPTIONS:MUNIXODBC}
-LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+= --with-unixodbc
.endif
.endif # if ${ZABBIX_BUILD} != "agent"
@@ -195,14 +191,13 @@ post-patch:
post-install:
.if defined(WITH_JAVAGW)
- @${MV} ${PREFIX}/sbin/zabbix_java/settings.sh ${PREFIX}/sbin/zabbix_java/settings.sh.sample
+ @${MV} ${PREFIX}/sbin/zabbix_java/settings.sh ${STAGEDIR}${PREFIX}/sbin/zabbix_java/settings.sh.sample
.endif
.if ${ZABBIX_BUILD} != "agent"
- @${MKDIR} "${DATADIR}/${ZABBIX_BUILD}/database"
- @cd ${WRKSRC}/upgrades/ && ${COPYTREE_SHARE} dbpatches ${DATADIR}/${ZABBIX_BUILD}/upgrades/
- @cd ${WRKSRC}/database/ && ${COPYTREE_SHARE} "ibm_db2 mysql oracle postgresql sqlite3" ${DATADIR}/${ZABBIX_BUILD}/database/
- @${CAT} ${PKGMESSAGE}
+ @${MKDIR} "${STAGEDIR}${DATADIR}/${ZABBIX_BUILD}/database"
+ @cd ${WRKSRC}/upgrades/ && ${COPYTREE_SHARE} dbpatches ${STAGEDIR}${DATADIR}/${ZABBIX_BUILD}/upgrades/
+ @cd ${WRKSRC}/database/ && ${COPYTREE_SHARE} "ibm_db2 mysql oracle postgresql sqlite3" ${STAGEDIR}${DATADIR}/${ZABBIX_BUILD}/database/
.endif
.endif # if ${ZABBIX_BUILD} != "frontend"
diff --git a/net-mgmt/zabbix2-server/pkg-plist b/net-mgmt/zabbix2-server/pkg-plist
index 366e4d554569..02a0c59745dd 100644
--- a/net-mgmt/zabbix2-server/pkg-plist
+++ b/net-mgmt/zabbix2-server/pkg-plist
@@ -1,4 +1,5 @@
%%ETCDIR%%/zabbix_%%ZABBIX_BUILD%%.conf.sample
+man/man8/zabbix_%%ZABBIX_BUILD%%.8.gz
sbin/zabbix_%%ZABBIX_BUILD%%
%%DATADIR%%/%%ZABBIX_BUILD%%/database/mysql/data.sql
%%DATADIR%%/%%ZABBIX_BUILD%%/database/mysql/schema.sql
diff --git a/net-mgmt/zabbix2-server/pkg-plist.agent b/net-mgmt/zabbix2-server/pkg-plist.agent
index 589cb8a158cb..bef621895412 100644
--- a/net-mgmt/zabbix2-server/pkg-plist.agent
+++ b/net-mgmt/zabbix2-server/pkg-plist.agent
@@ -7,3 +7,6 @@ sbin/zabbix_agentd
@dirrmtry %%ETCDIR%%/zabbix_agentd.conf.d
@dirrmtry %%ETCDIR%%/zabbix_agent.conf.d
@dirrmtry %%ETCDIR%%
+man/man1/zabbix_get.1.gz
+man/man1/zabbix_sender.1.gz
+man/man8/zabbix_%%ZABBIX_BUILD%%d.8.gz