aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/rpcs3/Makefile1
-rw-r--r--emulators/rpcs3/files/patch-no-asserts15
2 files changed, 16 insertions, 0 deletions
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index ac0cbe3e4bd0..a7c67760d89a 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -4,6 +4,7 @@ PORTNAME= rpcs3
DISTVERSIONPREFIX= v
DISTVERSION= 0.0.5-259
DISTVERSIONSUFFIX= -g76a1d0d8f
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= jbeich@FreeBSD.org
diff --git a/emulators/rpcs3/files/patch-no-asserts b/emulators/rpcs3/files/patch-no-asserts
new file mode 100644
index 000000000000..36df8ccaa148
--- /dev/null
+++ b/emulators/rpcs3/files/patch-no-asserts
@@ -0,0 +1,15 @@
+https://github.com/RPCS3/rpcs3/issues/3745
+
+--- rpcs3/CMakeLists.txt.orig 2018-05-09 22:44:51.000000000 +0000
++++ rpcs3/CMakeLists.txt
+@@ -81,6 +81,10 @@ add_custom_command(OUTPUT something_that_never_exists
+ # Check for a sufficient compiler and set build options
+ include(ConfigureCompiler)
+
++if(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
++ add_definitions(-DNDEBUG)
++endif()
++
+ if(WIN32)
+ add_definitions(-DUNICODE)
+ add_definitions(-D_WIN32_WINNT=0x0601)