aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cjson/Makefile23
-rw-r--r--devel/py-cjson/distinfo3
-rw-r--r--devel/py-cjson/pkg-descr15
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cad4ed6263f8..83ec6ad94b97 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1724,6 +1724,7 @@
SUBDIR += py-celementtree
SUBDIR += py-cheetah
SUBDIR += py-ciphon
+ SUBDIR += py-cjson
SUBDIR += py-clientcookie
SUBDIR += py-configobj
SUBDIR += py-coro
diff --git a/devel/py-cjson/Makefile b/devel/py-cjson/Makefile
new file mode 100644
index 000000000000..ffb22240e21c
--- /dev/null
+++ b/devel/py-cjson/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-cjson
+# Date created: Jan. 27, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cjson
+PORTVERSION= 1.0.3
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/p/python-cjson/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-cjson-${PORTVERSION}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= Fast JSON encoder/decoder for Python
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/cjson.so
+
+.include <bsd.port.mk>
diff --git a/devel/py-cjson/distinfo b/devel/py-cjson/distinfo
new file mode 100644
index 000000000000..868b4a916294
--- /dev/null
+++ b/devel/py-cjson/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-cjson-1.0.3.tar.gz) = 4c8ad537173103d8acfb12d20a2f5d38
+SHA256 (python-cjson-1.0.3.tar.gz) = 5d114c51791d7b4799c98514de1cbbb0915c873999aaf382186e9da059702797
+SIZE (python-cjson-1.0.3.tar.gz) = 10714
diff --git a/devel/py-cjson/pkg-descr b/devel/py-cjson/pkg-descr
new file mode 100644
index 000000000000..47e3878d3efd
--- /dev/null
+++ b/devel/py-cjson/pkg-descr
@@ -0,0 +1,15 @@
+This module implements a very fast JSON encoder/decoder for Python.
+
+JSON stands for JavaScript Object Notation and is a text based lightweight
+data exchange format which is easy for humans to read/write and for machines
+to parse/generate. JSON is completely language independent and has multiple
+implementations in most of the programming languages, making it ideal for
+data exchange and storage.
+
+The module is written in C and it is up to 250 times faster when compared to
+the other python JSON implementations which are written directly in python.
+This speed gain varies with the complexity of the data and the operation and
+is the the range of 10-200 times for encoding operations and in the range of
+100-250 times for decoding operations.
+
+WWW: http://www.python.org/pypi/python-cjson/
etions'>-1/+1 * Fix build on -CURRENT.trevor2002-09-253-6/+89 * I forgot to commit this file in the update to 0.15.6. Take outtrevor2000-12-251-8/+5 * Update to 0.15.6. Don't use a DIST_SUBDIR any more (it was onlytrevor2000-12-257-121/+36 * Change MAINTAINER for my ports.trevor2000-10-021-1/+1 * Fix copyright problem.sobomax2000-09-057-63/+61 * Teach MASTER_SITES about new MASTER_SITE_SOURCEFORGE.sobomax2000-06-141-1/+2