aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/postgresql-odbc/Makefile2
-rw-r--r--devel/p4api/Makefile2
-rw-r--r--devel/py-keystone-engine/Makefile2
-rw-r--r--devel/yosys/Makefile2
-rw-r--r--lang/guile2/Makefile1
-rw-r--r--net/freerdp1/Makefile2
-rw-r--r--ports-mgmt/portal/Makefile2
-rw-r--r--security/php72-hash/Makefile5
8 files changed, 16 insertions, 2 deletions
diff --git a/databases/postgresql-odbc/Makefile b/databases/postgresql-odbc/Makefile
index 783f964c15b6..20afca19f057 100644
--- a/databases/postgresql-odbc/Makefile
+++ b/databases/postgresql-odbc/Makefile
@@ -15,6 +15,8 @@ COMMENT= PostgreSQL ODBC driver
LICENSE= LGPL20+
LICENSE_FILE= ${WRKSRC}/license.txt
+BROKEN_powerpc64= fails to compile: misc.h:58:21: expected ';' before 'dummy_for_check'
+
LIB_DEPENDS= libodbc.so:databases/unixODBC
USES= compiler:c11 libtool pgsql
diff --git a/devel/p4api/Makefile b/devel/p4api/Makefile
index 0b9fcc62ffbc..9bd18d1fda78 100644
--- a/devel/p4api/Makefile
+++ b/devel/p4api/Makefile
@@ -22,6 +22,8 @@ COMMENT= Perforce API (static libraries and header files)
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: /bin/sh: clang++: not found
+
BUILD_DEPENDS= ${JAM}:devel/jam
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/py-keystone-engine/Makefile b/devel/py-keystone-engine/Makefile
index 9d256c91c360..aa388df9cce4 100644
--- a/devel/py-keystone-engine/Makefile
+++ b/devel/py-keystone-engine/Makefile
@@ -12,6 +12,8 @@ COMMENT= Keystone Assembler Engine with Python bindings
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+BROKEN_powerpc64= fails to install: /wrkdirs/usr/ports/devel/py-keystone-engine/work-py36/keystone-engine-0.9.1-3/src/build/llvm/lib/libkeystone.so: No such file or directory
+
BUILD_DEPENDS= cmake:devel/cmake
USES= pkgconfig python
diff --git a/devel/yosys/Makefile b/devel/yosys/Makefile
index 9032699afff9..3dd61b069dcf 100644
--- a/devel/yosys/Makefile
+++ b/devel/yosys/Makefile
@@ -12,6 +12,8 @@ COMMENT= Yosys Open SYnthesis Suite
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to build: /bin/sh: clang: not found
+
BUILD_DEPENDS= abc:cad/abc \
bash:shells/bash \
gawk:lang/gawk
diff --git a/lang/guile2/Makefile b/lang/guile2/Makefile
index 90e22657c151..7a83d017299d 100644
--- a/lang/guile2/Makefile
+++ b/lang/guile2/Makefile
@@ -14,6 +14,7 @@ COMMENT= GNU Ubiquitous Intelligent Language for Extension
LICENSE= LGPL21
BROKEN_mips64= fails to build: qemu: uncaught target signal 11 (Segmentation fault) - core dumped
+BROKEN_powerpc64= fails to build: gmake[4]: *** [Makefile:3216: libguile_2.0_la-vm.lo] Error 1
LIB_DEPENDS= libgmp.so:math/gmp \
libltdl.so:devel/libltdl \
diff --git a/net/freerdp1/Makefile b/net/freerdp1/Makefile
index ca766a010450..4c2778406ba0 100644
--- a/net/freerdp1/Makefile
+++ b/net/freerdp1/Makefile
@@ -13,6 +13,8 @@ COMMENT= Free implementation of Remote Desktop Protocol
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: ninja: error: build.ninja:315: bad $-escape (literal $ must be written as $$)
+
USE_GITHUB= yes
GH_ACCOUNT= FreeRDP
GH_PROJECT= ${GH_ACCOUNT}
diff --git a/ports-mgmt/portal/Makefile b/ports-mgmt/portal/Makefile
index 19a19c57c014..86249217ee0f 100644
--- a/ports-mgmt/portal/Makefile
+++ b/ports-mgmt/portal/Makefile
@@ -10,6 +10,8 @@ COMMENT= Front-end to pkg(8)
LICENSE= BSD2CLAUSE
+BROKEN_powerpc64= fails to build: /usr/local/lib/gcc6/include/c++/thread:189: undefined reference to `std::thread::_State::~_State()'
+
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
diff --git a/security/php72-hash/Makefile b/security/php72-hash/Makefile
index bffd3c975f1c..5b9cfc698766 100644
--- a/security/php72-hash/Makefile
+++ b/security/php72-hash/Makefile
@@ -6,8 +6,9 @@ MASTERDIR= ${.CURDIR}/../../lang/php72
PKGNAMESUFFIX= -hash
-TEST_TARGET= test
-
BROKEN_mips64= fails to compile: KeccakHash.h: No such file or directory
+BROKEN_powerpc64= fails to compile: KeccakHash.h: No such file or directory
+
+TEST_TARGET= test
.include "${MASTERDIR}/Makefile"