aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 6534f85c2c18..2cbbda5e24ac 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4457,6 +4457,10 @@ generate-plist: ${WRKDIR}
${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${PLIST} >> ${TMPPLIST}; \
fi
+.for dir in ${PLIST_DIRS}
+ @${ECHO_CMD} ${dir} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} -e 's,^,@dir ,' >> ${TMPPLIST}
+.endfor
+
.if defined(USE_LINUX_PREFIX)
.if defined(USE_LDCONFIG)
@${ECHO_CMD} "@postexec ${LDCONFIG_CMD}" >> ${TMPPLIST}