aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/mod_dav_svn/Makefile7
-rw-r--r--www/mod_dav_svn/pkg-plist8
2 files changed, 6 insertions, 9 deletions
diff --git a/www/mod_dav_svn/Makefile b/www/mod_dav_svn/Makefile
index 52c6f456a3b9..c7e6a46f4786 100644
--- a/www/mod_dav_svn/Makefile
+++ b/www/mod_dav_svn/Makefile
@@ -22,12 +22,15 @@ CONFIGURE_ARGS+= --with-apxs=${APXS} \
--with-apache-libexecdir \
--without-gnome-keyring \
--without-kwallet
-
-SUB_FILES= pkg-install
+SUB_FILES+= 220_subversion.conf.sample
PLIST_SUB+= SED=${SED}
ALL_TARGET= apache-mod
INSTALL_TARGET= install-mods-shared
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+ ${CP} ${WRKDIR}/220_subversion.conf.sample ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/modules.d
+
.include <bsd.port.post.mk>
diff --git a/www/mod_dav_svn/pkg-plist b/www/mod_dav_svn/pkg-plist
index 7b96153412d5..1b7aec2a3e2d 100644
--- a/www/mod_dav_svn/pkg-plist
+++ b/www/mod_dav_svn/pkg-plist
@@ -1,10 +1,4 @@
-@comment enable / disable modules in this order: dav_svn, authz_svn, dontdothat
-@unexec %%SED%% -i '' -E '/LoadModule[[:blank:]]+dav_svn_module/d' %D/%%APACHEETCDIR%%/httpd.conf
+@sample %%APACHEETCDIR%%/modules.d/220_subversion.conf.sample
%%APACHEMODDIR%%/mod_dav_svn.so
-@exec %D/sbin/apxs -e -a -n dav_svn %D/%F
-@unexec %%SED%% -i '' -E '/LoadModule[[:blank:]]+authz_svn_module/d' %D/%%APACHEETCDIR%%/httpd.conf
%%APACHEMODDIR%%/mod_authz_svn.so
-@exec %D/sbin/apxs -e -a -n authz_svn %D/%F
-@unexec %%SED%% -i '' -E '/LoadModule[[:blank:]]+dontdothat_module/d' %D/%%APACHEETCDIR%%/httpd.conf
%%APACHEMODDIR%%/mod_dontdothat.so
-@exec %D/sbin/apxs -e -A -n dontdothat %D/%F