aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/sane-backends/Makefile9
-rw-r--r--graphics/sane-backends/Makefile.man3
-rw-r--r--graphics/sane-backends/distinfo6
-rw-r--r--graphics/sane-backends/files/patch-sanei_sanei_usb.c96
-rw-r--r--graphics/sane-backends/pkg-plist19
5 files changed, 27 insertions, 106 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 45a5a96083ec..24192b6a594d 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= sane-backends
-PORTVERSION= 1.0.16
-PORTREVISION= 1
+PORTVERSION= 1.0.17
CATEGORIES= graphics
-MASTER_SITES= http://alioth.debian.org/download.php/1079/ \
+MASTER_SITES= http://alioth.debian.org/download.php/1347/ \
ftp://ftp.sane-project.org/pub/sane/%SUBDIR%/ \
ftp://ftp2.sane-project.org/pub/sane/%SUBDIR%/ \
ftp://ftp3.sane-project.org/pub/sane/%SUBDIR%/ \
@@ -41,10 +40,8 @@ INSTALLS_SHLIB= yes
.if defined(WITHOUT_USB)
CONFIGURE_ARGS+= --disable-libusb
-PLIST_SUB+= USB="@comment "
.else
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-PLIST_SUB+= USB=""
.endif
.if defined(WITHOUT_NLS)
@@ -66,5 +63,7 @@ PLIST_SUB+= GPHOTO2="@comment "
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|= \.\./libtool|= @LIBTOOL@|g'
+ @${REINPLACE_CMD} -e 's|} -D_REENT|} ${PTHREAD_CFLAGS} -D_REENT|g ; \
+ s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/graphics/sane-backends/Makefile.man b/graphics/sane-backends/Makefile.man
index d6f2e1906f8c..5815fd4f62e1 100644
--- a/graphics/sane-backends/Makefile.man
+++ b/graphics/sane-backends/Makefile.man
@@ -26,10 +26,12 @@ MAN5+= sane-genesys.5
MAN5+= sane-gphoto2.5
MAN5+= sane-gt68xx.5
MAN5+= sane-hp.5
+MAN5+= sane-hp4200.5
MAN5+= sane-hp5400.5
MAN5+= sane-hpsj5s.5
MAN5+= sane-ibm.5
MAN5+= sane-leo.5
+MAN5+= sane-lexmark.5
MAN5+= sane-ma1509.5
MAN5+= sane-matsushita.5
MAN5+= sane-microtek.5
@@ -37,6 +39,7 @@ MAN5+= sane-microtek2.5
MAN5+= sane-mustek.5
MAN5+= sane-mustek_pp.5
MAN5+= sane-mustek_usb.5
+MAN5+= sane-mustek_usb2.5
MAN5+= sane-nec.5
MAN5+= sane-net.5
MAN5+= sane-niash.5
diff --git a/graphics/sane-backends/distinfo b/graphics/sane-backends/distinfo
index f1d56fb61fbb..3293c3c0ccf9 100644
--- a/graphics/sane-backends/distinfo
+++ b/graphics/sane-backends/distinfo
@@ -1,3 +1,3 @@
-MD5 (sane-backends-1.0.16.tar.gz) = bec9b9262246316b4ebfe2bc7451aa28
-SHA256 (sane-backends-1.0.16.tar.gz) = 85c2720c4417cfe72e4bf8917f84173792b70b834a23fb61c790c6a85b67f036
-SIZE (sane-backends-1.0.16.tar.gz) = 3409799
+MD5 (sane-backends-1.0.17.tar.gz) = b51c10da8a81a04e1bae88c9e6556df2
+SHA256 (sane-backends-1.0.17.tar.gz) = f5478acc07494498fe94aa8801193f8511cacd023fed19aaee1429e10e805d77
+SIZE (sane-backends-1.0.17.tar.gz) = 3588993
diff --git a/graphics/sane-backends/files/patch-sanei_sanei_usb.c b/graphics/sane-backends/files/patch-sanei_sanei_usb.c
deleted file mode 100644
index 1460fa4d5658..000000000000
--- a/graphics/sane-backends/files/patch-sanei_sanei_usb.c
+++ /dev/null
@@ -1,96 +0,0 @@
---- sanei/sanei_usb.c.orig Sun Apr 20 23:55:43 2003
-+++ sanei/sanei_usb.c Tue May 27 12:19:51 2003
-@@ -59,6 +59,10 @@
- #include <usb.h>
- #endif /* HAVE_LIBUSB */
-
-+#if defined (__FreeBSD__)
-+#include <dev/usb/usb.h>
-+#endif /* __FreeBSD__ */
-+
- #define BACKEND_NAME sanei_usb
- #include "../include/sane/sane.h"
- #include "../include/sane/sanei_debug.h"
-@@ -177,6 +181,49 @@
- }
- }
-
-+#if defined (__FreeBSD__)
-+static void
-+kernel_get_vendor_product (int fd, const char *name, int *vendorID, int *productID)
-+{
-+ int controller;
-+ int ctrl_fd;
-+ char buf[40];
-+ int dev;
-+
-+ for (controller = 0; ; controller++ )
-+ {
-+ snprintf (buf, sizeof( buf ) - 1, "/dev/usb%d", controller);
-+ ctrl_fd = open (buf, O_RDWR);
-+
-+ /* If we can not open the usb controller device, treat it
-+ as the end of controller devices */
-+ if (ctrl_fd < 0)
-+ break;
-+
-+ /* Search for the scanner device on this bus */
-+ for( dev = 1; dev < USB_MAX_DEVICES; dev++ )
-+ {
-+ struct usb_device_info devInfo;
-+ devInfo.udi_addr = dev;
-+
-+ if (ioctl (ctrl_fd, USB_DEVICEINFO, &devInfo) == -1)
-+ break; /* Treak this as the end of devices for this controller */
-+
-+ snprintf( buf, sizeof( buf ), "/dev/%s", devInfo.udi_devnames[0] );
-+ if( strncmp( buf, name, sizeof( buf ) ) == 0 )
-+ {
-+ *vendorID = (int)devInfo.udi_vendorNo;
-+ *productID = (int)devInfo.udi_productNo;
-+ close( ctrl_fd );
-+ return;
-+ }
-+ }
-+ close( ctrl_fd );
-+ DBG (3, "kernel_get_vendor_product: Could not retrieve "
-+ "vendor/product ID from device %d\n", fd );
-+ }
-+}
-+#else
- static void
- kernel_get_vendor_product (int fd, int *vendorID, int *productID)
- {
-@@ -197,6 +244,7 @@
- #endif /* defined (__linux__) */
- /* put more os-dependant stuff ... */
- }
-+#endif
-
- void
- sanei_usb_init (void)
-@@ -277,7 +325,11 @@
- }
- vendor = -1;
- product = -1;
-+#if defined (__FreeBSD__)
-+ kernel_get_vendor_product (fd, devname, &vendor, &product);
-+#else
- kernel_get_vendor_product (fd, &vendor, &product);
-+#endif
- close (fd);
- devices[dn].devname = strdup (devname);
- if (!devices[dn].devname)
-@@ -440,7 +492,11 @@
- }
-
- if (devices[dn].method == sanei_usb_method_scanner_driver)
-+#if defined (__FreeBSD__)
-+ kernel_get_vendor_product (devices[dn].fd, devices[dn].devname, &vendorID, &productID);
-+#else
- kernel_get_vendor_product (devices[dn].fd, &vendorID, &productID);
-+#endif
- else if (devices[dn].method == sanei_usb_method_libusb)
- {
- #ifdef HAVE_LIBUSB
-
diff --git a/graphics/sane-backends/pkg-plist b/graphics/sane-backends/pkg-plist
index 8cd355a9d5d2..6413fdbbf00d 100644
--- a/graphics/sane-backends/pkg-plist
+++ b/graphics/sane-backends/pkg-plist
@@ -24,9 +24,11 @@ etc/sane.d/genesys.conf
%%GPHOTO2%%etc/sane.d/gphoto2.conf
etc/sane.d/gt68xx.conf
etc/sane.d/hp.conf
+etc/sane.d/hp4200.conf
etc/sane.d/hp5400.conf
etc/sane.d/ibm.conf
etc/sane.d/leo.conf
+etc/sane.d/lexmark.conf
etc/sane.d/ma1509.conf
etc/sane.d/matsushita.conf
etc/sane.d/microtek.conf
@@ -107,12 +109,16 @@ lib/sane/libsane-gt68xx.so
lib/sane/libsane-gt68xx.so.1
lib/sane/libsane-hp.so
lib/sane/libsane-hp.so.1
+lib/sane/libsane-hp4200.so
+lib/sane/libsane-hp4200.so.1
lib/sane/libsane-hp5400.so
lib/sane/libsane-hp5400.so.1
lib/sane/libsane-ibm.so
lib/sane/libsane-ibm.so.1
lib/sane/libsane-leo.so
lib/sane/libsane-leo.so.1
+lib/sane/libsane-lexmark.so
+lib/sane/libsane-lexmark.so.1
lib/sane/libsane-ma1509.so
lib/sane/libsane-ma1509.so.1
lib/sane/libsane-matsushita.so
@@ -125,6 +131,8 @@ lib/sane/libsane-mustek.so
lib/sane/libsane-mustek.so.1
lib/sane/libsane-mustek_usb.so
lib/sane/libsane-mustek_usb.so.1
+lib/sane/libsane-mustek_usb2.so
+lib/sane/libsane-mustek_usb2.so.1
lib/sane/libsane-nec.so
lib/sane/libsane-nec.so.1
lib/sane/libsane-net.so
@@ -145,8 +153,8 @@ lib/sane/libsane-sceptre.so
lib/sane/libsane-sceptre.so.1
lib/sane/libsane-sharp.so
lib/sane/libsane-sharp.so.1
-%%USB%%lib/sane/libsane-sm3600.so
-%%USB%%lib/sane/libsane-sm3600.so.1
+lib/sane/libsane-sm3600.so
+lib/sane/libsane-sm3600.so.1
lib/sane/libsane-sm3840.so
lib/sane/libsane-sm3840.so.1
lib/sane/libsane-snapscan.so
@@ -205,6 +213,8 @@ sbin/saned
%%PORTDOCS%%%%DOCSDIR%%/mustek/mustek.CHANGES
%%PORTDOCS%%%%DOCSDIR%%/mustek_usb/mustek_usb.CHANGES
%%PORTDOCS%%%%DOCSDIR%%/mustek_usb/mustek_usb.TODO
+%%PORTDOCS%%%%DOCSDIR%%/mustek_usb2/mustek_usb2.CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/mustek_usb2/mustek_usb2.TODO
%%PORTDOCS%%%%DOCSDIR%%/niash/niash.TODO
%%PORTDOCS%%%%DOCSDIR%%/plustek/FAQ
%%PORTDOCS%%%%DOCSDIR%%/plustek/MakeModule.sh
@@ -268,8 +278,12 @@ sbin/saned
%%NLS%%share/locale/ru/LC_MESSAGES/sane-backends.mo
%%NLS%%share/locale/sv/LC_MESSAGES/sane-backends.mo
@exec mkdir %D/share/sane
+@exec mkdir %D/share/sane/artec_eplus48u
@exec mkdir %D/share/sane/gt68xx
+@exec mkdir %D/share/sane/snapscan
+@unexec rmdir %D/share/sane/snapscan 2>/dev/null || true
@unexec rmdir %D/share/sane/gt68xx 2>/dev/null || true
+@unexec rmdir %D/share/sane/artec_eplus48u 2>/dev/null || true
@unexec rmdir %D/share/sane 2>/dev/null || true
%%PORTDOCS%%@dirrm %%DOCSDIR%%/umax
%%PORTDOCS%%@dirrm %%DOCSDIR%%/u12
@@ -277,6 +291,7 @@ sbin/saned
%%PORTDOCS%%@dirrm %%DOCSDIR%%/sceptre
%%PORTDOCS%%@dirrm %%DOCSDIR%%/plustek
%%PORTDOCS%%@dirrm %%DOCSDIR%%/niash
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/mustek_usb2
%%PORTDOCS%%@dirrm %%DOCSDIR%%/mustek_usb
%%PORTDOCS%%@dirrm %%DOCSDIR%%/mustek
%%PORTDOCS%%@dirrm %%DOCSDIR%%/matsushita