aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-im/sim-im/Makefile9
-rw-r--r--net-im/sim-im/distinfo2
-rw-r--r--net-im/sim-im/files/patch-Makefile.in11
-rw-r--r--net-im/sim-im/files/patch-configure10
-rw-r--r--net-im/sim-im/files/patch-icqssl.cpp15
-rw-r--r--net-im/sim-im/files/patch.toolsetup.h11
-rw-r--r--net-im/sim-im/pkg-plist5
-rw-r--r--net-im/simicq/Makefile9
-rw-r--r--net-im/simicq/distinfo2
-rw-r--r--net-im/simicq/files/patch-Makefile.in11
-rw-r--r--net-im/simicq/files/patch-configure10
-rw-r--r--net-im/simicq/files/patch-icqssl.cpp15
-rw-r--r--net-im/simicq/files/patch.toolsetup.h11
-rw-r--r--net-im/simicq/pkg-plist5
-rw-r--r--net/simicq/Makefile9
-rw-r--r--net/simicq/distinfo2
-rw-r--r--net/simicq/files/patch-Makefile.in11
-rw-r--r--net/simicq/files/patch-configure10
-rw-r--r--net/simicq/files/patch-icqssl.cpp15
-rw-r--r--net/simicq/files/patch.toolsetup.h11
-rw-r--r--net/simicq/pkg-plist5
21 files changed, 96 insertions, 93 deletions
diff --git a/net-im/sim-im/Makefile b/net-im/sim-im/Makefile
index 0075590883d8..0f9b1a00c2e9 100644
--- a/net-im/sim-im/Makefile
+++ b/net-im/sim-im/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= simicq
-PORTVERSION= 0.8.1
+PORTVERSION= 0.8.2
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
@@ -16,6 +16,7 @@ COMMENT= ICQ client which supports Version 8 of the ICQ protocol (ICQ 2001)
USE_GMAKE= yes
USE_QT_VER= 3
+USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
@@ -23,8 +24,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--disable-openssl
.endif
CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --disable-fast-perl \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if defined(WITHOUT_KDE)
CONFIGURE_ARGS+= --disable-kde --enable-mt
@@ -35,7 +35,8 @@ USE_KDELIBS_VER= 3
post-patch:
.if defined(WITHOUT_KDE)
- ${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
+ ${WRKSRC}/configure
.endif
.include <bsd.port.mk>
diff --git a/net-im/sim-im/distinfo b/net-im/sim-im/distinfo
index 153766d4dc89..f01b2a1b9cca 100644
--- a/net-im/sim-im/distinfo
+++ b/net-im/sim-im/distinfo
@@ -1 +1 @@
-MD5 (sim-0.8.1.tar.gz) = 5b00e474a71609f8d7e960acefcb9319
+MD5 (sim-0.8.2.tar.gz) = c04ecb5569746df71dd330d71eed89f0
diff --git a/net-im/sim-im/files/patch-Makefile.in b/net-im/sim-im/files/patch-Makefile.in
new file mode 100644
index 000000000000..612f005c1d7a
--- /dev/null
+++ b/net-im/sim-im/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Jun 22 16:38:25 2003
++++ Makefile.in Sun Jun 22 16:38:50 2003
+@@ -591,8 +591,6 @@
+ uninstall-info-recursive uninstall-recursive
+
+
+-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
+- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
+
+ $(top_srcdir)/subdirs:
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
diff --git a/net-im/sim-im/files/patch-configure b/net-im/sim-im/files/patch-configure
new file mode 100644
index 000000000000..24343e8ed633
--- /dev/null
+++ b/net-im/sim-im/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Jun 22 16:33:46 2003
++++ configure Sun Jun 22 16:33:56 2003
+@@ -25216,7 +25216,6 @@
+
+ ac_config_files="$ac_config_files ./Makefile"
+
+-ac_config_files="$ac_config_files gkrellm_plugin/Makefile"
+
+ ac_config_files="$ac_config_files pict/Makefile"
+
diff --git a/net-im/sim-im/files/patch-icqssl.cpp b/net-im/sim-im/files/patch-icqssl.cpp
deleted file mode 100644
index 0b19f0ed6573..000000000000
--- a/net-im/sim-im/files/patch-icqssl.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
-
---- sim/libicq/icqssl.cpp.orig Wed Mar 12 14:20:53 2003
-+++ sim/libicq/icqssl.cpp Wed Mar 12 14:21:08 2003
-@@ -151,7 +151,7 @@
- #else
- SSL_CTX_set_cipher_list(gSSL_CTX, "ADH");
- #endif
-- SSL_CTX_set_info_callback(gSSL_CTX, (void (*)())ssl_info_callback);
-+ SSL_CTX_set_info_callback(gSSL_CTX, (void (*)(const SSL*, int, int))ssl_info_callback);
- DH *dh = get_dh512();
- SSL_CTX_set_tmp_dh(gSSL_CTX, dh);
- DH_free(dh);
-
-
-
diff --git a/net-im/sim-im/files/patch.toolsetup.h b/net-im/sim-im/files/patch.toolsetup.h
deleted file mode 100644
index 55d95022f6cf..000000000000
--- a/net-im/sim-im/files/patch.toolsetup.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- toolsetup.h.old Tue Dec 17 13:25:36 2002
-+++ toolsetup.h Tue Dec 17 13:57:26 2002
-@@ -23,7 +23,7 @@
- #include "toolsetupbase.h"
- #include "toolbtn.h"
-
--class ToolBarSetup : public ToolBarSetupBase
-+class ToolBarSetup : ToolBarSetupBase
- {
- Q_OBJECT
- public:
diff --git a/net-im/sim-im/pkg-plist b/net-im/sim-im/pkg-plist
index 289d4b965f4b..5189a20c6bd9 100644
--- a/net-im/sim-im/pkg-plist
+++ b/net-im/sim-im/pkg-plist
@@ -1,16 +1,21 @@
bin/sim
bin/simctrl
+lib/menu/sim-kde.menu
share/applnk/Internet/sim.desktop
share/icons/locolor/32x32/apps/sim.png
share/icons/locolor/16x16/apps/sim.png
share/icons/hicolor/16x16/apps/sim.png
share/icons/hicolor/32x32/apps/sim.png
+share/locale/bg/LC_MESSAGES/sim.mo
share/locale/cs/LC_MESSAGES/sim.mo
share/locale/de/LC_MESSAGES/sim.mo
share/locale/es/LC_MESSAGES/sim.mo
+share/locale/he/LC_MESSAGES/sim.mo
+share/locale/fr/LC_MESSAGES/sim.mo
share/locale/it/LC_MESSAGES/sim.mo
share/locale/nl/LC_MESSAGES/sim.mo
share/locale/pl/LC_MESSAGES/sim.mo
+share/locale/sk/LC_MESSAGES/sim.mo
share/locale/ru/LC_MESSAGES/sim.mo
share/locale/tr/LC_MESSAGES/sim.mo
share/locale/uk/LC_MESSAGES/sim.mo
diff --git a/net-im/simicq/Makefile b/net-im/simicq/Makefile
index 0075590883d8..0f9b1a00c2e9 100644
--- a/net-im/simicq/Makefile
+++ b/net-im/simicq/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= simicq
-PORTVERSION= 0.8.1
+PORTVERSION= 0.8.2
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
@@ -16,6 +16,7 @@ COMMENT= ICQ client which supports Version 8 of the ICQ protocol (ICQ 2001)
USE_GMAKE= yes
USE_QT_VER= 3
+USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
@@ -23,8 +24,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--disable-openssl
.endif
CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --disable-fast-perl \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if defined(WITHOUT_KDE)
CONFIGURE_ARGS+= --disable-kde --enable-mt
@@ -35,7 +35,8 @@ USE_KDELIBS_VER= 3
post-patch:
.if defined(WITHOUT_KDE)
- ${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
+ ${WRKSRC}/configure
.endif
.include <bsd.port.mk>
diff --git a/net-im/simicq/distinfo b/net-im/simicq/distinfo
index 153766d4dc89..f01b2a1b9cca 100644
--- a/net-im/simicq/distinfo
+++ b/net-im/simicq/distinfo
@@ -1 +1 @@
-MD5 (sim-0.8.1.tar.gz) = 5b00e474a71609f8d7e960acefcb9319
+MD5 (sim-0.8.2.tar.gz) = c04ecb5569746df71dd330d71eed89f0
diff --git a/net-im/simicq/files/patch-Makefile.in b/net-im/simicq/files/patch-Makefile.in
new file mode 100644
index 000000000000..612f005c1d7a
--- /dev/null
+++ b/net-im/simicq/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Jun 22 16:38:25 2003
++++ Makefile.in Sun Jun 22 16:38:50 2003
+@@ -591,8 +591,6 @@
+ uninstall-info-recursive uninstall-recursive
+
+
+-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
+- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
+
+ $(top_srcdir)/subdirs:
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
diff --git a/net-im/simicq/files/patch-configure b/net-im/simicq/files/patch-configure
new file mode 100644
index 000000000000..24343e8ed633
--- /dev/null
+++ b/net-im/simicq/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Jun 22 16:33:46 2003
++++ configure Sun Jun 22 16:33:56 2003
+@@ -25216,7 +25216,6 @@
+
+ ac_config_files="$ac_config_files ./Makefile"
+
+-ac_config_files="$ac_config_files gkrellm_plugin/Makefile"
+
+ ac_config_files="$ac_config_files pict/Makefile"
+
diff --git a/net-im/simicq/files/patch-icqssl.cpp b/net-im/simicq/files/patch-icqssl.cpp
deleted file mode 100644
index 0b19f0ed6573..000000000000
--- a/net-im/simicq/files/patch-icqssl.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
-
---- sim/libicq/icqssl.cpp.orig Wed Mar 12 14:20:53 2003
-+++ sim/libicq/icqssl.cpp Wed Mar 12 14:21:08 2003
-@@ -151,7 +151,7 @@
- #else
- SSL_CTX_set_cipher_list(gSSL_CTX, "ADH");
- #endif
-- SSL_CTX_set_info_callback(gSSL_CTX, (void (*)())ssl_info_callback);
-+ SSL_CTX_set_info_callback(gSSL_CTX, (void (*)(const SSL*, int, int))ssl_info_callback);
- DH *dh = get_dh512();
- SSL_CTX_set_tmp_dh(gSSL_CTX, dh);
- DH_free(dh);
-
-
-
diff --git a/net-im/simicq/files/patch.toolsetup.h b/net-im/simicq/files/patch.toolsetup.h
deleted file mode 100644
index 55d95022f6cf..000000000000
--- a/net-im/simicq/files/patch.toolsetup.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- toolsetup.h.old Tue Dec 17 13:25:36 2002
-+++ toolsetup.h Tue Dec 17 13:57:26 2002
-@@ -23,7 +23,7 @@
- #include "toolsetupbase.h"
- #include "toolbtn.h"
-
--class ToolBarSetup : public ToolBarSetupBase
-+class ToolBarSetup : ToolBarSetupBase
- {
- Q_OBJECT
- public:
diff --git a/net-im/simicq/pkg-plist b/net-im/simicq/pkg-plist
index 289d4b965f4b..5189a20c6bd9 100644
--- a/net-im/simicq/pkg-plist
+++ b/net-im/simicq/pkg-plist
@@ -1,16 +1,21 @@
bin/sim
bin/simctrl
+lib/menu/sim-kde.menu
share/applnk/Internet/sim.desktop
share/icons/locolor/32x32/apps/sim.png
share/icons/locolor/16x16/apps/sim.png
share/icons/hicolor/16x16/apps/sim.png
share/icons/hicolor/32x32/apps/sim.png
+share/locale/bg/LC_MESSAGES/sim.mo
share/locale/cs/LC_MESSAGES/sim.mo
share/locale/de/LC_MESSAGES/sim.mo
share/locale/es/LC_MESSAGES/sim.mo
+share/locale/he/LC_MESSAGES/sim.mo
+share/locale/fr/LC_MESSAGES/sim.mo
share/locale/it/LC_MESSAGES/sim.mo
share/locale/nl/LC_MESSAGES/sim.mo
share/locale/pl/LC_MESSAGES/sim.mo
+share/locale/sk/LC_MESSAGES/sim.mo
share/locale/ru/LC_MESSAGES/sim.mo
share/locale/tr/LC_MESSAGES/sim.mo
share/locale/uk/LC_MESSAGES/sim.mo
diff --git a/net/simicq/Makefile b/net/simicq/Makefile
index 0075590883d8..0f9b1a00c2e9 100644
--- a/net/simicq/Makefile
+++ b/net/simicq/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= simicq
-PORTVERSION= 0.8.1
+PORTVERSION= 0.8.2
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/mi/m-i/}
@@ -16,6 +16,7 @@ COMMENT= ICQ client which supports Version 8 of the ICQ protocol (ICQ 2001)
USE_GMAKE= yes
USE_QT_VER= 3
+USE_PERL5_BUILD= yes
GNU_CONFIGURE= yes
.if !defined(WITHOUT_SSL)
USE_OPENSSL= yes
@@ -23,8 +24,7 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--disable-openssl
.endif
CONFIGURE_TARGET=
-CONFIGURE_ARGS+= --disable-fast-perl \
- --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if defined(WITHOUT_KDE)
CONFIGURE_ARGS+= --disable-kde --enable-mt
@@ -35,7 +35,8 @@ USE_KDELIBS_VER= 3
post-patch:
.if defined(WITHOUT_KDE)
- ${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s,qtlib=\"qt\",qtlib=\"qt-mt -pthread\"," \
+ ${WRKSRC}/configure
.endif
.include <bsd.port.mk>
diff --git a/net/simicq/distinfo b/net/simicq/distinfo
index 153766d4dc89..f01b2a1b9cca 100644
--- a/net/simicq/distinfo
+++ b/net/simicq/distinfo
@@ -1 +1 @@
-MD5 (sim-0.8.1.tar.gz) = 5b00e474a71609f8d7e960acefcb9319
+MD5 (sim-0.8.2.tar.gz) = c04ecb5569746df71dd330d71eed89f0
diff --git a/net/simicq/files/patch-Makefile.in b/net/simicq/files/patch-Makefile.in
new file mode 100644
index 000000000000..612f005c1d7a
--- /dev/null
+++ b/net/simicq/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sun Jun 22 16:38:25 2003
++++ Makefile.in Sun Jun 22 16:38:50 2003
+@@ -591,8 +591,6 @@
+ uninstall-info-recursive uninstall-recursive
+
+
+-$(top_srcdir)/configure.in: configure.in.in $(top_srcdir)/subdirs
+- cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common configure.in ;
+
+ $(top_srcdir)/subdirs:
+ cd $(top_srcdir) && $(MAKE) -f admin/Makefile.common subdirs
diff --git a/net/simicq/files/patch-configure b/net/simicq/files/patch-configure
new file mode 100644
index 000000000000..24343e8ed633
--- /dev/null
+++ b/net/simicq/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Sun Jun 22 16:33:46 2003
++++ configure Sun Jun 22 16:33:56 2003
+@@ -25216,7 +25216,6 @@
+
+ ac_config_files="$ac_config_files ./Makefile"
+
+-ac_config_files="$ac_config_files gkrellm_plugin/Makefile"
+
+ ac_config_files="$ac_config_files pict/Makefile"
+
diff --git a/net/simicq/files/patch-icqssl.cpp b/net/simicq/files/patch-icqssl.cpp
deleted file mode 100644
index 0b19f0ed6573..000000000000
--- a/net/simicq/files/patch-icqssl.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
-
---- sim/libicq/icqssl.cpp.orig Wed Mar 12 14:20:53 2003
-+++ sim/libicq/icqssl.cpp Wed Mar 12 14:21:08 2003
-@@ -151,7 +151,7 @@
- #else
- SSL_CTX_set_cipher_list(gSSL_CTX, "ADH");
- #endif
-- SSL_CTX_set_info_callback(gSSL_CTX, (void (*)())ssl_info_callback);
-+ SSL_CTX_set_info_callback(gSSL_CTX, (void (*)(const SSL*, int, int))ssl_info_callback);
- DH *dh = get_dh512();
- SSL_CTX_set_tmp_dh(gSSL_CTX, dh);
- DH_free(dh);
-
-
-
diff --git a/net/simicq/files/patch.toolsetup.h b/net/simicq/files/patch.toolsetup.h
deleted file mode 100644
index 55d95022f6cf..000000000000
--- a/net/simicq/files/patch.toolsetup.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- toolsetup.h.old Tue Dec 17 13:25:36 2002
-+++ toolsetup.h Tue Dec 17 13:57:26 2002
-@@ -23,7 +23,7 @@
- #include "toolsetupbase.h"
- #include "toolbtn.h"
-
--class ToolBarSetup : public ToolBarSetupBase
-+class ToolBarSetup : ToolBarSetupBase
- {
- Q_OBJECT
- public:
diff --git a/net/simicq/pkg-plist b/net/simicq/pkg-plist
index 289d4b965f4b..5189a20c6bd9 100644
--- a/net/simicq/pkg-plist
+++ b/net/simicq/pkg-plist
@@ -1,16 +1,21 @@
bin/sim
bin/simctrl
+lib/menu/sim-kde.menu
share/applnk/Internet/sim.desktop
share/icons/locolor/32x32/apps/sim.png
share/icons/locolor/16x16/apps/sim.png
share/icons/hicolor/16x16/apps/sim.png
share/icons/hicolor/32x32/apps/sim.png
+share/locale/bg/LC_MESSAGES/sim.mo
share/locale/cs/LC_MESSAGES/sim.mo
share/locale/de/LC_MESSAGES/sim.mo
share/locale/es/LC_MESSAGES/sim.mo
+share/locale/he/LC_MESSAGES/sim.mo
+share/locale/fr/LC_MESSAGES/sim.mo
share/locale/it/LC_MESSAGES/sim.mo
share/locale/nl/LC_MESSAGES/sim.mo
share/locale/pl/LC_MESSAGES/sim.mo
+share/locale/sk/LC_MESSAGES/sim.mo
share/locale/ru/LC_MESSAGES/sim.mo
share/locale/tr/LC_MESSAGES/sim.mo
share/locale/uk/LC_MESSAGES/sim.mo
d> * Update to 20170806sunpoet2017-08-082-4/+4 * Update to 5.3.5.jkim2017-08-041-5/+5 * Update to 20170729sunpoet2017-07-313-8/+9 * Update to 20170716sunpoet2017-07-182-4/+4 * Update to 20170709sunpoet2017-07-112-4/+4 * Update to 20170702sunpoet2017-07-032-4/+4 * Update devel/readline to 7.0 patch 3sunpoet2017-06-272-2/+2 * Update to 20170625sunpoet2017-06-262-4/+4 * Update to 5.3.4.jkim2017-06-221-5/+5 * Update to 20170618sunpoet2017-06-202-4/+4 * Update the Calligra ports to 3.0.1.rakuco2017-06-175-91/+0 * Update to 20170611sunpoet2017-06-142-4/+4 * Update to 20170604sunpoet2017-06-052-4/+4 * - Add LICENSE informationpawel2017-06-012-11/+16 * Update to 20170528sunpoet2017-05-292-4/+4 * Update to 20170521sunpoet2017-05-232-4/+4 * Update to version 0.2.3pawel2017-05-205-7/+37 * Update to 5.3.3.jkim2017-05-201-5/+5 * Update to 20170514sunpoet2017-05-152-4/+4 * Prepare the removal of x11-toolkits/qt5-declarativetcberner2017-05-151-2/+2 * Fix segfault on program exitpawel2017-05-122-1/+13 * Update to 20170505sunpoet2017-05-082-4/+4 * Update to 5.2.7.jkim2017-05-051-5/+5 * Update to 20170430sunpoet2017-05-032-4/+4 * Chase ffmpeg 3.3 update (ABI changes)riggs2017-04-252-1/+2 * Update to 20170416sunpoet2017-04-182-4/+4 * Rename the magic DISTVERSION into SPELLVERSION for the aspell ports.mat2017-04-121-1/+1 * Update to 20170402sunpoet2017-04-032-4/+4 * Bump PORTREVISIONs for ports depending on the canonical version of GCC andgerald2017-04-012-0/+2 * Update to 5.2.6.jkim2017-03-281-5/+5 * - Update to 20170305sunpoet2017-03-062-4/+4 * - Add LICENSEamdmi32017-03-021-4/+7 * - Update to 20170212sunpoet2017-02-142-4/+4 * Update to 5.2.5.jkim2017-02-011-5/+5 * Update to version 4.3pawel2017-01-283-6/+45 * - Update to version 1.12.2pawel2017-01-283-5/+5 * Update to 20170115sunpoet2017-01-162-4/+4 * Assume "pkg-config zlib" works after 9.x reached EOLjbeich2017-01-041-2/+0 * Update to 5.2.4.jkim2017-01-021-5/+5 * - Update to 20161216sunpoet2016-12-172-4/+4 * Remove libintl.so.9 compatibility link that was added in r374303 totijl2016-12-091-1/+1 * Fix build on FreeBSD 10.1 by disabling build of some tests usingpawel2016-12-071-0/+2 * - Update to version 4.2pawel2016-12-0611-616/+1394 * Switch to GnuTLS for secure connections, it's upstream firstpawel2016-12-062-26/+4 * - Update to version 20091121, now in UTF8 formatpawel2016-11-284-45/+89 * Update security/gpgme-* to 1.8.0jhale2016-11-271-1/+1 * - Update to 20161111sunpoet2016-11-212-3/+4 * - Update to version 0.2.2pawel2016-11-122-5/+8 * Update libreoffice to 5.2.3 and liborcus to 0.11.2bapt2016-11-121-4/+5 * Use USES=pathfix where applicable.mat2016-10-212-3/+2 * polish/fortunepl: uncomment BROKENmarino2016-09-201-1/+1 * polish/fortunepl: Once again, mark this port BROKEN (unfetchable)marino2016-09-201-0/+2 * Revert recent strfile changes, strfile is already in baseantoine2016-09-151-10/+10 * GOOGLE_CODE has gone away.mat2016-09-141-1/+0 * polish/fortunepl: Use fortune_strfile instead of strfile(8) and mark BROKENmarino2016-09-141-10/+10 * polish/libgadu: Handle missing SSLv3 method for LibreSSLmarino2016-09-122-1/+15 * - Update to version 1.1.0pawel2016-07-241-0/+1 * Many KDE i10n ports: Patch updates CURDIRpi2016-05-261-1/+1 * editors/calligra-l10n: add plist-subpi2016-05-242-72/+72 * Convert tab after WWW: in pkg-descrs to single space as per PHBamdmi32016-05-241-1/+1 * - Fix trailing whitespace in pkg-descrs, categories [p-x]*amdmi32016-05-192-2/+2 * Update to 5.0.6.jkim2016-05-071-4/+4 * Remove ${PORTSDIR}/ from dependencies, categories m, n, o, and p.mat2016-04-017-37/+37 * Add missing items to the calligra-l10n ports plists.rakuco2016-03-292-0/+2 * - Update security/gnutls to 3.4.10.tijl2016-03-271-1/+1 * - Add LICENSE_FILEamdmi32016-03-161-4/+2 * Always set the DEFAULT github DISTFILE with .tar.gz for EXTRACT_SUFX.mat2016-03-081-2/+2 * - Makefile.local for slave ports is included by bsd.port.mk r397519dinoex2016-02-281-4/+0 * Update to version 0.2.1pawel2016-02-272-5/+7 * - Explicitly specify version for libotr.so to differentiate security/libotr a...amdmi32016-02-251-1/+1 * Update to 5.0.5.jkim2016-02-161-4/+4 * Update Calligra to 2.9.11.rakuco2016-02-092-3/+2 * polish/ekg: document ncurses requirement (USES+=ncurses)marino2016-02-061-2/+2 * Add upstream patch to fix the build with the upcoming Qt 5.5.1.rakuco2016-01-211-0/+112 * Convert LICENSE= "GPLxx # or later" to "GPLxx+"amdmi32016-01-131-1/+1 * Fix library dependency.bdrewery2016-01-081-2/+3 * Update Calligra to 2.9.10.rakuco2015-12-223-26/+38 * Update to 5.0.4.jkim2015-12-181-4/+4 * Switch to options helperpawel2015-12-121-6/+2 * - Switch to USES=shebangfixpawel2015-12-121-9/+3 * Update to version 0.2.0pawel2015-11-253-7/+8 * - Switch to options helpersamdmi32015-11-131-0/+2 * - Add LICENSEamdmi32015-11-131-1/+3 * - Fix build with gcc 4.9 [1]pawel2015-11-112-5/+12 * Update to 5.0.3.jkim2015-11-041-4/+4 * - Update to 20150428sunpoet2015-10-272-3/+3 * Update to 5.0.2.jkim2015-09-242-6/+6 * Remove the autodetect optionbapt2015-09-132-101/+34 * Update LibreOffice to 5.0.1.jkim2015-09-021-4/+4 * Update to version 0.1.9pawel2015-08-273-40/+6 * - Update to version 1.8, now Qt5 basedpawel2015-08-175-73/+50 * - Update to version 2.1, now Qt5 basedpawel2015-07-248-86/+244 * - Add NO_ARCHsunpoet2015-07-181-0/+1 * - Add NO_ARCHsunpoet2015-07-181-0/+1 * - Add NO_ARCHsunpoet2015-07-181-0/+1 * - Strip librariesamdmi32015-06-011-1/+2 * - Strip libraryamdmi32015-05-161-1/+3 * Cleanup DIST* variables.mat2015-05-122-4/+3 * USE_GITHUB: For the new support, fix DISTNAME to be more consistent.bdrewery2015-04-291-2/+2 * - Update to 20150426sunpoet2015-04-272-3/+3 * Update to 4.3.7.jkim2015-04-261-4/+4 * - Update to 20150419sunpoet2015-04-222-3/+3 * - Update to 20150405sunpoet2015-04-062-3/+3 * Convert to new USE_GITHUBpawel2015-04-042-3/+2 * - Update to 20150329sunpoet2015-03-302-3/+3 * - Update to 20150322sunpoet2015-03-242-3/+3 * - Update to 20150315sunpoet2015-03-172-3/+3 * Update KDE SC to 4.14.3alonso2015-03-122-2/+3 * - Update to 20150308sunpoet2015-03-102-3/+3 * - Update to 20150301sunpoet2015-03-032-3/+3 * - Update to 20150222sunpoet2015-02-242-3/+3 * - Update to 4.3.6.jkim2015-02-211-4/+4 * - Remove deprecated USE_KDE4=kdehiermakc2015-02-201-1/+1 * Unbreak on headantoine2015-02-151-11/+6 * Update to version 1.5pawel2015-01-212-4/+3 * - Update to 20150111sunpoet2015-01-132-3/+3 * - Update devel/qca to version 2.1.0tijl2015-01-131-1/+1 * - Update to 20150104sunpoet2015-01-062-3/+3 * - Convert <OPTION>_USE= PYTHON... to <OPTION>_USES= python...mva2015-01-031-1/+1 * Update to version 1.4pawel2015-01-012-4/+4 * - Update to version 1.12.1pawel2015-01-012-11/+6 * CMake 3.1.0 compatibility, take 2.rakuco2015-01-011-0/+37 * Revert r375855 for now.rakuco2014-12-311-29/+0 * Add a patch (submitted upstream) to make the port build with CMake 3.1.0.rakuco2014-12-311-0/+29 * - Update to 20141221sunpoet2014-12-242-3/+3 * cleanup plistbapt2014-12-213-3/+0 * Update to 4.3.5.jkim2014-12-191-4/+4 * - Update to version 1.3pawel2014-12-139-85/+3 * - Update to 20141207sunpoet2014-12-092-3/+3 * - Update polish/kadu to version 1.2pawel2014-12-0613-255/+723 * Update to 4.3.4.jkim2014-11-271-4/+4 * Change the way Perl modules are installed, update the default Perl to 5.18.mat2014-11-262-8/+5 * - Update to 20141123sunpoet2014-11-25