aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/fusefs-simple-mtpfs/Makefile19
-rw-r--r--sysutils/fusefs-simple-mtpfs/files/special_simple-mtpfs.in2
2 files changed, 11 insertions, 10 deletions
diff --git a/sysutils/fusefs-simple-mtpfs/Makefile b/sysutils/fusefs-simple-mtpfs/Makefile
index c441f099d3c3..cbd58c21c62a 100644
--- a/sysutils/fusefs-simple-mtpfs/Makefile
+++ b/sysutils/fusefs-simple-mtpfs/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simple-mtpfs
PORTVERSION= 0.2.s20140709
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
PKGNAMEPREFIX= fusefs-
@@ -18,14 +18,13 @@ GH_ACCOUNT= phatina
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 74dfce6
-USES= compiler:c++11-lib fuse pkgconfig
-USE_AUTOTOOLS= aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= --add-missing
+USES= autoreconf compiler:c++11-lib fuse pkgconfig
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules
MAKEFILE= makefile
-MAKE_ENV= V=1
INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz
PORTDOCS= AUTHORS NEWS README.md
@@ -36,9 +35,10 @@ OPTIONS_DEFINE= DOCS
CONFIGURE_ENV+= LIBUSB1_CFLAGS=" " LIBUSB1_LIBS="-lusb"
.endif
+# XXX move to PREFIX when bug 193596 lands
.if exists(/etc/autofs)
-PLIST_FILES+= /etc/autofs/special_simple-mtpfs
-SUB_FILES+= special_simple-mtpfs
+PLIST_FILES+= /etc/autofs/special_${PORTNAME}
+SUB_FILES+= special_${PORTNAME}
.endif
post-install:
@@ -46,7 +46,8 @@ post-install:
${INSTALL_DATA} ${PORTDOCS:C|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.if exists(/etc/autofs)
@${MKDIR} ${STAGEDIR}/etc/autofs
- ${INSTALL_SCRIPT} ${WRKDIR}/special_simple-mtpfs ${STAGEDIR}/etc/autofs
+ ${INSTALL_SCRIPT} ${WRKDIR}/special_${PORTNAME} \
+ ${STAGEDIR}/etc/autofs
.endif
.include <bsd.port.mk>
diff --git a/sysutils/fusefs-simple-mtpfs/files/special_simple-mtpfs.in b/sysutils/fusefs-simple-mtpfs/files/special_simple-mtpfs.in
index 98510240689f..7f45b8649e53 100644
--- a/sysutils/fusefs-simple-mtpfs/files/special_simple-mtpfs.in
+++ b/sysutils/fusefs-simple-mtpfs/files/special_simple-mtpfs.in
@@ -4,7 +4,7 @@
# /mtp -simple-mtpfs -allow_other
#
-out=$(%%PREFIX%%/bin/simple-mtpfs --list-devices 2>&1)
+out=$(%%PREFIX%%/bin/simple-mtpfs --list-devices)
[ $? -eq 0 ] || exit 1
if [ $# -eq 0 ]; then