aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/recoverjpeg/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/graphics/recoverjpeg/Makefile b/graphics/recoverjpeg/Makefile
index 103860953453..ec04227a19e3 100644
--- a/graphics/recoverjpeg/Makefile
+++ b/graphics/recoverjpeg/Makefile
@@ -12,34 +12,32 @@ COMMENT= Recoverjpeg tries to recover JFIF (JPEG) pictures from a peripheral
LICENSE= GPLv2
GNU_CONFIGURE= yes
-MANCOMPRESSED= no
-PLIST_FILES= bin/recoverjpeg
MAN1= recoverjpeg.1
+PLIST_FILES= bin/recoverjpeg man/man1/recoverjpeg.1.gz
# recoverjpeg scripts require many dependencies
OPTIONS_DEFINE= SSCRIPTS
SSCRIPTS_DESC= Install sort-pictures script
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSCRIPTS}
RUN_DEPENDS= exif:${PORTSDIR}/graphics/exif \
identify:${PORTSDIR}/graphics/ImageMagick
-PLIST_FILES+= bin/sort-pictures
+PLIST_FILES+= bin/sort-pictures man/man1/sort-pictures.1.gz
MAN1+= sort-pictures.1
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MSSCRIPTS}
.for f in sort-pictures
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
.endif
.for f in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/${f} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>