aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--archivers/innoextract/Makefile5
-rw-r--r--archivers/libcabinet/Makefile2
-rw-r--r--archivers/tclmkziplib/Makefile2
-rw-r--r--astro/cfitsio/Makefile2
-rw-r--r--audio/festival/Makefile10
-rw-r--r--audio/festival/pkg-descr2
-rw-r--r--audio/gnuspeechsa/Makefile1
-rw-r--r--audio/musescore/Makefile2
-rw-r--r--audio/vsound/Makefile2
-rw-r--r--audio/xmcd/Makefile3
-rw-r--r--cad/irsim/Makefile2
-rw-r--r--comms/linrad/Makefile2
-rw-r--r--comms/mgetty+sendfax/Makefile3
-rw-r--r--comms/xnec2c/Makefile2
-rw-r--r--converters/wkhtmltopdf/Makefile7
15 files changed, 38 insertions, 9 deletions
diff --git a/archivers/innoextract/Makefile b/archivers/innoextract/Makefile
index 2de69c3f8f61..d561c3ea283d 100644
--- a/archivers/innoextract/Makefile
+++ b/archivers/innoextract/Makefile
@@ -12,8 +12,6 @@ COMMENT= Program to extract Inno Setup files
LICENSE= ZLIB
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs \
libboost_filesystem.so:devel/boost-libs \
libboost_system.so:devel/boost-libs \
@@ -25,4 +23,7 @@ CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=man
PLIST_FILES= bin/innoextract \
man/man1/innoextract.1.gz
+BROKEN_powerpc64= Does not build
+BROKEN_sparc64= Does not build: undefined reference to std::ctype<char>::_M_widen_init()
+
.include <bsd.port.mk>
diff --git a/archivers/libcabinet/Makefile b/archivers/libcabinet/Makefile
index f9992816d613..1a5bd261008e 100644
--- a/archivers/libcabinet/Makefile
+++ b/archivers/libcabinet/Makefile
@@ -12,6 +12,8 @@ COMMENT= Portable library and utility to use Microsoft cabinet files (.cab)
USE_LDCONFIG= yes
+BROKEN_aarch64= Fails to link: linker command failed with exit code 1
+
USES= uidfix
SRCFILE= ${WRKSRC}/listcab.cpp
PROGFILE= ${SRCFILE:S/.cpp$//}
diff --git a/archivers/tclmkziplib/Makefile b/archivers/tclmkziplib/Makefile
index 29a3a684f594..dce187e511c8 100644
--- a/archivers/tclmkziplib/Makefile
+++ b/archivers/tclmkziplib/Makefile
@@ -11,6 +11,8 @@ DISTNAME= mkZiplib${PORTVERSION:S/.//}
MAINTAINER= tcltk@FreeBSD.org
COMMENT= GZIP and ZIP support for TCL; dynamically loadable
+BROKEN_aarch64= Fails to build: error: operand of type va_list where arithmetic or pointer type is required
+
USES+= tcl zip
WRKSRC= ${WRKDIR}/mkZiplib${PORTVERSION}
diff --git a/astro/cfitsio/Makefile b/astro/cfitsio/Makefile
index 0ed54e695a12..9075be7f6270 100644
--- a/astro/cfitsio/Makefile
+++ b/astro/cfitsio/Makefile
@@ -35,6 +35,8 @@ PORTDOCS= *
SHLIB_MAJOR_VER=5
SHLIB_MINOR_VER=${PORTVERSION:S|0$||}
+BROKEN_sparc64= Fails to compile: malloc.h has been replaced by stdlib.h
+
do-install:
cd ${WRKSRC}/ && ${INSTALL_DATA} drvrsmem.h fitsio.h fitsio2.h longnam.h ${STAGEDIR}${PREFIX}/include/
cd ${WRKSRC}/ && ${INSTALL_DATA} libcfitsio.a ${STAGEDIR}${PREFIX}/lib/
diff --git a/audio/festival/Makefile b/audio/festival/Makefile
index 2494d0430a0c..450682db9b7c 100644
--- a/audio/festival/Makefile
+++ b/audio/festival/Makefile
@@ -7,6 +7,7 @@ CATEGORIES= audio accessibility
MASTER_SITES= FESTIVAL
DISTFILES= ${DISTNAME}-release.tar.gz \
speech_tools-${PORTVERSION}-release.tar.gz
+DIST_SUBDIR= festival
PATCHFILES= src_modules_diphone_diphone.h.diff?id=b58a836:debian \
src_modules_diphone_di_io.cc.diff?id=b58a836:debian \
@@ -24,12 +25,15 @@ PATCH_SITES= ftp://ftp.netbsd.org/pub/pkgsrc/current/pkgsrc/audio/festival/patch
MAINTAINER= mi@aldan.algebra.com
COMMENT= Multi-lingual speech synthesis system
+BROKEN_aarch64= XXX
+BROKEN_armv6= Fails to link: cc.mak: No such file or directory
+BROKEN_mips64= Fails to link: cc.mak: No such file or directory
+BROKEN_powerpc64= Does not build
+
OPTIONS_DEFINE= NAS ESD
OPTIONS_DEFAULT=NAS ESD
ESD_DESC= ${ESOUND_DESC}
-DIST_SUBDIR= festival
-
CXXFLAGS+= -DFTLIBDIR=${LOCALBASE}/share/festival/lib
CONFIGURE_WRKSRC= ${WRKDIR}/festival
USES= gmake
@@ -43,8 +47,6 @@ WRKSRC= ${WRKDIR}
SPT_PATCHES= include_ling__class_EST__FeatureFunctionPackage.h \
include_unix_EST__socket__unix.h
-BROKEN_powerpc64= Does not build
-
do-build:
.for d in speech_tools festival
${MAKE_CMD} -C ${WRKDIR}/$d ${MAKE_FLAGS} Makefile ${MAKE_ARGS}
diff --git a/audio/festival/pkg-descr b/audio/festival/pkg-descr
index f3ce17acd94b..2282e42663bd 100644
--- a/audio/festival/pkg-descr
+++ b/audio/festival/pkg-descr
@@ -15,6 +15,6 @@ manual.
If you need the OGI extensions, install ports/audio/festival+OGI instead.
-WWW: http://www.cstr.ed.ac.uk/projects/festival/
+WWW: http://www.cstr.ed.ac.uk/projects/festival/
Trevor Johnson
diff --git a/audio/gnuspeechsa/Makefile b/audio/gnuspeechsa/Makefile
index 05b72f9861f1..cea96b069ecf 100644
--- a/audio/gnuspeechsa/Makefile
+++ b/audio/gnuspeechsa/Makefile
@@ -13,6 +13,7 @@ LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_FreeBSD_9= does not build
+BROKEN_aarch64= Does not build: the clang compiler does not support -march=native
BROKEN_powerpc64= Does not build
USES= cmake compiler:c++11-lib
diff --git a/audio/musescore/Makefile b/audio/musescore/Makefile
index c5595f4dcca7..4c40ea1c5f25 100644
--- a/audio/musescore/Makefile
+++ b/audio/musescore/Makefile
@@ -26,6 +26,8 @@ ALL_TARGET= lrelease manpages all
DATADIR= ${PREFIX}/share/mscore-${PORTVERSION:R}
+BROKEN_aarch64= Fails to compile: error: constant expression evaluates to -1
+
OPTIONS_DEFINE= ALSA JACK PORTAUDIO PULSEAUDIO
OPTIONS_DEFAULT= PORTAUDIO
diff --git a/audio/vsound/Makefile b/audio/vsound/Makefile
index aa24fe81a5cc..17872fad0d59 100644
--- a/audio/vsound/Makefile
+++ b/audio/vsound/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= sox:audio/sox
USES= alias libtool
GNU_CONFIGURE= yes
+BROKEN_aarch64= Fails to build: error: Cannot determine endian-ness of processor
+
OPTIONS_DEFINE= DOCS
post-install:
diff --git a/audio/xmcd/Makefile b/audio/xmcd/Makefile
index b9b61c5a3487..e5fa3a7cb284 100644
--- a/audio/xmcd/Makefile
+++ b/audio/xmcd/Makefile
@@ -22,6 +22,9 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
LIBBINDIR= ${STAGEDIR}${PREFIX}/lib/X11/xmcd/bin-${OPSYS}_${OSREL:R:R}-${ARCH}
+BROKEN_aarch64= Fails to compile: many undefined symbols in xorg.cf
+BROKEN_armv6= Fails to compile: many undefined symbols in xorg.cf
+BROKEN_mips64= Fails to compile: many undefined symbols in xorg.cf
BROKEN_powerpc64= Does not build on powerpc64
pre-patch:
diff --git a/cad/irsim/Makefile b/cad/irsim/Makefile
index 5e2323618200..d83cf0be8aa6 100644
--- a/cad/irsim/Makefile
+++ b/cad/irsim/Makefile
@@ -31,6 +31,8 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+BROKEN_aarch64= Fails to link: missing sbrk
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MTCL}
diff --git a/comms/linrad/Makefile b/comms/linrad/Makefile
index 95d993077546..d8c2063de89e 100644
--- a/comms/linrad/Makefile
+++ b/comms/linrad/Makefile
@@ -32,6 +32,8 @@ LINRAD_DOCFILES= z_APM.txt z_BUFFERS.txt z_CALIBRATE.txt \
z_PARALLEL_PORT.txt z_SETTINGS.txt \
z_USERS_EXTRA.txt z_USERS_HWARE.txt
+BROKEN_sparc64= Fails to compile: implicit declaration of function outb
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
BINFILE= xlinrad
diff --git a/comms/mgetty+sendfax/Makefile b/comms/mgetty+sendfax/Makefile
index 8f9de9ecaab4..863c67b00242 100644
--- a/comms/mgetty+sendfax/Makefile
+++ b/comms/mgetty+sendfax/Makefile
@@ -26,6 +26,9 @@ CFLAGS+= -DAUTO_PPP
MAKE_JOBS_UNSAFE= yes
+BROKEN_aarch64= Fails to compile: error: initializer element is not a compile-time constant
+BROKEN_mips64= Fails to compile: error: initializer element is not a compile-time constant
+
OPTIONS_DEFINE= FIDO
FIDO_DESC= Enable FIDO EMSI support
FIDO_CFLAGS= -DFIDO
diff --git a/comms/xnec2c/Makefile b/comms/xnec2c/Makefile
index e657c8f2127b..d915875a314b 100644
--- a/comms/xnec2c/Makefile
+++ b/comms/xnec2c/Makefile
@@ -21,6 +21,8 @@ USE_GNOME= gtk20 intltool
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
+BROKEN_sparc64= Fails to link: relocation truncated to fit: R_SPARC_GOT13 against symbol input_fp
+
post-extract:
${CP} ${PATCHDIR}/clog.c ${WRKSRC}/src
${TOUCH} ${WRKSRC}/src/cexp.c
diff --git a/converters/wkhtmltopdf/Makefile b/converters/wkhtmltopdf/Makefile
index 2625b340bbee..be09db4d0cb8 100644
--- a/converters/wkhtmltopdf/Makefile
+++ b/converters/wkhtmltopdf/Makefile
@@ -11,8 +11,6 @@ COMMENT= Convert HTML (or live webpages) to PDF or image
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
@@ -26,6 +24,11 @@ WKQT_TAGNAME= fe194f9
GH_TUPLE= ${PORTNAME}:qt:${WKQT_TAGNAME}:qt
HAS_CONFIGURE= yes
+BROKEN_aarch64= Does not build: error: cast from pointer to smaller type loses information
+BROKEN_armv6= Does not build: error: Not supported ARM architecture
+BROKEN_mips64= Does not link: undefined reference to __sync_add_and_fetch_4
+BROKEN_powerpc64= Does not build
+
PATCH_WRKSRC= ${WRKSRC}/qt
CONFIGURE_WRKSRC= ${WRKSRC}/build/qt
BUILD_WRKSRC= ${WRKSRC}/build/qt