aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/nginx-devel/Makefile5
-rw-r--r--www/nginx-devel/distinfo4
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_postgres::config6
-rw-r--r--www/nginx-devel/files/extra-patch-ngx_postgres_output.c11
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/distinfo4
-rw-r--r--www/nginx/files/extra-patch-ngx_postgres::config6
7 files changed, 13 insertions, 25 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index bcef0ebd8caa..a4544c696ec6 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -480,12 +480,11 @@ CFLAGS+= -DNDEBUG
.if defined(WITH_POSTGRES_MODULE)
USE_PGSQL= yes
-NGINX_POSTGRES_MODULE_VERSION= 0.8
+NGINX_POSTGRES_MODULE_VERSION= 0.9
MASTER_SITES+= http://labs.frickle.com/files/:postgres
DISTFILES+= ngx_postgres-${NGINX_POSTGRES_MODULE_VERSION}.tar.gz:postgres
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_postgres-${NGINX_POSTGRES_MODULE_VERSION}
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_postgres::config \
- ${PATCHDIR}/extra-patch-ngx_postgres_output.c
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ngx_postgres::config
.endif
.if defined(WITH_REDIS2_MODULE)
diff --git a/www/nginx-devel/distinfo b/www/nginx-devel/distinfo
index 211423ea484a..22622b75a261 100644
--- a/www/nginx-devel/distinfo
+++ b/www/nginx-devel/distinfo
@@ -58,8 +58,8 @@ SHA256 (naxsi-0.42.tar.gz) = 94a08f6cb08d2a5b199cb4ad17caaa7509c959abaf50f254e46
SIZE (naxsi-0.42.tar.gz) = 43840
SHA256 (passenger-3.0.11.tar.gz) = 7bbabfafb9d7f4e1beb6a231dea1fe68d540910ceafec6469f51187a43d8ee4e
SIZE (passenger-3.0.11.tar.gz) = 2378398
-SHA256 (ngx_postgres-0.8.tar.gz) = 321de5ddfe95da45550a2b1d29cfcd425ed7d7d63edb0e086406486675d04283
-SIZE (ngx_postgres-0.8.tar.gz) = 40108
+SHA256 (ngx_postgres-0.9.tar.gz) = aac0141e73b5c440927b7e040072f120b36e49deb2ff36ad00ff96a80622fbec
+SIZE (ngx_postgres-0.9.tar.gz) = 41022
SHA256 (agentzh-redis2-nginx-module-v0.07-0-g6f7fc37.tar.gz) = 3fbc76fbf60e02e879184b28cb9e834a4bb8f10ecd073ebd3cc585c469650b1a
SIZE (agentzh-redis2-nginx-module-v0.07-0-g6f7fc37.tar.gz) = 23458
SHA256 (agentzh-set-misc-nginx-module-v0.22rc3-0-g7adef5a.tar.gz) = 3fab5dcd2fc653983c4295a6223ddb42283b06ac739131a45470aa084b17c402
diff --git a/www/nginx-devel/files/extra-patch-ngx_postgres::config b/www/nginx-devel/files/extra-patch-ngx_postgres::config
index 1b00e802dcce..cfba3278ca87 100644
--- a/www/nginx-devel/files/extra-patch-ngx_postgres::config
+++ b/www/nginx-devel/files/extra-patch-ngx_postgres::config
@@ -1,6 +1,6 @@
---- ../ngx_postgres-0.8/config.orig 2011-07-12 19:06:52.000000000 +0400
-+++ ../ngx_postgres-0.8/config 2011-07-12 19:07:42.000000000 +0400
-@@ -29,12 +29,12 @@
+--- ../ngx_postgres-0.9/config.orig 2011-12-29 11:17:24.000000000 +0400
++++ ../ngx_postgres-0.9/config 2011-12-29 11:18:47.000000000 +0400
+@@ -48,12 +48,12 @@
if [ $ngx_found = no ]; then
# FreeBSD
diff --git a/www/nginx-devel/files/extra-patch-ngx_postgres_output.c b/www/nginx-devel/files/extra-patch-ngx_postgres_output.c
deleted file mode 100644
index 8ff45113ae77..000000000000
--- a/www/nginx-devel/files/extra-patch-ngx_postgres_output.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ../ngx_postgres-0.8/src/ngx_postgres_output.c.orig 2011-09-20 13:00:59.000000000 +0400
-+++ ../ngx_postgres-0.8/src/ngx_postgres_output.c 2011-09-20 13:05:09.000000000 +0400
-@@ -624,7 +624,7 @@
- return rc;
- }
-
-- ngx_chain_update_chains(&u->free_bufs, &u->busy_bufs, &cl, u->output.tag);
-+ ngx_chain_update_chains(r->pool, &u->free_bufs, &u->busy_bufs, &cl, u->output.tag);
-
- dd("returning rc:%d", (int) rc);
- return rc;
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index 6a083c15d364..6c733be9b51d 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -487,7 +487,7 @@ CFLAGS+= -DNDEBUG
.if defined(WITH_POSTGRES_MODULE)
USE_PGSQL= yes
-NGINX_POSTGRES_MODULE_VERSION= 0.8
+NGINX_POSTGRES_MODULE_VERSION= 0.9
MASTER_SITES+= http://labs.frickle.com/files/:postgres
DISTFILES+= ngx_postgres-${NGINX_POSTGRES_MODULE_VERSION}.tar.gz:postgres
CONFIGURE_ARGS+=--add-module=${WRKDIR}/ngx_postgres-${NGINX_POSTGRES_MODULE_VERSION}
diff --git a/www/nginx/distinfo b/www/nginx/distinfo
index 611f18ef3b38..22e8666c7d67 100644
--- a/www/nginx/distinfo
+++ b/www/nginx/distinfo
@@ -60,8 +60,8 @@ SHA256 (naxsi-0.42.tar.gz) = 94a08f6cb08d2a5b199cb4ad17caaa7509c959abaf50f254e46
SIZE (naxsi-0.42.tar.gz) = 43840
SHA256 (passenger-3.0.11.tar.gz) = 7bbabfafb9d7f4e1beb6a231dea1fe68d540910ceafec6469f51187a43d8ee4e
SIZE (passenger-3.0.11.tar.gz) = 2378398
-SHA256 (ngx_postgres-0.8.tar.gz) = 321de5ddfe95da45550a2b1d29cfcd425ed7d7d63edb0e086406486675d04283
-SIZE (ngx_postgres-0.8.tar.gz) = 40108
+SHA256 (ngx_postgres-0.9.tar.gz) = aac0141e73b5c440927b7e040072f120b36e49deb2ff36ad00ff96a80622fbec
+SIZE (ngx_postgres-0.9.tar.gz) = 41022
SHA256 (agentzh-redis2-nginx-module-v0.07-0-g6f7fc37.tar.gz) = 3fbc76fbf60e02e879184b28cb9e834a4bb8f10ecd073ebd3cc585c469650b1a
SIZE (agentzh-redis2-nginx-module-v0.07-0-g6f7fc37.tar.gz) = 23458
SHA256 (agentzh-set-misc-nginx-module-v0.22rc3-0-g7adef5a.tar.gz) = 3fab5dcd2fc653983c4295a6223ddb42283b06ac739131a45470aa084b17c402
diff --git a/www/nginx/files/extra-patch-ngx_postgres::config b/www/nginx/files/extra-patch-ngx_postgres::config
index 1b00e802dcce..cfba3278ca87 100644
--- a/www/nginx/files/extra-patch-ngx_postgres::config
+++ b/www/nginx/files/extra-patch-ngx_postgres::config
@@ -1,6 +1,6 @@
---- ../ngx_postgres-0.8/config.orig 2011-07-12 19:06:52.000000000 +0400
-+++ ../ngx_postgres-0.8/config 2011-07-12 19:07:42.000000000 +0400
-@@ -29,12 +29,12 @@
+--- ../ngx_postgres-0.9/config.orig 2011-12-29 11:17:24.000000000 +0400
++++ ../ngx_postgres-0.9/config 2011-12-29 11:18:47.000000000 +0400
+@@ -48,12 +48,12 @@
if [ $ngx_found = no ]; then
# FreeBSD