aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/finch/Makefile14
-rw-r--r--net-im/finch/pkg-descr10
-rw-r--r--net-im/finch/pkg-plist52
4 files changed, 41 insertions, 36 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 5be042317d10..4eefbc6895ee 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -19,6 +19,7 @@
SUBDIR += echat
SUBDIR += ejabberd
SUBDIR += eva
+ SUBDIR += finch
SUBDIR += firetalk
SUBDIR += fugu
SUBDIR += gaim
diff --git a/net-im/finch/Makefile b/net-im/finch/Makefile
index f61e35b9f470..421ecbff0ddd 100644
--- a/net-im/finch/Makefile
+++ b/net-im/finch/Makefile
@@ -6,22 +6,20 @@
# $MCom: ports-stable/net-im/gaim-consoleui-devel/Makefile,v 1.2 2006/10/29 18:55:28 marcus Exp $
#
-PORTNAME= gaim
-PKGNAMEPREFIX=
-PKGNAMESUFFIX= -consoleui-devel
+PORTNAME= finch
MAINTAINER= marcus@FreeBSD.org
-COMMENT= Gaim multi-protocol messaging client (Console UI)
+COMMENT= Finch multi-protocol messaging client (Console UI)
-LIB_DEPENDS= gaim.0:${PORTSDIR}/net-im/libgaim
+LIB_DEPENDS= purple.0:${PORTSDIR}/net-im/libpurple
-MASTERDIR= ${.CURDIR}/../libgaim
-BUILD_WRKSRC= ${WRKSRC}/console
+MASTERDIR= ${.CURDIR}/../libpurple
+BUILD_WRKSRC= ${WRKSRC}/finch
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-GAIM_SLAVE= yes
+PIDGIN_SLAVE= yes
WITH_CONSOLEUI= yes
USE_LDCONFIG= yes
diff --git a/net-im/finch/pkg-descr b/net-im/finch/pkg-descr
index d4901fdf0fae..4276853ac1b1 100644
--- a/net-im/finch/pkg-descr
+++ b/net-im/finch/pkg-descr
@@ -1,13 +1,13 @@
-Gaim is a multi-protocol instant messaging client. It is compatible with AIM
+Finch is a multi-protocol instant messaging client. It is compatible with AIM
(Oscar and TOC protocols), ICQ, MSN Messenger, Yahoo, IRC, Jabber, Gadu-Gadu,
and Zephyr networks.
-Gaim users can log in to multiple accounts on multiple IM networks
+Finch users can log in to multiple accounts on multiple IM networks
simultaneously. This means that you can be chatting with friends on AOL
Instant Messenger, talking to a friend on Yahoo Messenger, and sitting in an
IRC channel all at the same time.
-Gaim supports many features of the various networks, such as file transfer
+Finch supports many features of the various networks, such as file transfer
(coming soon), away messages, typing notification, and MSN window closing
notification. It also goes beyond that and provides many unique features. A
few popular features are Buddy Pounces, which give the ability to notify you,
@@ -16,6 +16,6 @@ signs online, or returns from idle; and plugins, consisting of text
replacement, a buddy ticker, extended message notification, iconify on away,
and more.
-(Adapted from the About Gaim page.)
+(Adapted from the About Finch page.)
-WWW: http://gaim.sourceforge.net/
+WWW: http://www.pidgin.im/
diff --git a/net-im/finch/pkg-plist b/net-im/finch/pkg-plist
index b6e0e73a025a..144a151c84c8 100644
--- a/net-im/finch/pkg-plist
+++ b/net-im/finch/pkg-plist
@@ -1,24 +1,29 @@
-bin/gaim-text
-include/gaim/gnt/gntaccount.h
-include/gaim/gnt/gntblist.h
-include/gaim/gnt/gntconn.h
-include/gaim/gnt/gntconv.h
-include/gaim/gnt/gntdebug.h
-include/gaim/gnt/gntgaim.h
-include/gaim/gnt/gntnotify.h
-include/gaim/gnt/gntplugin.h
-include/gaim/gnt/gntprefs.h
-include/gaim/gnt/gntrequest.h
-include/gaim/gnt/gntstatus.h
-include/gaim/gnt/gntui.h
+bin/finch
+include/finch/finch.h
+include/finch/gntaccount.h
+include/finch/gntblist.h
+include/finch/gntconn.h
+include/finch/gntconv.h
+include/finch/gntdebug.h
+include/finch/gntft.h
+include/finch/gntidle.h
+include/finch/gntnotify.h
+include/finch/gntplugin.h
+include/finch/gntpounce.h
+include/finch/gntprefs.h
+include/finch/gntrequest.h
+include/finch/gntstatus.h
+include/finch/gntui.h
include/gnt/gnt.h
include/gnt/gntbindable.h
include/gnt/gntbox.h
include/gnt/gntbutton.h
include/gnt/gntcheckbox.h
+include/gnt/gntclipboard.h
include/gnt/gntcolors.h
include/gnt/gntcombobox.h
include/gnt/gntentry.h
+include/gnt/gntfilesel.h
include/gnt/gntkeys.h
include/gnt/gntlabel.h
include/gnt/gntline.h
@@ -33,18 +38,19 @@ include/gnt/gntutils.h
include/gnt/gntwidget.h
include/gnt/gntwindow.h
include/gnt/gntwm.h
-lib/gaim/gntgf.la
-lib/gaim/gntgf.so
-lib/gaim/gnthistory.la
-lib/gaim/gnthistory.so
-lib/gaim/gntlastlog.la
-lib/gaim/gntlastlog.so
-lib/gaim/s.la
-lib/gaim/s.so
+lib/finch/gntgf.la
+lib/finch/gntgf.so
+lib/finch/gntclipboard.la
+lib/finch/gntclipboard.so
+lib/finch/gnthistory.la
+lib/finch/gnthistory.so
+lib/finch/gntlastlog.la
+lib/finch/gntlastlog.so
+lib/finch/s.la
+lib/finch/s.so
lib/libgnt.la
lib/libgnt.so
lib/libgnt.so.0
libdata/pkgconfig/gnt.pc
@dirrm include/gnt
-@dirrm include/gaim/gnt
-@dirrm include/gaim
+@dirrm include/finch