aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/filters/Makefile8
-rw-r--r--mail/delatt/Makefile12
-rw-r--r--sysutils/rej/Makefile7
-rw-r--r--textproc/colordiff/Makefile8
-rw-r--r--www/bannerfilter/Makefile6
5 files changed, 16 insertions, 25 deletions
diff --git a/games/filters/Makefile b/games/filters/Makefile
index 5cc2723316c3..83012a5ac23e 100644
--- a/games/filters/Makefile
+++ b/games/filters/Makefile
@@ -14,6 +14,7 @@ COMMENT= Collection of filters, including B1FF, and the Swedish Chef
CONFLICTS= talkfilters-[0-9]* jive-[0-9]* chef-[0-9]* kenny-[0-9]* \
lolcat-[0-9]*
+USES= shebangfix
USE_PERL5= yes
USE_GMAKE= yes
MAKE_JOBS_UNSAFE= yes
@@ -25,6 +26,8 @@ PERLFILTERS= b1ff censor chef eleet fudd jibberish kenny pirate rasterman \
CFILTERS= jethro kraut cockney jive nyc ken ky00te newspeak nethackify \
scramble
+SHEBANG_FILES= ${PERLFILTERS}
+
MAN1= filters.1
MLINKS= filters.1 b1ff.1 \
filters.1 censor.1 \
@@ -55,11 +58,6 @@ MLINKS= filters.1 b1ff.1 \
post-extract:
@${MV} ${WRKSRC}/${PORTNAME}.6 ${WRKSRC}/${MAN1}
-post-patch:
-.for f in ${PERLFILTERS}
- @${REINPLACE_CMD} -e '1s|.*perl|#!${PERL}|' ${WRKSRC}/${f}
-.endfor
-
do-install:
.for f in ${CFILTERS}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
diff --git a/mail/delatt/Makefile b/mail/delatt/Makefile
index 183c8dbcddac..7ec92b8ad741 100644
--- a/mail/delatt/Makefile
+++ b/mail/delatt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: delatt
-# Date created: 22 Jun 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= delatt
DISTVERSION= 1.1.3
@@ -18,15 +14,13 @@ LICENSE= GPLv2
RUN_DEPENDS= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+USES= shebangfix
USE_PERL5_RUN= yes
NO_BUILD= yes
+SHEBANG_FILES= delatt
PLIST_FILES= bin/delatt
-post-patch:
- ${REINPLACE_CMD} -e 's|^#!/usr/bin/perl|#!${PERL}|' \
- ${WRKSRC}/${PORTNAME}
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/sysutils/rej/Makefile b/sysutils/rej/Makefile
index dd1bce2f4d4b..0bc46821ba6f 100644
--- a/sysutils/rej/Makefile
+++ b/sysutils/rej/Makefile
@@ -9,9 +9,12 @@ MASTER_SITES= CRITICAL
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= Merges patch-rejects and runs a merge program to verify the changes
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= qp mp
+
PORTDOCS= CHANGELOG README vimrc
PLIST_FILES= bin/rej bin/rej-qp bin/rej-mp
@@ -20,10 +23,6 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
-.for f in ${PORTNAME} qp mp
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/${f}
-.endfor
@${REINPLACE_CMD} -e 's|/bin/bash|${SH}|' \
${WRKSRC}/runtests.sh
diff --git a/textproc/colordiff/Makefile b/textproc/colordiff/Makefile
index fca1f4a8e872..4dac6b2d861c 100644
--- a/textproc/colordiff/Makefile
+++ b/textproc/colordiff/Makefile
@@ -11,16 +11,16 @@ COMMENT= Tool to colorize diff output
LICENSE= GPLv2
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
+SHEBANG_FILES= colordiff.pl
+
MAN1= colordiff.1
post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/local/bin/perl|${PERL}|; s|/etc|${PREFIX}/etc|' \
- ${WRKSRC}/${PORTNAME}.pl \
- ${WRKSRC}/${MAN1}
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${MAN1}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
diff --git a/www/bannerfilter/Makefile b/www/bannerfilter/Makefile
index 3ebf5d9a77c0..7e355a685e46 100644
--- a/www/bannerfilter/Makefile
+++ b/www/bannerfilter/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
RUN_DEPENDS= squid:${PORTSDIR}/www/squid
+USES= shebangfix
USE_PERL5= yes
NO_BUILD= yes
@@ -23,11 +24,10 @@ CONFIG_FILES= bannerfilter.conf banners.data banners.local.data \
exceptions.data exceptions.local.data frames.data \
frames.local.data popups.data popups.local.data
+SHEBANG_FILES= redirector.pl
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/local/etc|${PREFIX}/etc|; s|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/redirector.pl
- @${REINPLACE_CMD} -e \
's|^;\ \(DATA\ =\ \).*|\1${PREFIX}/etc/${PORTNAME}/|' \
${WRKSRC}/${PORTNAME}.conf
@${REINPLACE_CMD} -e \