aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/nmap/Makefile2
-rw-r--r--security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index b5adf3289cef..9fddefb333e6 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= nmap
PORTVERSION= ${DISTVERSION:L:C/([a-z])[a-z]+/\1/g:C/[^a-z0-9+]+/./g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://download.insecure.org/nmap/dist/ \
http://www.mirrors.wiretapped.net/security/network-mapping/nmap/ \
diff --git a/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c b/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c
new file mode 100644
index 000000000000..15bea72d3cec
--- /dev/null
+++ b/security/nmap/files/patch-libdnet-stripped__src__eth-bsd.c
@@ -0,0 +1,17 @@
+#
+# $FreeBSD$
+#
+# - nmap fails to attach to bpf when more than 128 bpfs are busy.
+# PR: 98080
+#
+--- libdnet-stripped/src/eth-bsd.c.orig
++++ libdnet-stripped/src/eth-bsd.c
+@@ -45,7 +45,7 @@
+ int i;
+
+ if ((e = calloc(1, sizeof(*e))) != NULL) {
+- for (i = 0; i < 128; i++) {
++ for (i = 0; i < 1024; i++) {
+ snprintf(file, sizeof(file), "/dev/bpf%d", i);
+ e->fd = open(file, O_WRONLY);
+ if (e->fd != -1 || errno != EBUSY)