aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/mspdebug/Makefile2
-rw-r--r--devel/mspdebug/distinfo4
-rw-r--r--devel/mspdebug/files/patch-Makefile17
3 files changed, 7 insertions, 16 deletions
diff --git a/devel/mspdebug/Makefile b/devel/mspdebug/Makefile
index 72d1339d2999..ba31fd46f479 100644
--- a/devel/mspdebug/Makefile
+++ b/devel/mspdebug/Makefile
@@ -7,7 +7,7 @@
# Based on the OpenBSD port by: Jasper Lievisse Adriaanse <jasper@openbsd.org>
PORTNAME= mspdebug
-PORTVERSION= 0.17
+PORTVERSION= 0.19
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}
diff --git a/devel/mspdebug/distinfo b/devel/mspdebug/distinfo
index 19e419201205..2c3a466bc80d 100644
--- a/devel/mspdebug/distinfo
+++ b/devel/mspdebug/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mspdebug-0.17.tar.gz) = f9c1ffb39969ad7716347112e66c6e67b9f57bc47ed7a4379697d1144ee3b8a4
-SIZE (mspdebug-0.17.tar.gz) = 144012
+SHA256 (mspdebug-0.19.tar.gz) = 0410ee3c30ae50d028bacee0fe27ec0d0b6cda3163cae51d02cda9aaa8814b6a
+SIZE (mspdebug-0.19.tar.gz) = 174126
diff --git a/devel/mspdebug/files/patch-Makefile b/devel/mspdebug/files/patch-Makefile
index 8e60102d9558..766e4d4c7cb1 100644
--- a/devel/mspdebug/files/patch-Makefile
+++ b/devel/mspdebug/files/patch-Makefile
@@ -1,17 +1,8 @@
---- Makefile.orig 2011-06-14 11:27:10.000000000 +1000
-+++ Makefile 2011-07-29 05:26:08.226244817 +1000
-@@ -16,7 +16,7 @@
- # along with this program; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
--CC = gcc
-+CC ?= gcc
- INSTALL = /usr/bin/install
- PREFIX ?= /usr/local
- LDFLAGS ?= -s
-@@ -38,8 +38,14 @@
+--- Makefile.orig 2011-11-08 08:11:49.000000000 +1100
++++ Makefile 2012-02-25 09:33:44.098219483 +1100
+@@ -43,8 +43,14 @@
PORTS_CFLAGS = `pkg-config --cflags libusb`
- PORTS_LDFLAGS = `pkg-config --libs libusb` -ltermcap
+ PORTS_LDFLAGS = `pkg-config --libs libusb` -ltermcap -pthread
else
+ ifeq ($(UNAME),FreeBSD) # FreeBSD Ports stuff
+# This is only needed prior to FreeBSD 8.x to find libusb