aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/py-serial/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/comms/py-serial/Makefile b/comms/py-serial/Makefile
index fb73fde2cd54..aa2f02fc7311 100644
--- a/comms/py-serial/Makefile
+++ b/comms/py-serial/Makefile
@@ -1,6 +1,6 @@
-# New ports collection makefile for: py-serial
-# Date created: 26 February 2002
-# Whom: Hye-Shik Chang <perky@fallin.lv>
+# New ports collection makefile for: pySerial
+# Date created: 26 February 2002
+# Whom: Hye-Shik Chang <perky@fallin.lv>
#
# $FreeBSD$
#
@@ -9,8 +9,8 @@ PORTNAME= serial
PORTVERSION= 2.5
CATEGORIES= comms python
MASTER_SITES= CHEESESHOP
+DISTNAME= py${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= pyserial-${PORTVERSION}
MAINTAINER= sbrabez@gmail.com
COMMENT= Serial port encapsulation library for Python
@@ -18,18 +18,18 @@ COMMENT= Serial port encapsulation library for Python
USE_PYTHON= yes
USE_PYDISTUTILS= yes
USE_PYTHON_PREFIX= yes
-PYDISTUTILS_PKGNAME= pyserial
+PYDISTUTILS_PKGNAME= py${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/*.txt ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif