aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-omniauth-facebook/Makefile19
-rw-r--r--net/rubygem-omniauth-facebook/distinfo2
-rw-r--r--net/rubygem-omniauth-facebook/pkg-descr3
4 files changed, 25 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ce0c51b0c4f3..7a74e9d06739 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1008,6 +1008,7 @@
SUBDIR += rubygem-oauth
SUBDIR += rubygem-oauth2
SUBDIR += rubygem-octokit
+ SUBDIR += rubygem-omniauth-facebook
SUBDIR += rubygem-omniauth-github
SUBDIR += rubygem-omniauth-github-discourse
SUBDIR += rubygem-omniauth-google-oauth2
diff --git a/net/rubygem-omniauth-facebook/Makefile b/net/rubygem-omniauth-facebook/Makefile
new file mode 100644
index 000000000000..ed8092b3d961
--- /dev/null
+++ b/net/rubygem-omniauth-facebook/Makefile
@@ -0,0 +1,19 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= omniauth-facebook
+PORTVERSION= 2.0.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Facebook OAuth2 Strategy for OmniAuth
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=1.2:${PORTSDIR}/net/rubygem-omniauth-oauth2
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+USE_RAKE= yes
+RUBYGEM_AUTOPLIST=yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-facebook/distinfo b/net/rubygem-omniauth-facebook/distinfo
new file mode 100644
index 000000000000..1d2d088d9681
--- /dev/null
+++ b/net/rubygem-omniauth-facebook/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/omniauth-facebook-2.0.0.gem) = c241db1fb0fdd8f3a9629688aad0c60cad7679dc0c404d0f35907ce73f14047b
+SIZE (rubygem/omniauth-facebook-2.0.0.gem) = 17408
diff --git a/net/rubygem-omniauth-facebook/pkg-descr b/net/rubygem-omniauth-facebook/pkg-descr
new file mode 100644
index 000000000000..fb1f5c777a36
--- /dev/null
+++ b/net/rubygem-omniauth-facebook/pkg-descr
@@ -0,0 +1,3 @@
+Facebook OAuth2 Strategy for OmniAuth
+
+WWW: https://github.com/mkdynamic/omniauth-facebook