aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--databases/xapian-core/Makefile9
-rw-r--r--databases/xapian-core10/Makefile9
2 files changed, 10 insertions, 8 deletions
diff --git a/databases/xapian-core/Makefile b/databases/xapian-core/Makefile
index e454b7c61ba3..a2aea5b6434d 100644
--- a/databases/xapian-core/Makefile
+++ b/databases/xapian-core/Makefile
@@ -16,19 +16,20 @@ COMMENT= A probabilistic text search database engine
LIB_DEPENDS= uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
MAN1= xapian-check.1 xapian-chert-update.1 xapian-compact.1 \
xapian-config.1 xapian-inspect.1 xapian-metadata.1 \
xapian-progsrv.1 xapian-replicate-server.1 xapian-tcpsrv.1 \
- xapian-replicate.1
+ xapian-replicate.1
+post-install:
.ifdef(NOPORTDOCS)
${RM} -rf ${DOCSDIR}
.endif
diff --git a/databases/xapian-core10/Makefile b/databases/xapian-core10/Makefile
index e454b7c61ba3..a2aea5b6434d 100644
--- a/databases/xapian-core10/Makefile
+++ b/databases/xapian-core10/Makefile
@@ -16,19 +16,20 @@ COMMENT= A probabilistic text search database engine
LIB_DEPENDS= uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
MAN1= xapian-check.1 xapian-chert-update.1 xapian-compact.1 \
xapian-config.1 xapian-inspect.1 xapian-metadata.1 \
xapian-progsrv.1 xapian-replicate-server.1 xapian-tcpsrv.1 \
- xapian-replicate.1
+ xapian-replicate.1
+post-install:
.ifdef(NOPORTDOCS)
${RM} -rf ${DOCSDIR}
.endif