aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.wx.mk6
-rw-r--r--graphics/wxsvg/Makefile8
-rw-r--r--multimedia/dvdstyler/Makefile9
3 files changed, 10 insertions, 13 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index b5d17d8b95cf..7e5cf664a133 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -35,7 +35,6 @@
# wx - The wxWidgets library.
# contrib - The wxWidgets contributed libraries.
# python - The wxWidgets API for Python.
-# svg - WxSVG (only for 2.8).
# The available dependency types are:
# build - Requires component for building.
# lib - Requires component for building and running.
@@ -129,7 +128,7 @@ _WX_Definitions_Done= yes
# _WX_VERS_LISTS - Reverse lists preference order.
#
-_WX_COMPS_ALL= wx contrib python svg
+_WX_COMPS_ALL= wx contrib python
_WX_DEP_TYPES_ALL= build lib run
_WX_VERS_ALL= 2.8 3.0
_WX_VERS_UC_ALL= 2.8 3.0
@@ -155,9 +154,6 @@ _WX_LIB_contrib_2.8= wx_gtk2${_WX_UC}_fl-2.8
_WX_PORT_python_2.8= x11-toolkits/py-wxPython28${_WX_UCL}
_WX_FILE_python_2.8= ${PYTHON_SITELIBDIR}/wx-2.8-gtk2${_WX_PYSUFX}/wx/__init__.py
-_WX_PORT_svg_2.8= graphics/wxsvg
-_WX_LIB_svg_2.8= wxsvg
-
# wxgtk 3.0
_WX_PORT_wx_3.0= x11-toolkits/wxgtk30
_WX_LIB_wx_3.0= wx_baseu-3.0
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index 2466fa7ffd0b..cced441d58b7 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wxsvg
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
@@ -15,9 +15,9 @@ LICENSE= LGPL21 # (or later)
LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg \
libexpat.so:${PORTSDIR}/textproc/expat2
-USE_BZIP2= yes
-USES= gmake pathfix pkgconfig
-USE_WX= yes
+USES= gmake pathfix pkgconfig tar:bzip2
+USE_WX= 3.0
+WX_UNICODE= yes
WX_CONF_ARGS= absolute
USE_GNOME= cairo
GNU_CONFIGURE= yes
diff --git a/multimedia/dvdstyler/Makefile b/multimedia/dvdstyler/Makefile
index a58fbdb090e5..cdf24f01a191 100644
--- a/multimedia/dvdstyler/Makefile
+++ b/multimedia/dvdstyler/Makefile
@@ -3,6 +3,7 @@
PORTNAME= dvdstyler
PORTVERSION= 2.7.1
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= multimedia
MASTER_SITES= SF
@@ -29,10 +30,10 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
mkisofs:${PORTSDIR}/sysutils/cdrtools \
growisofs:${PORTSDIR}/sysutils/dvd+rw-tools
-USE_BZIP2= yes
-USES= gettext gmake pkgconfig
-USE_WX= 2.8
-WX_COMPS= wx svg
+USES= gettext gmake pkgconfig tar:bzip2
+USE_WX= 3.0
+WX_UNICODE= yes
+WX_COMPS= wx
WX_CONF_ARGS= absolute
USE_AUTOTOOLS= aclocal automake autoconf
ACLOCAL_ARGS= -I ${WRKSRC}