aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/rudiments/Makefile5
-rw-r--r--devel/rudiments/distinfo4
-rw-r--r--devel/rudiments/files/patch-configure25
-rw-r--r--devel/rudiments/pkg-plist15
4 files changed, 22 insertions, 27 deletions
diff --git a/devel/rudiments/Makefile b/devel/rudiments/Makefile
index 5f978ac6fde2..c1b785cec83d 100644
--- a/devel/rudiments/Makefile
+++ b/devel/rudiments/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= rudiments
-PORTVERSION= 0.46
-PORTREVISION= 2
+PORTVERSION= 0.47
CATEGORIES= devel
MASTER_SITES= SF
@@ -41,6 +40,6 @@ post-patch:
/finish/s| $$(libdir)| $${DESTDIR}$$(libdir)|'
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librudiments-0.46.so.1
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/librudiments-0.47.so.1
.include <bsd.port.mk>
diff --git a/devel/rudiments/distinfo b/devel/rudiments/distinfo
index 552ccfca4247..256e2218c406 100644
--- a/devel/rudiments/distinfo
+++ b/devel/rudiments/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rudiments-0.46.tar.gz) = b59b830af52cdf5a361d73524efa0a7aa2f804011e07bf3855551ad07273d70a
-SIZE (rudiments-0.46.tar.gz) = 1732565
+SHA256 (rudiments-0.47.tar.gz) = efca29327fe0a96afd06d49cdffce2bac4eaa57ffa5ad7f0972d30bcfc5da217
+SIZE (rudiments-0.47.tar.gz) = 1765665
diff --git a/devel/rudiments/files/patch-configure b/devel/rudiments/files/patch-configure
index 6a2a9aa924e0..2e1e72e311a3 100644
--- a/devel/rudiments/files/patch-configure
+++ b/devel/rudiments/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig 2012-02-17 13:38:13.000000000 +0900
-+++ configure 2012-04-13 00:56:01.000000000 +0900
-@@ -15691,6 +15691,9 @@
- *minix* )
+--- configure.orig 2014-06-21 04:23:02 UTC
++++ configure
+@@ -15765,6 +15765,9 @@
+ *mingw32* )
WERROR=""
;;
+ freebsd* )
@@ -10,7 +10,7 @@
*)
;;
esac
-@@ -17476,8 +17479,8 @@
+@@ -17738,8 +17741,8 @@
HAVE_PTHREAD=""
@@ -21,16 +21,7 @@
if ( test "$cross_compiling" = "yes" )
then
-@@ -17496,7 +17499,7 @@
-
- else
-
-- for i in "pthread" "c_r" "thread" "pthreads" "gthreads" ""
-+ for i in "thread" "pthreads" "gthreads" ""
- do
- if ( test -n "$i" )
- then
-@@ -17530,9 +17533,6 @@
+@@ -17795,9 +17798,6 @@
STATIC=""
HEADERSANDLIBSPATH=""
@@ -40,7 +31,7 @@
eval "PTHREADSTATIC=\"\""
if ( test -n "" )
then
-@@ -17747,9 +17747,6 @@
+@@ -18012,9 +18012,6 @@
LIBSTRING=`echo $LIBSTRING | sed -e "s|-L/usr/lib$||g" -e "s|-L/lib$||g" -e "s|-L/usr/lib ||g" -e "s|-L/lib ||g"`
LIBSTRING=`echo $LIBSTRING | sed -e "s|-L/usr/lib64$||g" -e "s|-L/lib64$||g" -e "s|-L/usr/lib64 ||g" -e "s|-L/lib64 ||g"`
@@ -50,7 +41,7 @@
eval "PTHREADSTATIC=\"$STATIC\""
if ( test -n "" )
then
-@@ -29618,47 +29615,47 @@
+@@ -30750,47 +30747,47 @@
# prepend DESTDIR where appropriate
if ( test "`echo $ac_default_prefix | cut -c1`" = "/" )
then
diff --git a/devel/rudiments/pkg-plist b/devel/rudiments/pkg-plist
index 3a1ba2286cdb..1bea440124c1 100644
--- a/devel/rudiments/pkg-plist
+++ b/devel/rudiments/pkg-plist
@@ -1,4 +1,6 @@
bin/rudiments-config
+include/rudiments/bytebuffer.h
+include/rudiments/bytestring.h
include/rudiments/character.h
include/rudiments/charstring.h
include/rudiments/chat.h
@@ -33,6 +35,9 @@ include/rudiments/modemserver.h
include/rudiments/parameterstring.h
include/rudiments/passwdentry.h
include/rudiments/permissions.h
+include/rudiments/private/bytebuffer.h
+include/rudiments/private/bytebufferincludes.h
+include/rudiments/private/bytestringincludes.h
include/rudiments/private/characterincludes.h
include/rudiments/private/charstring.h
include/rudiments/private/charstringincludes.h
@@ -114,7 +119,6 @@ include/rudiments/private/processincludes.h
include/rudiments/private/protocolentry.h
include/rudiments/private/protocolentryincludes.h
include/rudiments/private/randomnumberincludes.h
-include/rudiments/private/rawbufferincludes.h
include/rudiments/private/regularexpression.h
include/rudiments/private/regularexpressionincludes.h
include/rudiments/private/rpcentry.h
@@ -139,6 +143,10 @@ include/rudiments/private/shmfileincludes.h
include/rudiments/private/signalclassesincludes.h
include/rudiments/private/signalhandler.h
include/rudiments/private/signalset.h
+include/rudiments/private/singlylinkedlist.h
+include/rudiments/private/singlylinkedlistincludes.h
+include/rudiments/private/singlylinkedlistinlines.h
+include/rudiments/private/singlylinkedlistnode.h
include/rudiments/private/snoozeincludes.h
include/rudiments/private/socketclient.h
include/rudiments/private/socketclientincludes.h
@@ -161,8 +169,6 @@ include/rudiments/private/unixsocketserver.h
include/rudiments/private/unixsocketserverincludes.h
include/rudiments/private/unixsocketutil.h
include/rudiments/private/unixsocketutilincludes.h
-include/rudiments/private/variablebuffer.h
-include/rudiments/private/variablebufferincludes.h
include/rudiments/private/winsock.h
include/rudiments/private/xmldom.h
include/rudiments/private/xmldomincludes.h
@@ -173,7 +179,6 @@ include/rudiments/private/xmlsaxincludes.h
include/rudiments/process.h
include/rudiments/protocolentry.h
include/rudiments/randomnumber.h
-include/rudiments/rawbuffer.h
include/rudiments/regularexpression.h
include/rudiments/resultcodes.h
include/rudiments/rpcentry.h
@@ -186,6 +191,7 @@ include/rudiments/shadowentry.h
include/rudiments/sharedmemory.h
include/rudiments/shmfile.h
include/rudiments/signalclasses.h
+include/rudiments/singlylinkedlist.h
include/rudiments/snooze.h
include/rudiments/socketclient.h
include/rudiments/socketserver.h
@@ -197,7 +203,6 @@ include/rudiments/threadmutex.h
include/rudiments/unixsocketclient.h
include/rudiments/unixsocketserver.h
include/rudiments/unixsocketutil.h
-include/rudiments/variablebuffer.h
include/rudiments/xmldom.h
include/rudiments/xmldomnode.h
include/rudiments/xmlsax.h