aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--java/linux-blackdown-jdk12/Makefile2
-rw-r--r--java/linux-blackdown-jdk12/files/patch-aa22
-rw-r--r--java/linux-blackdown-jdk12/files/patch-ab22
-rw-r--r--java/linux-jdk/Makefile2
-rw-r--r--java/linux-jdk/files/patch-aa22
-rw-r--r--java/linux-jdk/files/patch-ab22
6 files changed, 90 insertions, 2 deletions
diff --git a/java/linux-blackdown-jdk12/Makefile b/java/linux-blackdown-jdk12/Makefile
index 0d7ec1a52a4a..9c582e37de3f 100644
--- a/java/linux-blackdown-jdk12/Makefile
+++ b/java/linux-blackdown-jdk12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= ftp://ftp.tux.org/pub/java/JDK-${PORTVERSION}/${ARCH}/FCS/ \
http://www.metaverse.nl/~ernst/ \
diff --git a/java/linux-blackdown-jdk12/files/patch-aa b/java/linux-blackdown-jdk12/files/patch-aa
new file mode 100644
index 000000000000..9f6c6b8dd4bb
--- /dev/null
+++ b/java/linux-blackdown-jdk12/files/patch-aa
@@ -0,0 +1,22 @@
+--- bin/.java_wrapper.orig Fri Apr 12 17:03:39 2002
++++ bin/.java_wrapper Fri Apr 12 17:04:00 2002
+@@ -32,8 +32,8 @@
+ # Resolve symlinks. See 4152645.
+ while [ -L "$PRG" ]; do
+ ls=`ls -ld "$PRG"`
+- link=`expr "$ls" : '.*-> \(.*\)$'`
+- if expr "$link" : '/' > /dev/null; then
++ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
++ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
+ PRG="$link"
+ else
+ PRG="`dirname $PRG`/$link"
+@@ -65,7 +65,7 @@
+ # Select vm type (if classic vm, also select thread type).
+ unset vmtype
+ unset ttype
+-DEFAULT_THREADS_FLAG=native
++DEFAULT_THREADS_FLAG=green
+ if [ "x$1" = "x-hotspot" ]; then
+ vmtype=hotspot
+ ttype=native_threads
diff --git a/java/linux-blackdown-jdk12/files/patch-ab b/java/linux-blackdown-jdk12/files/patch-ab
new file mode 100644
index 000000000000..91029806f724
--- /dev/null
+++ b/java/linux-blackdown-jdk12/files/patch-ab
@@ -0,0 +1,22 @@
+--- jre/bin/.java_wrapper.orig Fri Apr 12 17:03:39 2002
++++ jre/bin/.java_wrapper Fri Apr 12 17:04:00 2002
+@@ -32,8 +32,8 @@
+ # Resolve symlinks. See 4152645.
+ while [ -L "$PRG" ]; do
+ ls=`ls -ld "$PRG"`
+- link=`expr "$ls" : '.*-> \(.*\)$'`
+- if expr "$link" : '/' > /dev/null; then
++ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
++ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
+ PRG="$link"
+ else
+ PRG="`dirname $PRG`/$link"
+@@ -65,7 +65,7 @@
+ # Select vm type (if classic vm, also select thread type).
+ unset vmtype
+ unset ttype
+-DEFAULT_THREADS_FLAG=native
++DEFAULT_THREADS_FLAG=green
+ if [ "x$1" = "x-hotspot" ]; then
+ vmtype=hotspot
+ ttype=native_threads
diff --git a/java/linux-jdk/Makefile b/java/linux-jdk/Makefile
index 0d7ec1a52a4a..9c582e37de3f 100644
--- a/java/linux-jdk/Makefile
+++ b/java/linux-jdk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= ftp://ftp.tux.org/pub/java/JDK-${PORTVERSION}/${ARCH}/FCS/ \
http://www.metaverse.nl/~ernst/ \
diff --git a/java/linux-jdk/files/patch-aa b/java/linux-jdk/files/patch-aa
new file mode 100644
index 000000000000..9f6c6b8dd4bb
--- /dev/null
+++ b/java/linux-jdk/files/patch-aa
@@ -0,0 +1,22 @@
+--- bin/.java_wrapper.orig Fri Apr 12 17:03:39 2002
++++ bin/.java_wrapper Fri Apr 12 17:04:00 2002
+@@ -32,8 +32,8 @@
+ # Resolve symlinks. See 4152645.
+ while [ -L "$PRG" ]; do
+ ls=`ls -ld "$PRG"`
+- link=`expr "$ls" : '.*-> \(.*\)$'`
+- if expr "$link" : '/' > /dev/null; then
++ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
++ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
+ PRG="$link"
+ else
+ PRG="`dirname $PRG`/$link"
+@@ -65,7 +65,7 @@
+ # Select vm type (if classic vm, also select thread type).
+ unset vmtype
+ unset ttype
+-DEFAULT_THREADS_FLAG=native
++DEFAULT_THREADS_FLAG=green
+ if [ "x$1" = "x-hotspot" ]; then
+ vmtype=hotspot
+ ttype=native_threads
diff --git a/java/linux-jdk/files/patch-ab b/java/linux-jdk/files/patch-ab
new file mode 100644
index 000000000000..91029806f724
--- /dev/null
+++ b/java/linux-jdk/files/patch-ab
@@ -0,0 +1,22 @@
+--- jre/bin/.java_wrapper.orig Fri Apr 12 17:03:39 2002
++++ jre/bin/.java_wrapper Fri Apr 12 17:04:00 2002
+@@ -32,8 +32,8 @@
+ # Resolve symlinks. See 4152645.
+ while [ -L "$PRG" ]; do
+ ls=`ls -ld "$PRG"`
+- link=`expr "$ls" : '.*-> \(.*\)$'`
+- if expr "$link" : '/' > /dev/null; then
++ link=`/compat/linux/usr/bin/expr "$ls" : '.*-> \(.*\)$'`
++ if /compat/linux/usr/bin/expr "$link" : '/' > /dev/null; then
+ PRG="$link"
+ else
+ PRG="`dirname $PRG`/$link"
+@@ -65,7 +65,7 @@
+ # Select vm type (if classic vm, also select thread type).
+ unset vmtype
+ unset ttype
+-DEFAULT_THREADS_FLAG=native
++DEFAULT_THREADS_FLAG=green
+ if [ "x$1" = "x-hotspot" ]; then
+ vmtype=hotspot
+ ttype=native_threads