aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/metromap/Makefile1
-rw-r--r--misc/metromap/files/patch-python2747
2 files changed, 48 insertions, 0 deletions
diff --git a/misc/metromap/Makefile b/misc/metromap/Makefile
index 891c3d6bc171..cc2e6d59d359 100644
--- a/misc/metromap/Makefile
+++ b/misc/metromap/Makefile
@@ -7,6 +7,7 @@
PORTNAME= metromap
PORTVERSION= 0.1.3
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://metromap.antex.ru/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/misc/metromap/files/patch-python27 b/misc/metromap/files/patch-python27
new file mode 100644
index 000000000000..30d512e5c6ab
--- /dev/null
+++ b/misc/metromap/files/patch-python27
@@ -0,0 +1,47 @@
+--- modules/ReadMap.py 2010-07-01 11:22:36.000000000 +0400
++++ modules/ReadMap.py 2011-01-03 02:28:53.000000000 +0300
+@@ -85,7 +85,7 @@
+ return None
+
+ def GetMapName(ini):
+- cp = ConfigParser.RawConfigParser()
++ cp = ConfigParser.RawConfigParser(allow_no_value=True)
+ try:
+ cp.readfp(ini)
+ except:
+@@ -105,7 +105,7 @@
+ return None
+
+ def GetMapVec(ini):
+- cp = ConfigParser.RawConfigParser()
++ cp = ConfigParser.RawConfigParser(allow_no_value=True)
+ try:
+ cp.readfp(ini)
+ except:
+@@ -568,7 +568,7 @@
+ self.Graph[i] = filter(lambda a: a[0] not in uclist, self.Graph[i])
+
+ def _load_vec(self):
+- cp = ConfigParser.RawConfigParser()
++ cp = ConfigParser.RawConfigParser(allow_no_value=True)
+ try:
+ cp.readfp(self.vec)
+ except: #ConfigParser.readfp raises exception, when he thinks,
+@@ -594,7 +594,7 @@
+ self.Stations[st]['vfile'] = cp_get(cp, section, self.Stations[st]['name_orig'], None)
+
+ def _load(self):
+- cp = ConfigParser.RawConfigParser()
++ cp = ConfigParser.RawConfigParser(allow_no_value=True)
+ try:
+ cp.readfp(self.ini)
+ except: #ConfigParser.readfp raises exception, when he thinks,
+@@ -945,7 +945,7 @@
+ self.name = None
+ self.data = dict()
+ self.enc = encoding
+- cp = ConfigParser.RawConfigParser()
++ cp = ConfigParser.RawConfigParser(allow_no_value=True)
+ try:
+ cp.readfp(infodata)
+ except: \ No newline at end of file