aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/ucommon/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/devel/ucommon/Makefile b/devel/ucommon/Makefile
index 94a5b069556f..0ef2e0fc80af 100644
--- a/devel/ucommon/Makefile
+++ b/devel/ucommon/Makefile
@@ -13,16 +13,13 @@ LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
USES= compiler:c++11-lib cmake:outsource pathfix pkgconfig
-CMAKE_ARGS+= -DBUILD_TESTING:BOOL=ON \
- -DCMAKE_INSTALL_BINDIR:STRING=bin/${PORTNAME} \
- -DCMAKE_INSTALL_MANDIR:STRING=man
+CMAKE_ARGS= -DBUILD_TESTING:BOOL=ON \
+ -DCMAKE_INSTALL_BINDIR:STRING=bin/${PORTNAME}
USE_LDCONFIG= yes
USE_OPENSSL= yes
+TEST_TARGET= test
post-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/ucommon-config.h ${STAGEDIR}${PREFIX}/include/ucommon
-regression-test: build
- cd ${BUILD_WRKSRC}/test && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} test
-
.include <bsd.port.mk>