aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-furl/Makefile24
-rw-r--r--devel/py-furl/distinfo3
-rw-r--r--devel/py-furl/pkg-descr12
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2ca3073624e3..e6706f241e00 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4452,6 +4452,7 @@
SUBDIR += py-funcsigs
SUBDIR += py-functools32
SUBDIR += py-funcy
+ SUBDIR += py-furl
SUBDIR += py-fusefs
SUBDIR += py-fusepy
SUBDIR += py-future
diff --git a/devel/py-furl/Makefile b/devel/py-furl/Makefile
new file mode 100644
index 000000000000..000b22024958
--- /dev/null
+++ b/devel/py-furl/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= furl
+PORTVERSION= 2.0.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= gmm@tutanota.com
+COMMENT= Small Python library that makes parsing and manipulating URLs easy
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}orderedmultidict>0:devel/py-orderedmultidict@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}flake8>0:devel/py-flake8@${PY_FLAVOR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-furl/distinfo b/devel/py-furl/distinfo
new file mode 100644
index 000000000000..1366ba1688e7
--- /dev/null
+++ b/devel/py-furl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568134642
+SHA256 (furl-2.0.0.tar.gz) = fdcaedc1fb19a63d7d875b0105b0a5b496dd0989330d454a42bcb401fa5454ec
+SIZE (furl-2.0.0.tar.gz) = 42732
diff --git a/devel/py-furl/pkg-descr b/devel/py-furl/pkg-descr
new file mode 100644
index 000000000000..b4e6b142a4cd
--- /dev/null
+++ b/devel/py-furl/pkg-descr
@@ -0,0 +1,12 @@
+furl is a small Python library that makes parsing and
+manipulating URLs easy.
+
+Python's standard urllib and urlparse modules provide a number of URL
+related functions, but using these functions to perform common URL
+operations proves tedious. Furl makes parsing and manipulating URLs
+easy.
+
+Furl is well tested, Unlicensed in the public domain, and supports
+Python 2, Python 3, PyPy2, and PyPy3.
+
+WWW: https://github.com/gruns/furl