aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/tomenet/Makefile6
-rw-r--r--games/tomenet/files/patch-makefile2
2 files changed, 7 insertions, 1 deletions
diff --git a/games/tomenet/Makefile b/games/tomenet/Makefile
index c2fc931d4ec5..cd4515733ec6 100644
--- a/games/tomenet/Makefile
+++ b/games/tomenet/Makefile
@@ -31,6 +31,12 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
+.if ${OSVERSION} < 1000000
+LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+CFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
+.endif
+
post-install:
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/tomenet/files/patch-makefile b/games/tomenet/files/patch-makefile
index c88ac7f509b2..ca184a625d1f 100644
--- a/games/tomenet/files/patch-makefile
+++ b/games/tomenet/files/patch-makefile
@@ -5,7 +5,7 @@
# This is my compiler of choice, it seems to work most everywhere
#
-CC = gcc
-+CC = cc
++CC ?= cc
# For allowing #if..#else..#endif constructs in LUA files - C. Blue
# Note: The flags must contain