aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--java/intellij-pycharm/Makefile12
-rw-r--r--java/intellij-pycharm/distinfo6
-rw-r--r--java/intellij-pycharm/pkg-plist193
3 files changed, 79 insertions, 132 deletions
diff --git a/java/intellij-pycharm/Makefile b/java/intellij-pycharm/Makefile
index 0ffb6a02f03f..a886caec8ae5 100644
--- a/java/intellij-pycharm/Makefile
+++ b/java/intellij-pycharm/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pycharm
-PORTVERSION= 2017.1
+PORTVERSION= 2017.1.1
CATEGORIES= java devel python
MASTER_SITES= https://download.jetbrains.com/python/ \
http://download.jetbrains.com/python/
@@ -19,6 +19,8 @@ RUN_DEPENDS= intellij-fsnotifier>0:java/intellij-fsnotifier \
USE_JAVA= yes
JAVA_VERSION= 1.7+
+USES= python:run shebangfix
+SHEBANG_FILES= bin/printenv.py bin/restart.py
NO_ARCH= yes
NO_BUILD= yes
@@ -34,14 +36,12 @@ do-install:
# Linux/Windows/OS X only so remove them
@${RM} ${STAGEDIR}${DATADIR}/bin/fsnotifier \
${STAGEDIR}${DATADIR}/bin/fsnotifier-arm \
- ${STAGEDIR}${DATADIR}/bin/fsnotifier64 \
- ${STAGEDIR}${DATADIR}/bin/libbreakgen.so \
- ${STAGEDIR}${DATADIR}/bin/libbreakgen64.so \
+ ${STAGEDIR}${DATADIR}/bin/fsnotifier64
# Remove the bundled native Pty4J support libraries, they are replaced
# by java/intellij-pty4j
@${RM} -r ${STAGEDIR}${DATADIR}/lib/libpty
# Remove bundled linux-only JRE
- @${RM} -r ${STAGEDIR}${DATADIR}/jre
+ @${RM} -r ${STAGEDIR}${DATADIR}/jre64
@${RM} -r ${STAGEDIR}${DATADIR}/helpers/pydev/pydevd_attach_to_process
@${RM} ${STAGEDIR}${DATADIR}/lib/pty4j-0.5.jar
${INSTALL_SCRIPT} ${WRKDIR}/pycharm ${STAGEDIR}${PREFIX}/bin/
@@ -51,6 +51,6 @@ do-install:
# Disable filewatcher warning message on IDEA startup
${ECHO} "idea.filewatcher.disabled=true" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
# Use fsnotifier replacement provided by java/intellij-fsnotifier
-# ${ECHO} "idea.filewatcher.executable.path=${IDEA_HOME}/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
+ ${ECHO} "idea.filewatcher.executable.path=${IDEA_HOME}/bin/fsnotifier" >> ${STAGEDIR}${DATADIR}/bin/idea.properties
.include <bsd.port.mk>
diff --git a/java/intellij-pycharm/distinfo b/java/intellij-pycharm/distinfo
index f3967e827c36..9b0ee748564d 100644
--- a/java/intellij-pycharm/distinfo
+++ b/java/intellij-pycharm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490616875
-SHA256 (pycharm-community-2017.1.tar.gz) = 6669120b68873a0bcb7faf179ea79f7c2dd7eac34d377d1f574724604b70e692
-SIZE (pycharm-community-2017.1.tar.gz) = 195354973
+TIMESTAMP = 1492087190
+SHA256 (pycharm-community-2017.1.1.tar.gz) = 1300e15b760a05d0b41f7d85674c01368e37ac2b6215889badf8ab0adcf4a34b
+SIZE (pycharm-community-2017.1.1.tar.gz) = 195516714
diff --git a/java/intellij-pycharm/pkg-plist b/java/intellij-pycharm/pkg-plist
index 9b239dd996ab..7319a0a1106b 100644
--- a/java/intellij-pycharm/pkg-plist
+++ b/java/intellij-pycharm/pkg-plist
@@ -780,6 +780,7 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/pydev/tests_pydevd_python/_debugger_case_remote_1.py
%%DATADIR%%/helpers/pydev/tests_pydevd_python/_debugger_case_remote_2.py
%%DATADIR%%/helpers/pydev/tests_pydevd_python/_debugger_case_set_next_statement.py
+%%DATADIR%%/helpers/pydev/tests_pydevd_python/_many_names_example.py
%%DATADIR%%/helpers/pydev/tests_pydevd_python/_performance_1.py
%%DATADIR%%/helpers/pydev/tests_pydevd_python/_performance_2.py
%%DATADIR%%/helpers/pydev/tests_pydevd_python/_performance_3.py
@@ -1064,7 +1065,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2/cPickle.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/cStringIO.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/calendar.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/2/codecs.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/collections.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/commands.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/compileall.pyi
@@ -1130,7 +1130,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2/posixpath.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/pprint.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/pwd.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/2/quopri.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/random.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/re.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/repr.pyi
@@ -1146,7 +1145,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2/signal.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/smtplib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/socket.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/2/spwd.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/sqlite3/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/sqlite3/dbapi2.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/ssl.pyi
@@ -1155,6 +1153,7 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2/strop.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/struct.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/subprocess.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2/symbol.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/sys.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/tempfile.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/textwrap.pyi
@@ -1164,7 +1163,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2/tokenize.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/types.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/typing.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/2/unicodedata.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/unittest.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/urllib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/urllib2.pyi
@@ -1174,20 +1172,23 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2/wsgiref/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/wsgiref/types.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/wsgiref/validate.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/2/xxsubtype.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2/zlib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/_bisect.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/_heapq.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/argparse.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/asynchat.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/asyncore.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/binhex.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/bisect.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/bz2.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/cProfile.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/cgi.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/cmath.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/code.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/codecs.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/colorsys.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/contextlib.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/dis.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/distutils/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/distutils/archive_util.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/distutils/bcppcompiler.pyi
@@ -1235,7 +1236,9 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2and3/distutils/util.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/distutils/version.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/errno.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/filecmp.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/fractions.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/ftplib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/hmac.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/keyword.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/locale.pyi
@@ -1247,21 +1250,40 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/2and3/mimetypes.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/mmap.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/numbers.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/opcode.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/operator.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/pkgutil.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/plistlib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/profile.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/pstats.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/py_compile.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/pyclbr.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/quopri.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/readline.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/rlcompleter.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/site.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/sndhdr.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/spwd.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/stringprep.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/sunau.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/symtable.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/sysconfig.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/syslog.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/tabnanny.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/tarfile.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/telnetlib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/termios.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/threading.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/timeit.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/trace.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/traceback.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/tty.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/unicodedata.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/uu.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/warnings.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/wave.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/webbrowser.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/2and3/xdrlib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/xml/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/xml/etree/ElementInclude.pyi
%%DATADIR%%/helpers/typeshed/stdlib/2and3/xml/etree/ElementPath.pyi
@@ -1291,6 +1313,9 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3.4/enum.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3.4/pathlib.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3.4/selectors.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/3.4/statistics.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/3.4/tracemalloc.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/3.5/zipapp.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3.6/secrets.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/__future__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/_ast.pyi
@@ -1315,10 +1340,9 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3/binascii.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/builtins.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/calendar.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/cgi.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/codecs.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/collections/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/collections/abc.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/3/compileall.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/concurrent/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/concurrent/futures/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/concurrent/futures/_base.pyi
@@ -1331,7 +1355,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3/datetime.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/decimal.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/difflib.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/dis.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/doctest.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/email/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/email/charset.pyi
@@ -1394,7 +1417,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3/multiprocessing/managers.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/multiprocessing/pool.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/multiprocessing/process.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/opcode.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/os/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/os/path.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/pdb.pyi
@@ -1405,7 +1427,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3/posixpath.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/pprint.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/pwd.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/pyclbr.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/queue.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/random.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/re.pyi
@@ -1426,8 +1447,8 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3/string.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/struct.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/subprocess.pyi
+%%DATADIR%%/helpers/typeshed/stdlib/3/symbol.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/sys.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/sysconfig.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/tempfile.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/textwrap.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/time.pyi
@@ -1438,7 +1459,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/stdlib/3/tokenize.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/types.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/typing.pyi
-%%DATADIR%%/helpers/typeshed/stdlib/3/unicodedata.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/unittest/__init__.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/unittest/mock.pyi
%%DATADIR%%/helpers/typeshed/stdlib/3/urllib/__init__.pyi
@@ -1506,41 +1526,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/third_party/2/redis/connection.pyi
%%DATADIR%%/helpers/typeshed/third_party/2/redis/exceptions.pyi
%%DATADIR%%/helpers/typeshed/third_party/2/redis/utils.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/adapters.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/api.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/auth.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/compat.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/cookies.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/exceptions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/hooks.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/models.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/_collections.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/connection.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/connectionpool.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/contrib/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/exceptions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/fields.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/filepost.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/packages/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/packages/ssl_match_hostname/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/packages/ssl_match_hostname/_implementation.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/poolmanager.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/request.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/response.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/connection.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/request.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/response.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/retry.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/timeout.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/packages/urllib3/util/url.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/sessions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/status_codes.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/structures.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2/requests/utils.pyi
%%DATADIR%%/helpers/typeshed/third_party/2/routes/__init__.pyi
%%DATADIR%%/helpers/typeshed/third_party/2/routes/mapper.pyi
%%DATADIR%%/helpers/typeshed/third_party/2/routes/util.pyi
@@ -1777,46 +1762,43 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/third_party/2and3/pymysql/util.pyi
%%DATADIR%%/helpers/typeshed/third_party/2and3/pytz/__init__.pyi
%%DATADIR%%/helpers/typeshed/third_party/2and3/pytz/lazy.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/adapters.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/api.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/auth.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/compat.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/cookies.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/exceptions.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/hooks.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/models.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/_collections.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/connection.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/connectionpool.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/contrib/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/exceptions.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/fields.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/filepost.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/packages/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/packages/ssl_match_hostname/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/packages/ssl_match_hostname/_implementation.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/poolmanager.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/request.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/response.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/__init__.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/connection.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/request.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/response.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/retry.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/ssl_.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/timeout.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/packages/urllib3/util/url.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/sessions.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/status_codes.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/structures.pyi
+%%DATADIR%%/helpers/typeshed/third_party/2and3/requests/utils.pyi
%%DATADIR%%/helpers/typeshed/third_party/2and3/singledispatch.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/databases/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/databases/mysql.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/dialects/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/dialects/mysql/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/dialects/mysql/base.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/engine/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/engine/base.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/engine/strategies.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/engine/url.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/exc.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/inspection.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/log.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/orm/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/orm/session.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/orm/util.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/pool.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/schema.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/annotation.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/base.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/ddl.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/dml.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/elements.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/expression.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/functions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/naming.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/operators.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/schema.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/selectable.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/sqltypes.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/type_api.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/sql/visitors.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/types.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/util/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/util/_collections.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/util/compat.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/util/deprecations.pyi
-%%DATADIR%%/helpers/typeshed/third_party/2and3/sqlalchemy/util/langhelpers.pyi
%%DATADIR%%/helpers/typeshed/third_party/2and3/ujson.pyi
%%DATADIR%%/helpers/typeshed/third_party/3.6/click/README.md
%%DATADIR%%/helpers/typeshed/third_party/3.6/click/__init__.pyi
@@ -1849,42 +1831,6 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/helpers/typeshed/third_party/3/lxml/etree.pyi
%%DATADIR%%/helpers/typeshed/third_party/3/lxml/objectify.pyi
%%DATADIR%%/helpers/typeshed/third_party/3/pkg_resources.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/adapters.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/api.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/auth.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/compat.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/cookies.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/exceptions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/hooks.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/models.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/_collections.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/connection.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/connectionpool.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/contrib/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/exceptions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/fields.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/filepost.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/packages/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/packages/ssl_match_hostname/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/packages/ssl_match_hostname/_implementation.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/poolmanager.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/request.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/response.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/__init__.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/connection.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/request.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/response.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/retry.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/ssl_.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/timeout.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/packages/urllib3/util/url.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/sessions.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/status_codes.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/structures.pyi
-%%DATADIR%%/helpers/typeshed/third_party/3/requests/utils.pyi
%%DATADIR%%/helpers/typeshed/third_party/3/six/__init__.pyi
%%DATADIR%%/helpers/typeshed/third_party/3/six/moves/__init__.pyi
%%DATADIR%%/helpers/typeshed/third_party/3/six/moves/cPickle.pyi
@@ -2000,7 +1946,7 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/lib/miglayout-core-5.0.jar
%%DATADIR%%/lib/miglayout-swing-5.0.jar
%%DATADIR%%/lib/nanoxml-2.2.3.jar
-%%DATADIR%%/lib/netty-all-4.1.6.Final.Patched.jar
+%%DATADIR%%/lib/netty-all-4.1.9.Final.jar
%%DATADIR%%/lib/openapi.jar
%%DATADIR%%/lib/oromatcher.jar
%%DATADIR%%/lib/picocontainer.jar
@@ -2065,6 +2011,7 @@ share/applications/pycharm-ce.desktop
%%DATADIR%%/license/sqljet-license.txt
%%DATADIR%%/license/svnkit-license.txt
%%DATADIR%%/license/swingx_license.txt
+%%DATADIR%%/license/trove4j_license.txt
%%DATADIR%%/license/winp_license.txt
%%DATADIR%%/license/xerces_license.txt
%%DATADIR%%/license/xmlrpc_license.txt