aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/Makefile1
-rw-r--r--mail/wbl/Makefile39
-rw-r--r--mail/wbl/distinfo3
-rw-r--r--mail/wbl/pkg-descr11
4 files changed, 54 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index d80fffde8e78..1feea8a5345d 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -580,6 +580,7 @@
SUBDIR += wanderlust
SUBDIR += wanderlust-emacs20
SUBDIR += wanderlust-xemacs21-mule
+ SUBDIR += wbl
SUBDIR += websieve
SUBDIR += whoson
SUBDIR += wmbiff
diff --git a/mail/wbl/Makefile b/mail/wbl/Makefile
new file mode 100644
index 000000000000..43fc5dbaf294
--- /dev/null
+++ b/mail/wbl/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: wbl
+# Date created: 2006-07-15
+# Whom: Renato Botelho <garga@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wbl
+PORTVERSION= 1.1
+CATEGORIES= mail
+MASTER_SITES= http://www.technocage.com/~caskey/wbl/download/
+
+MAINTAINER= garga@localhost.bsd
+COMMENT= Simple tool to manage white/black list on qmail
+
+USE_BZIP2= yes
+USE_PERL5_RUN= yes
+USE_QMAIL_RUN= yes
+NO_BUILD= yes
+
+PORTDOCS= CHANGELOG COPYING README
+PLIST_FILES= bin/wbl
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/bin/perl,${PERL},' \
+ -e 's,/var/qmail,${QMAIL_PREFIX},g' \
+ -e 's,/bin/cat,${CAT},g' \
+ ${WRKSRC}/wbl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/wbl ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/wbl/distinfo b/mail/wbl/distinfo
new file mode 100644
index 000000000000..bdc4ba0303b5
--- /dev/null
+++ b/mail/wbl/distinfo
@@ -0,0 +1,3 @@
+MD5 (wbl-1.1.tar.bz2) = 7aa89f3098f8803d48d79b992412278a
+SHA256 (wbl-1.1.tar.bz2) = b6cbfb2870747d65399a01378447b029e23695f999089f2b40f236ee1906f9e0
+SIZE (wbl-1.1.tar.bz2) = 7653
diff --git a/mail/wbl/pkg-descr b/mail/wbl/pkg-descr
new file mode 100644
index 000000000000..718ecad61ff5
--- /dev/null
+++ b/mail/wbl/pkg-descr
@@ -0,0 +1,11 @@
+wbl is a really simple tool that can be used in a .qmail file for managing
+a white/black list of email addresses. It only does one thing--it
+checks for entries in ~/.wbl that it uses as a regex against the From:
+field of an incoming email. If it matches a line with a +, it forwards
+the email to the white list, if it matches a line with a - it forwards
+the email to the blacklist.
+
+Questions, feedback, comments may be sent to the author.
+
+Author: Caskey Dickson <caskey@technocage.com>
+WWW: http://www.technocage.com/~caskey/wbl/