aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/xmorph/Makefile18
-rw-r--r--graphics/xmorph/distinfo6
-rw-r--r--graphics/xmorph/files/patch-Makefile.in12
-rw-r--r--graphics/xmorph/pkg-plist6
4 files changed, 28 insertions, 14 deletions
diff --git a/graphics/xmorph/Makefile b/graphics/xmorph/Makefile
index 37a75798c840..2fc36c112c78 100644
--- a/graphics/xmorph/Makefile
+++ b/graphics/xmorph/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xmorph
-PORTVERSION= 2004.01.10
-PORTREVISION= 2
+PORTVERSION= 2006.03.04
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,16 +15,20 @@ DISTNAME= ${PORTNAME}_${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= A digital image warping program
-WRKSRC= ${WRKDIR}/${PORTNAME}-current
+LIB_DEPENDS= fftw3.3:${PORTSDIR}/math/fftw3
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.//g}
CONFLICTS= libmorph*
USE_X_PREFIX= yes
WANT_GNOME= yes
-USE_GNOME= gnometarget lthack
+USE_GNOME= gnometarget
+USE_GCC= 3.4+
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ARGS= --without-waili
INSTALLS_SHLIB= yes
MAN1= xmorph.1
@@ -33,6 +36,10 @@ INFO= xmorph
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 502114
+CFLAGS+= -Dround=rint
+.endif
+
# XXX Seems that gtkmorph.1 is always installed
MAN1+= gtkmorph.1
.if ${HAVE_GNOME:Mgtk20}!=""
@@ -53,6 +60,9 @@ PLIST_SUB+= NLS=""
post-extract:
@${RM} -f ${WRKSRC}/doc/*.info*
+post-patch:
+ @${REINPLACE_CMD} -e 's|^LDFLAGS=|#LDFLAGS=|g' ${WRKSRC}/configure
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
diff --git a/graphics/xmorph/distinfo b/graphics/xmorph/distinfo
index 68154bf04f3c..2a42276c7994 100644
--- a/graphics/xmorph/distinfo
+++ b/graphics/xmorph/distinfo
@@ -1,3 +1,3 @@
-MD5 (xmorph_20040110.tar.gz) = f0fec1ab474649fbbc74f04e2b151e19
-SHA256 (xmorph_20040110.tar.gz) = 52bf534308b1176b1e21905ae1cc3b4f6b0ee8942db953b7e76fd13d698b5066
-SIZE (xmorph_20040110.tar.gz) = 1146523
+MD5 (xmorph_20060304.tar.gz) = 3015ab664658c81430036b8dac8be554
+SHA256 (xmorph_20060304.tar.gz) = 45b8897fe5906a251be0ff89b1975862abbfadffa194f5d45ee7a2ae1f1fbf42
+SIZE (xmorph_20060304.tar.gz) = 1548516
diff --git a/graphics/xmorph/files/patch-Makefile.in b/graphics/xmorph/files/patch-Makefile.in
index d8128c9222a4..ce043c152696 100644
--- a/graphics/xmorph/files/patch-Makefile.in
+++ b/graphics/xmorph/files/patch-Makefile.in
@@ -1,9 +1,9 @@
---- Makefile.in.orig Tue Jan 13 00:29:21 2004
-+++ Makefile.in Sun Mar 14 02:13:28 2004
-@@ -763,12 +763,6 @@
+--- Makefile.in.orig Sun Mar 5 20:54:29 2006
++++ Makefile.in Sun Apr 23 15:13:07 2006
+@@ -795,12 +795,6 @@
+ $(INSTALL_DATA) $$pixmap $(DESTDIR)$(pkgdatadir)/pixmaps; \
fi \
- done \
- fi
+ done
- cd example; for i in * ;\
- do $(INSTALL) -d $(DESTDIR)$(pkgdatadir)/example/$$i ;\
- for j in $$i/* ;\
@@ -12,4 +12,4 @@
- done
dist-hook:
- if test -d pixmaps; then \
+ cp -a example pixmaps debian $(distdir)/
diff --git a/graphics/xmorph/pkg-plist b/graphics/xmorph/pkg-plist
index b31fbf354b80..5471da9ca77c 100644
--- a/graphics/xmorph/pkg-plist
+++ b/graphics/xmorph/pkg-plist
@@ -5,6 +5,7 @@ bin/xmorph
include/xmorph/RgbaImage.h
include/xmorph/mesh-getext.h
include/xmorph/mesh.h
+include/xmorph/mesh_t.h
include/xmorph/my_malloc.h
include/xmorph/relax.h
include/xmorph/resample.h
@@ -30,6 +31,8 @@ lib/libmorph.so.1
%%PORTDOCS%%%%EXAMPLESDIR%%/AA/grid.ppm
%%PORTDOCS%%%%EXAMPLESDIR%%/AA/grid.ppm.mesh
%%PORTDOCS%%%%EXAMPLESDIR%%/AA/gtkmorph.session
+%%PORTDOCS%%%%EXAMPLESDIR%%/AD/1-to-2.mesh
+%%PORTDOCS%%%%EXAMPLESDIR%%/AD/2-to-1.mesh
%%PORTDOCS%%%%EXAMPLESDIR%%/AD/README
%%PORTDOCS%%%%EXAMPLESDIR%%/AD/gtkmorph.session
%%PORTDOCS%%%%EXAMPLESDIR%%/AD/image1.png
@@ -49,8 +52,9 @@ lib/libmorph.so.1
%%PORTDOCS%%%%EXAMPLESDIR%%/AD_freeborder/image2.png
%%PORTDOCS%%%%EXAMPLESDIR%%/AD_freeborder/image2.png.mesh
%%PORTDOCS%%%%EXAMPLESDIR%%/AD_freeborder/image2.png.meshtmp
+%%NLS%%share/locale/fr/LC_MESSAGES/xmorph.mo
%%NLS%%share/locale/it/LC_MESSAGES/xmorph.mo
-%%GNOME:%%%%DATADIR%%/mpeg.param
+%%DATADIR%%/mpeg.param
%%DATADIR%%/pixmaps/cursor_left.xpm
%%DATADIR%%/pixmaps/eraser.xpm
%%DATADIR%%/pixmaps/example.xpm