aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/grub2-efi/Makefile5
-rw-r--r--sysutils/grub2-pcbsd/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/sysutils/grub2-efi/Makefile b/sysutils/grub2-efi/Makefile
index 754cf188a39c..5d2ea5f7ed39 100644
--- a/sysutils/grub2-efi/Makefile
+++ b/sysutils/grub2-efi/Makefile
@@ -26,10 +26,13 @@ USE_GCC= yes
USE_AUTOTOOLS= automake aclocal autoconf
ACLOCAL_ARGS= -Im4
GNU_CONFIGURE= yes
-USES= bison gettext gmake python tar:xz
+USES= bison cpe gettext gmake python tar:xz
ONLY_FOR_ARCHS= amd64
MAKE_JOBS_UNSAFE= yes
+CPE_PRODUCT= grub
+CPE_VENDOR= gnu
+
CONFIGURE_ARGS= --with-platform=efi --disable-werror --localedir=${PREFIX}/share/locale
CONFIGURE_ENV= CPP="${CC} -E" \
LEX=${LOCALBASE}/bin/flex
diff --git a/sysutils/grub2-pcbsd/Makefile b/sysutils/grub2-pcbsd/Makefile
index fbb78df30d15..b7f433ff5535 100644
--- a/sysutils/grub2-pcbsd/Makefile
+++ b/sysutils/grub2-pcbsd/Makefile
@@ -25,11 +25,14 @@ USE_GCC= yes
USE_AUTOTOOLS= automake aclocal autoconf
ACLOCAL_ARGS= -Im4
GNU_CONFIGURE= yes
-USES= bison gettext gmake makeinfo python tar:xz
+USES= bison cpe gettext gmake makeinfo python tar:xz
ONLY_FOR_ARCHS= i386 amd64
INFO= grub grub-dev
MAKE_JOBS_UNSAFE= yes
+CPE_PRODUCT= grub
+CPE_VENDOR= gnu
+
CONFIGURE_ARGS= --disable-werror --localedir=${PREFIX}/share/locale
CONFIGURE_ENV= CPP="${CC} -E" \
LEX=${LOCALBASE}/bin/flex