aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/userinfo/Makefile14
-rw-r--r--sysutils/userinfo/files/patch-src::common.h10
-rw-r--r--sysutils/userinfo/files/patch-src::process.c27
3 files changed, 40 insertions, 11 deletions
diff --git a/sysutils/userinfo/Makefile b/sysutils/userinfo/Makefile
index 5296a974061f..deece1ebd3ad 100644
--- a/sysutils/userinfo/Makefile
+++ b/sysutils/userinfo/Makefile
@@ -14,19 +14,11 @@ MAINTAINER= bjk@m-net.arbornet.org
COMMENT= Show information about local users
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= ui.1
-MANCOMPRESSED= no
-
-CONFIGURE_TARGET=
pre-build:
- ${CP} ${WRKSRC}/doc/ui.man ${WRKSRC}/doc/ui.1
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
-BROKEN= "Doesn't work on 5.x, mainainter informed - 2003-04-07"
-.endif
+ ${MV} ${WRKSRC}/doc/ui.man ${WRKSRC}/doc/ui.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/userinfo/files/patch-src::common.h b/sysutils/userinfo/files/patch-src::common.h
new file mode 100644
index 000000000000..b1f813cb3883
--- /dev/null
+++ b/sysutils/userinfo/files/patch-src::common.h
@@ -0,0 +1,10 @@
+--- src/common.h.orig Sat Jun 14 02:45:40 2003
++++ src/common.h Sat Jun 14 02:21:13 2003
+@@ -16,6 +16,7 @@
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <sys/types.h>
+ #include <pwd.h>
+ #include "config.h"
+
diff --git a/sysutils/userinfo/files/patch-src::process.c b/sysutils/userinfo/files/patch-src::process.c
new file mode 100644
index 000000000000..092666d5683c
--- /dev/null
+++ b/sysutils/userinfo/files/patch-src::process.c
@@ -0,0 +1,27 @@
+--- src/process.c.orig Sat Jun 14 02:33:21 2003
++++ src/process.c Sat Jun 14 02:42:29 2003
+@@ -63,15 +63,24 @@
+ }
+
+ for (i = 0; i < cnt; i++) {
++#if __FreeBSD_version < 500000
+ if (kp[i].kp_eproc.e_flag & EPROC_SLEADER && kp[i].kp_eproc.e_tdev !=
+ -1) {
+ pid = kp[i].kp_proc.p_pid;
++#else
++ if (kp[i].ki_kiflag & KI_SLEADER && kp[i].ki_tdev != -1) {
++ pid = kp[i].ki_pid;
++#endif
+ break;
+ }
+ }
+
+ if (!pid)
++#if __FreeBSD_version < 500000
+ pid = kp[0].kp_eproc.e_ppid;
++#else
++ pid = kp[0].ki_ppid;
++#endif
+
+ return (pid > 1) ? pid : -1;
+ }