aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/grepip/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-mgmt/grepip/Makefile b/net-mgmt/grepip/Makefile
index 2a14cfafe425..ace10eeccc06 100644
--- a/net-mgmt/grepip/Makefile
+++ b/net-mgmt/grepip/Makefile
@@ -11,22 +11,22 @@ MASTER_SITES= http://komquats.com/distfiles/ \
MAINTAINER= cy@FreeBSD.org
COMMENT= Print lines contans IP matching a pattern in CIDR format
-LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
PLIST_FILES= bin/grepip
PORTDOCS= README.txt
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-build:
cd ${WRKSRC}; \
${CC} ${CFLAGS} -c patricia.c; \
- ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o -L${LOCALBASE}/lib -lpcre
+ ${CC} ${CFLAGS} -I${LOCALBASE}/include -o grepip grepip.c patricia.o \
+ -L${LOCALBASE}/lib -lpcre
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/grepip ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/grepip ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>