aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile18
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist3
2 files changed, 11 insertions, 10 deletions
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
index 8d197c706985..2aa2831becdf 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/Makefile
@@ -20,17 +20,19 @@ BUILD_DEPENDS= p5-POE>=0.37:${PORTSDIR}/devel/p5-POE \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
-USES= perl5
+
+USES= perl5 shebangfix
USE_PERL5= configure
-MAN3= POE::Component::IRC::Plugin::Blowfish.3
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= synopsis.pl
+SHEBANG_FILES= examples/synopsis.pl
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.ifndef(NOPORTEXAMPLES)
- @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist
index ab02c204d75e..a7aba16eb393 100644
--- a/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist
+++ b/irc/p5-POE-Component-IRC-Plugin-Blowfish/pkg-plist
@@ -1,7 +1,6 @@
%%SITE_PERL%%/POE/Component/IRC/Plugin/Blowfish.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Blowfish/.packlist
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PERL5_MAN3%%/POE::Component::IRC::Plugin::Blowfish.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Blowfish
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC