aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/nxtvepg/Makefile5
-rw-r--r--multimedia/nxtvepg/distinfo4
-rw-r--r--multimedia/nxtvepg/files/patch-Makefile15
-rw-r--r--multimedia/nxtvepg/files/patch-Makefile.bsd52
-rw-r--r--multimedia/nxtvepg/files/patch-tcl2c.c19
-rw-r--r--multimedia/nxtvepg/files/patch-tvsim::tvsim_main.c52
-rw-r--r--multimedia/nxtvepg/pkg-plist10
7 files changed, 81 insertions, 76 deletions
diff --git a/multimedia/nxtvepg/Makefile b/multimedia/nxtvepg/Makefile
index 8ee166412c61..f505713cd5e0 100644
--- a/multimedia/nxtvepg/Makefile
+++ b/multimedia/nxtvepg/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nxtvepg
-PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTVERSION= 2.7.1
CATEGORIES= multimedia tcl84 tk84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
@@ -20,7 +19,7 @@ LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
USE_GMAKE= yes
USE_XLIB= yes
USE_X_PREFIX= yes
-MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS}
+MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} WRKSRC=${WRKSRC}
MAN1= nxtvepg.1
MYPORTDOCS= README TODO CHANGES manual.html
diff --git a/multimedia/nxtvepg/distinfo b/multimedia/nxtvepg/distinfo
index a7d7785a584b..b694fe9e15ce 100644
--- a/multimedia/nxtvepg/distinfo
+++ b/multimedia/nxtvepg/distinfo
@@ -1,2 +1,2 @@
-MD5 (nxtvepg-2.6.0.tar.gz) = 9d7efd6b19f95274c002f19b92bcd9da
-SIZE (nxtvepg-2.6.0.tar.gz) = 1129008
+MD5 (nxtvepg-2.7.1.tar.gz) = 7625d7e9d4a57ab58277e7edb073f931
+SIZE (nxtvepg-2.7.1.tar.gz) = 1217393
diff --git a/multimedia/nxtvepg/files/patch-Makefile b/multimedia/nxtvepg/files/patch-Makefile
index 80afbb8de831..6fe995b92732 100644
--- a/multimedia/nxtvepg/files/patch-Makefile
+++ b/multimedia/nxtvepg/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Thu Oct 9 21:09:22 2003
-+++ Makefile Tue Oct 21 12:57:04 2003
+--- Makefile.orig Sun Jul 18 15:00:26 2004
++++ Makefile Fri Jul 30 16:34:23 2004
@@ -43,12 +43,24 @@
include Makefile.bsd
else
@@ -27,7 +27,7 @@
# if you have perl set the path here, else just leave it alone
PERL = /usr/bin/perl
-@@ -92,10 +104,10 @@
+@@ -104,10 +116,10 @@
# The database directory can be either in the user's $HOME (or relative to any
# other env variable) or at a global place like /var/spool (world-writable)
# -> uncomment 2 lines below to put the databases in the user's home
@@ -41,3 +41,12 @@
DEFS += -DEPG_DB_DIR=\"$(SYS_DBDIR)\"
INST_DB_DIR = $(ROOT)$(SYS_DBDIR)
INST_DB_PERM = 0777
+@@ -121,7 +133,7 @@
+ CFLAGS += $(WARN) $(INCS) $(DEFS)
+ #LDLIBS += -pg
+
+-BUILD_DIR = build-$(shell uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/')
++BUILD_DIR ?= build-$(shell uname -m | sed -e 's/i.86/i386/' -e 's/ppc/powerpc/')
+ INCS += -I$(BUILD_DIR)
+
+ # end Linux specific part
diff --git a/multimedia/nxtvepg/files/patch-Makefile.bsd b/multimedia/nxtvepg/files/patch-Makefile.bsd
index b0226b5535ac..73d6515c516e 100644
--- a/multimedia/nxtvepg/files/patch-Makefile.bsd
+++ b/multimedia/nxtvepg/files/patch-Makefile.bsd
@@ -1,46 +1,10 @@
---- Makefile.bsd.orig Mon Apr 21 00:10:22 2003
-+++ Makefile.bsd Tue Oct 21 15:10:24 2003
-@@ -46,17 +46,20 @@
- # other settings
- # On FreeBSD there is only a modified tclsh with a message to launch
- # tclsh8.3 or tclsh8.4 , so this is hardcoded here
--TCL_VER = 8.3
-+TCL_VER = 8.4
- LDLIBS = -L$(LOCALBASE)/lib\
- -L$(X11BASE)/lib\
-- -ltk83 -ltcl83 -lX11 -lXmu -lm
-+ -ltk84 -ltcl84 -lX11 -lXmu -lm
+--- Makefile.bsd.orig Fri Jul 30 16:35:54 2004
++++ Makefile.bsd Fri Jul 30 16:36:04 2004
+@@ -127,6 +127,7 @@
+ CFLAGS ?= $(OPTFLAGS)
+ CFLAGS += $(WARN) $(INCS) $(DEFS)
+ #LDLIBS += -pg
++BUILD_DIR= ${WRKSRC}
- INCS += -I$(LOCALBASE)/include/tcl$(TCL_VER)\
- -I$(LOCALBASE)/include/tk$(TCL_VER)
--WANT_THREADS = 1 # uncomment to force process based implementation
--
--PTHREAD = -pthread
-+WANT_THREADS = 1 # comment out to force process based implementation
+ all :: printconfig
-+ifeq ($(OS), FreeBSD)
-+PTHREAD = $(PTHREAD_LIBS)
-+else
-+PTHREAD = -pthread
-+endif
-
- ### Common part for all UN*X variants ###
-
-@@ -77,7 +80,7 @@
- endif
-
- # other settings
--OPTFLAGS = -O6 -pipe -g
-+OPTFLAGS = -O -pipe -g
-
- # use static libraries for debugging only
- #LDLIBS += -Ldbglib -static
-@@ -143,7 +146,7 @@
- $(ECHO) " system db dir: $(SYS_DBDIR)"
- endif
- ifdef WANT_THREADS
-- $(ECHO) " Concurrency implementation based on: threads"
-+ $(ECHO) " Concurrency implementation based on: threads (using $(PTHREAD))"
- else
- $(ECHO) " Concurrency implementation based on: processes"
- endif
diff --git a/multimedia/nxtvepg/files/patch-tcl2c.c b/multimedia/nxtvepg/files/patch-tcl2c.c
deleted file mode 100644
index d6eab5c1887d..000000000000
--- a/multimedia/nxtvepg/files/patch-tcl2c.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- tcl2c.c.orig Tue Sep 23 21:49:35 2003
-+++ tcl2c.c Tue Oct 21 13:14:35 2003
-@@ -50,6 +50,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <stdio.h>
-+#include <time.h>
- #include <errno.h>
- #include <time.h>
- #include <ctype.h>
-@@ -429,6 +430,8 @@
- scriptName = malloc(fileNameLen + 1);
- strncpy(outNameC, inFileName, fileNameLen - 4);
- strncpy(outNameH, inFileName, fileNameLen - 4);
-+ outNameC[fileNameLen-4]=0;
-+ outNameH[fileNameLen-4]=0;
- baseName = (char *)strrchr(inFileName, '/');
- if (baseName != NULL)
- {
diff --git a/multimedia/nxtvepg/files/patch-tvsim::tvsim_main.c b/multimedia/nxtvepg/files/patch-tvsim::tvsim_main.c
new file mode 100644
index 000000000000..52442bf286b4
--- /dev/null
+++ b/multimedia/nxtvepg/files/patch-tvsim::tvsim_main.c
@@ -0,0 +1,52 @@
+--- tvsim/tvsim_main.c.orig Fri Jul 30 16:37:05 2004
++++ tvsim/tvsim_main.c Fri Jul 30 17:00:10 2004
+@@ -63,6 +63,9 @@
+ #include "tvsim/tvsim_gui.h"
+ #include "tvsim/tvsim_version.h"
+
++#if defined(__FreeBSD__) || defined(__NetBSD__)
++#include <machine/ioctl_bt848.h>
++#endif
+
+ // prior to 8.4 there's a SEGV when evaluating const scripts (Tcl tries to modify the string)
+ #if (TCL_MAJOR_VERSION > 8) || ((TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION >= 4))
+@@ -493,7 +496,6 @@
+ }
+
+ #else // __NetBSD__ || __FreeBSD__
+- char * pDevName;
+ ulong lfreq;
+ uint norm;
+ bool result = FALSE;
+@@ -505,26 +507,26 @@
+ {
+ if ( (*pIsTuner) && (lfreq != 0) )
+ {
+- if (tuner_fd != -1)
++ if (video_fd != -1)
+ {
+ // mute audio
+ int mute_arg = AUDIO_MUTE;
+- if (ioctl (tuner_fd, BT848_SAUDIO, &mute_arg) == 0)
++ if (ioctl (video_fd, BT848_SAUDIO, &mute_arg) == 0)
+ {
+ dprintf0("Muted tuner audio.\n");
+ }
+ else
+- fprintf(stderr, "muting audio (ioctl AUDIO_MUTE)\n", strerror(errno));
++ fprintf(stderr, "muting audio (ioctl AUDIO_MUTE): %s\n", strerror(errno));
+
+ // Set the tuner frequency
+- if(ioctl(tuner_fd, VIDIOCSFREQ, &lfreq) == 0)
++ if(ioctl(video_fd, TVTUNER_SETFREQ, &lfreq) == 0)
+ {
+ dprintf1("Vbi-TuneChannel: set to %.2f\n", (double)freq/16);
+
+ result = TRUE;
+ }
+ else
+- fprintf(stderr, "setting tuner frequency (ioctl VIDIOCSFREQ): \n", strerror(errno));
++ fprintf(stderr, "setting tuner frequency (ioctl TVTUNER_SETFREQ): %s\n", strerror(errno));
+ }
+ }
+ }
diff --git a/multimedia/nxtvepg/pkg-plist b/multimedia/nxtvepg/pkg-plist
index c94f48959bce..432a05a1dd76 100644
--- a/multimedia/nxtvepg/pkg-plist
+++ b/multimedia/nxtvepg/pkg-plist
@@ -1,7 +1,7 @@
bin/nxtvepg
lib/X11/app-defaults/Nxtvepg
-%%PORTDOCS%%share/doc/nxtvepg/README
-%%PORTDOCS%%share/doc/nxtvepg/TODO
-%%PORTDOCS%%share/doc/nxtvepg/CHANGES
-%%PORTDOCS%%share/doc/nxtvepg/manual.html
-@dirrm share/doc/nxtvepg
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/manual.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%