aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 4b9aa59be30f..a87a902c980f 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -1401,6 +1401,7 @@ PKGCOMPATDIR?= ${LOCALBASE}/lib/compat/pkg
# XXX to remain undefined until all ports that require Perl are fixed
# to set one of the conditionals that force the inclusion of bsd.perl.mk
+_PERL_REFACTORING_COMPLETE= BEING_TESTED
.if !defined(_PERL_REFACTORING_COMPLETE)
PERL_VERSION?= 5.8.8
@@ -1470,13 +1471,13 @@ PERL= ${LOCALBASE}/bin/perl
.endif
.endif
-#.if defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
+.if defined(WANT_PERL) || defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
.if exists(${DEVELPORTSDIR}/Mk/bsd.perl.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.perl.mk"
.else
.include "${PORTSDIR}/Mk/bsd.perl.mk"
.endif
-#.endif
+.endif
.if defined(USE_PHP)
.if exists(${DEVELPORTSDIR}/Mk/bsd.php.mk)
@@ -2122,13 +2123,13 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
.endif
.endif
-#.if defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
+.if defined(WANT_PERL) || defined(USE_PERL5) || defined(USE_PERL5_BUILD) || defined(USE_PERL5_RUN) || defined(PERL_CONFIGURE) || defined(PERL_MODBUILD)
.if exists(${DEVELPORTSDIR}/Mk/bsd.perl.mk)
.include "${DEVELPORTSDIR}/Mk/bsd.perl.mk"
.else
.include "${PORTSDIR}/Mk/bsd.perl.mk"
.endif
-#.endif
+.endif
.if defined(USE_PHP)
.if exists(${DEVELPORTSDIR}/Mk/bsd.php.mk)