aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mbone/mcl/distinfo1
-rw-r--r--mbone/mcl/files/patch-Makefile.common2
-rw-r--r--mbone/mcl/files/patch-flute-Makefile4
-rw-r--r--net/mcl/distinfo1
-rw-r--r--net/mcl/files/patch-Makefile.common2
-rw-r--r--net/mcl/files/patch-flute-Makefile4
6 files changed, 8 insertions, 6 deletions
diff --git a/mbone/mcl/distinfo b/mbone/mcl/distinfo
index d66d0a1a90d0..c2499bb901b5 100644
--- a/mbone/mcl/distinfo
+++ b/mbone/mcl/distinfo
@@ -1,2 +1,3 @@
MD5 (mcl_v2.99.1.tgz) = d4a5c0c384d45dfa6c2a3dcbdcb3a81e
+SHA256 (mcl_v2.99.1.tgz) = 141966bf922c2995a29eeb73a536ee3f83438835b0f29f99afb626048decdc35
SIZE (mcl_v2.99.1.tgz) = 368784
diff --git a/mbone/mcl/files/patch-Makefile.common b/mbone/mcl/files/patch-Makefile.common
index f2b8c2b2975e..4cb001289885 100644
--- a/mbone/mcl/files/patch-Makefile.common
+++ b/mbone/mcl/files/patch-Makefile.common
@@ -22,7 +22,7 @@
LD = /opt/SUNWspro/bin/CC
+endif
+ifeq (${OS},freebsd)
-+ OSFLAGS = -DFREEBSD -I/usr/include/g++ -I/usr/include/c++/3.3
++ OSFLAGS = -DFREEBSD -I${LOCALBASE}/g++ -I${LOCALBASE}/c++/3.3
+ # Which compiler?
+ # NB: use -Wall for compilation warnings with gcc
+ #
diff --git a/mbone/mcl/files/patch-flute-Makefile b/mbone/mcl/files/patch-flute-Makefile
index 233632048d57..159fef2f7960 100644
--- a/mbone/mcl/files/patch-flute-Makefile
+++ b/mbone/mcl/files/patch-flute-Makefile
@@ -11,9 +11,9 @@
+ #
+ BINDIR = ../bin/freebsd
+ LDPC_BINDIR = ../../ldpc/bin/freebsd
-+ LIBRARIES = -lm -pthread -lglib-2.0 -lgdome -lxml2 -L/usr/local/lib
++ LIBRARIES = -lm -pthread -lglib-2.0 -lgdome -lxml2 -L${LOCALBASE}/lib
+ # added -I/usr/local/include for libgdome header files
-+ ADD_INCLUDES = -I/usr/local/include/ -I/usr/local/include/glib-2.0/ -I/usr/local/include/libgdome/
++ ADD_INCLUDES = -I${LOCALBASE}/include/ -I${LOCALBASE}/include/glib-2.0/ -I${LOCALBASE}/include/libgdome/
+endif
+
diff --git a/net/mcl/distinfo b/net/mcl/distinfo
index d66d0a1a90d0..c2499bb901b5 100644
--- a/net/mcl/distinfo
+++ b/net/mcl/distinfo
@@ -1,2 +1,3 @@
MD5 (mcl_v2.99.1.tgz) = d4a5c0c384d45dfa6c2a3dcbdcb3a81e
+SHA256 (mcl_v2.99.1.tgz) = 141966bf922c2995a29eeb73a536ee3f83438835b0f29f99afb626048decdc35
SIZE (mcl_v2.99.1.tgz) = 368784
diff --git a/net/mcl/files/patch-Makefile.common b/net/mcl/files/patch-Makefile.common
index f2b8c2b2975e..4cb001289885 100644
--- a/net/mcl/files/patch-Makefile.common
+++ b/net/mcl/files/patch-Makefile.common
@@ -22,7 +22,7 @@
LD = /opt/SUNWspro/bin/CC
+endif
+ifeq (${OS},freebsd)
-+ OSFLAGS = -DFREEBSD -I/usr/include/g++ -I/usr/include/c++/3.3
++ OSFLAGS = -DFREEBSD -I${LOCALBASE}/g++ -I${LOCALBASE}/c++/3.3
+ # Which compiler?
+ # NB: use -Wall for compilation warnings with gcc
+ #
diff --git a/net/mcl/files/patch-flute-Makefile b/net/mcl/files/patch-flute-Makefile
index 233632048d57..159fef2f7960 100644
--- a/net/mcl/files/patch-flute-Makefile
+++ b/net/mcl/files/patch-flute-Makefile
@@ -11,9 +11,9 @@
+ #
+ BINDIR = ../bin/freebsd
+ LDPC_BINDIR = ../../ldpc/bin/freebsd
-+ LIBRARIES = -lm -pthread -lglib-2.0 -lgdome -lxml2 -L/usr/local/lib
++ LIBRARIES = -lm -pthread -lglib-2.0 -lgdome -lxml2 -L${LOCALBASE}/lib
+ # added -I/usr/local/include for libgdome header files
-+ ADD_INCLUDES = -I/usr/local/include/ -I/usr/local/include/glib-2.0/ -I/usr/local/include/libgdome/
++ ADD_INCLUDES = -I${LOCALBASE}/include/ -I${LOCALBASE}/include/glib-2.0/ -I${LOCALBASE}/include/libgdome/
+endif
+