aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/py-posix1e/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/security/py-posix1e/Makefile b/security/py-posix1e/Makefile
index 54996357ac06..b663fa295be3 100644
--- a/security/py-posix1e/Makefile
+++ b/security/py-posix1e/Makefile
@@ -3,6 +3,7 @@
PORTNAME= posix1e
PORTVERSION= 0.5.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= SF/pylibacl/pylibacl/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,23 +12,17 @@ DISTNAME= pylibacl-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python module for manipulating POSIX.1e ACLs
-USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
-PYDISTUTILS_PKGNAME= pylibacl
-PYEASYINSTALL_ARCHDEP= yes
+LICENSE= LGPL21
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
PORTDOCS= COPYING IMPLEMENTATION NEWS PLATFORMS README
DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>