aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--biology/iqtree/Makefile4
-rw-r--r--biology/seqan-apps/Makefile8
-rw-r--r--devel/rcs57/Makefile11
-rw-r--r--sysutils/p5-File-Stat-Bits/Makefile3
-rw-r--r--www/h2o/Makefile3
-rw-r--r--www/mod_security-devel/Makefile4
6 files changed, 26 insertions, 7 deletions
diff --git a/biology/iqtree/Makefile b/biology/iqtree/Makefile
index 35bf00c45200..9b6e6e9b04da 100644
--- a/biology/iqtree/Makefile
+++ b/biology/iqtree/Makefile
@@ -15,6 +15,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
+BROKEN_aarch64= fails to compile: unrecognized command line option '-msse3'
+BROKEN_armv6= fails to compile: unrecognized command line options '-m32' and '-msse3'
+BROKEN_armv7= fails to compile: unrecognized command line options '-m32' and '-msse3'
+
USES= cmake compiler:openmp
USE_GITHUB= yes
GH_ACCOUNT= Cibiv
diff --git a/biology/seqan-apps/Makefile b/biology/seqan-apps/Makefile
index edb9458557c5..55211a5b5da5 100644
--- a/biology/seqan-apps/Makefile
+++ b/biology/seqan-apps/Makefile
@@ -15,6 +15,11 @@ LICENSE_COMB= multi
BUILD_DEPENDS= boost-libs>0:devel/boost-libs
+BROKEN_aarch64= fails to compile: Error: unknown mnemonic rep -- rep
+BROKEN_armv6= fails to compile: Error: bad instruction rep
+BROKEN_armv7= fails to compile: Error: bad instruction rep
+BROKEN_powerpc64= fails to compile: Error: unrecognized opcode: rep
+
USE_GITHUB= yes
GH_ACCOUNT= seqan
GH_PROJECT= seqan
@@ -26,9 +31,6 @@ CMAKE_ARGS= -DSEQAN_BUILD_SYSTEM="SEQAN_RELEASE_APPS"
USE_GCC= yes
-BROKEN_aarch64= fails to compile: Error: unknown mnemonic rep -- rep
-BROKEN_powerpc64= fails to compile: Error: unrecognized opcode: rep
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386"
diff --git a/devel/rcs57/Makefile b/devel/rcs57/Makefile
index 99ed58b7be52..226b9d390f2b 100644
--- a/devel/rcs57/Makefile
+++ b/devel/rcs57/Makefile
@@ -9,17 +9,20 @@ PKGNAMESUFFIX= 57
MAINTAINER= cy@FreeBSD.org
COMMENT= Version control system (as was in FreeBSD prior to removal)
+LICENSE= GPLv2
+
+BROKEN_armv6= fails to build: runaway build
+BROKEN_armv7= fails to build: runaway build
+
+CONFLICTS= rcs-5.[89]*
+
OPTIONS_DEFINE= FREEBSD
OPTIONS_DEFAULT= FREEBSD
FREEBSD_DESC= Apply FreeBSD patches
-CONFLICTS= rcs-5.[89]*
-LICENSE= GPLv2
-
USES= desthack gmake
GNU_CONFIGURE= yes
-
FREEBSD_EXTRA_PATCHES+= ${FILESDIR}/freebsd-src-ident.c \
${FILESDIR}/freebsd-src-maketime.c \
${FILESDIR}/freebsd-src-rcsbase.h \
diff --git a/sysutils/p5-File-Stat-Bits/Makefile b/sysutils/p5-File-Stat-Bits/Makefile
index d93eaa6f63d2..59384a359d2f 100644
--- a/sysutils/p5-File-Stat-Bits/Makefile
+++ b/sysutils/p5-File-Stat-Bits/Makefile
@@ -11,6 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pirzyk@FreeBSD.org
COMMENT= Perl5 module interface to the major()/minor() C routines
+BROKEN_armv6= fails to build: runaway build
+BROKEN_armv7= fails to build: runaway build
+
USES= perl5
USE_PERL5= configure
diff --git a/www/h2o/Makefile b/www/h2o/Makefile
index 29bc1a9878ab..335ab9104b0e 100644
--- a/www/h2o/Makefile
+++ b/www/h2o/Makefile
@@ -11,6 +11,9 @@ COMMENT= Optimized HTTP/2 server including support for TLS 1.3 and HTTP/1.x
LICENSE= MIT
+BROKEN_armv6= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
+BROKEN_armv7= fails to compile: asm_arm.inc:139:36: '.syntax divided' arm assembly not supported
+
USES= cmake:noninja compiler:c11 cpe perl5 shebangfix ssl
CPE_VENDOR= h2o_project
USE_GITHUB= yes
diff --git a/www/mod_security-devel/Makefile b/www/mod_security-devel/Makefile
index 68e148212b27..9c6b195ccefa 100644
--- a/www/mod_security-devel/Makefile
+++ b/www/mod_security-devel/Makefile
@@ -15,6 +15,10 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libyajl.so:devel/yajl \
libGeoIP.so:net/GeoIP
+BROKEN_aarch64= fails to compile: string.h:55:1: narrowing conversion of '-1' from 'int' to 'char' inside { }
+BROKEN_armv6= fails to compile: string.h:55:1: narrowing conversion of '-1' from 'int' to 'char' inside { }
+BROKEN_armv7= fails to compile: string.h:55:1: narrowing conversion of '-1' from 'int' to 'char' inside { }
+
USES= gmake autoreconf libtool pkgconfig:build
USE_GNOME= libxml2
# GCC because of https://github.com/SpiderLabs/ModSecurity/issues/1411