aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/lrzsz/Makefile2
-rw-r--r--comms/lrzsz/files/patch-lsz.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/comms/lrzsz/Makefile b/comms/lrzsz/Makefile
index 929c97684000..4598aa2b5541 100644
--- a/comms/lrzsz/Makefile
+++ b/comms/lrzsz/Makefile
@@ -7,7 +7,7 @@
PORTNAME= lrzsz
PORTVERSION= 0.12.20
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= comms
MASTER_SITES= http://www.ohse.de/uwe/releases/
diff --git a/comms/lrzsz/files/patch-lsz.c b/comms/lrzsz/files/patch-lsz.c
new file mode 100644
index 000000000000..0d055f3f5da5
--- /dev/null
+++ b/comms/lrzsz/files/patch-lsz.c
@@ -0,0 +1,10 @@
+--- src/lsz.c.orig 1998-12-30 07:07:59.000000000 +0900
++++ src/lsz.c 2012-01-21 10:44:49.000000000 +0900
+@@ -1191,6 +1191,7 @@
+ struct stat f;
+
+ name2=alloca(PATH_MAX+1);
++ f.st_size = 0;
+
+ if (protocol==ZM_XMODEM) {
+ if (Verbose && *zi->fname && fstat(fileno(input_f), &f)!= -1) { \ No newline at end of file