aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/ffmpeg2theora/Makefile28
-rw-r--r--multimedia/ffmpeg2theora/distinfo3
-rw-r--r--multimedia/ffmpeg2theora/pkg-descr5
4 files changed, 37 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index e474206050aa..50ed9e864e05 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -41,6 +41,7 @@
SUBDIR += etoile-babbler
SUBDIR += etoile-multimediakit
SUBDIR += ffmpeg
+ SUBDIR += ffmpeg2theora
SUBDIR += ffmpegthumbnailer
SUBDIR += flv2mpeg4
SUBDIR += flvtool++
diff --git a/multimedia/ffmpeg2theora/Makefile b/multimedia/ffmpeg2theora/Makefile
new file mode 100644
index 000000000000..58eee139648f
--- /dev/null
+++ b/multimedia/ffmpeg2theora/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: ffmpeg2theora
+# Date created: Sat 19 Oct 2008
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= ffmpeg2theora
+PORTVERSION= 0.22
+CATEGORIES= multimedia
+MASTER_SITES= http://v2v.cc/~j/ffmpeg2theora/
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Reencode many media file formats to Ogg Theora
+
+LIB_DEPENDS= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
+ theora.0:${PORTSDIR}/multimedia/libtheora \
+ kate.1:${PORTSDIR}/multimedia/libkate
+
+USE_BZIP2= yes
+USE_SCONS= yes
+
+SCONS_ENV+= APPEND_LINKFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib" \
+ APPEND_CFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include"
+
+MAN1= ffmpeg2theora.1
+PLIST_FILES= bin/ffmpeg2theora
+
+.include <bsd.port.mk>
diff --git a/multimedia/ffmpeg2theora/distinfo b/multimedia/ffmpeg2theora/distinfo
new file mode 100644
index 000000000000..4b518726443e
--- /dev/null
+++ b/multimedia/ffmpeg2theora/distinfo
@@ -0,0 +1,3 @@
+MD5 (ffmpeg2theora-0.22.tar.bz2) = 6523be13740343c93bbab5358755a511
+SHA256 (ffmpeg2theora-0.22.tar.bz2) = 3c29743247fa4480eea02d0c4f4053ab788f515808413f7ccb7cbeadccc0a9da
+SIZE (ffmpeg2theora-0.22.tar.bz2) = 60246
diff --git a/multimedia/ffmpeg2theora/pkg-descr b/multimedia/ffmpeg2theora/pkg-descr
new file mode 100644
index 000000000000..4745349a15c3
--- /dev/null
+++ b/multimedia/ffmpeg2theora/pkg-descr
@@ -0,0 +1,5 @@
+ffmpeg2theora is a simple command line tool to convert media files to
+.ogg with Theora video and Vorbis audio streams. It supports reading any
+file format that ffmpeg can decode.
+
+WWW: http://v2v.cc/~j/ffmpeg2theora/