aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/gpsman/Makefile1
-rw-r--r--astro/gpsman/files/patch-garmin.tcl30
-rw-r--r--astro/gpsman/files/patch-wrtdials.tcl22
3 files changed, 53 insertions, 0 deletions
diff --git a/astro/gpsman/Makefile b/astro/gpsman/Makefile
index 0083d7c4ee1e..c99b0b3cb7a4 100644
--- a/astro/gpsman/Makefile
+++ b/astro/gpsman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gpsman
PORTVERSION= 6.4
+PORTREVISION= 1
CATEGORIES= astro tk geography
MASTER_SITES= http://www.ncc.up.pt/gpsman/gpsmanhtml/
MASTER_SITE_SUBDIR= science/cartography
diff --git a/astro/gpsman/files/patch-garmin.tcl b/astro/gpsman/files/patch-garmin.tcl
new file mode 100644
index 000000000000..8da2151393c1
--- /dev/null
+++ b/astro/gpsman/files/patch-garmin.tcl
@@ -0,0 +1,30 @@
+diff -ruN gmsrc/garmin.tcl gmsrc/garmin.tcl
+--- gmsrc/garmin.tcl 2008-10-28 10:19:48.000000000 -0700
++++ gmsrc/garmin.tcl 2008-11-10 04:39:44.000000000 -0800
+@@ -17,7 +17,7 @@
+ # along with this program.
+ #
+ # File: garmin.tcl
+-# Last change: 23 October 2008
++# Last change: 2 November 2008
+ #
+ # Includes contributions by
+ # - David Gardner (djgardner_AT_users.sourceforge.net) marked
+@@ -2567,7 +2567,7 @@
+ }
+
+ proc ConvGarminDate {gd} {
+- # converts Garmin date (seconds since 1990.01.01 00:00:00) into list
++ # converts Garmin date (seconds since 1989.12.31 00:00:00) into list
+ # with date in current format and seconds since beginning of $YEAR0,
+ # not necessarily a leap year, but < 1990
+ global YEAR0 TimeOffset
+@@ -2579,7 +2579,7 @@
+ if { $yy%100!=0 || $yy%400==0 } { incr dd }
+ incr yy 4
+ }
+- set secs [expr round((((1990-$YEAR0)*365+$dd)*24+$TimeOffset-12)*3600+$gd)]
++ set secs [expr round((((1990-$YEAR0)*365+$dd)*24+$TimeOffset)*3600+$gd)]
+ return [list [DateFromSecs $secs] $secs]
+ }
+
diff --git a/astro/gpsman/files/patch-wrtdials.tcl b/astro/gpsman/files/patch-wrtdials.tcl
new file mode 100644
index 000000000000..6737f1a89e34
--- /dev/null
+++ b/astro/gpsman/files/patch-wrtdials.tcl
@@ -0,0 +1,22 @@
+diff -ruN gmsrc/wrtdials.tcl gmsrc/wrtdials.tcl
+--- gmsrc/wrtdials.tcl 2008-10-28 10:19:48.000000000 -0700
++++ gmsrc/wrtdials.tcl 2008-11-10 04:39:44.000000000 -0800
+@@ -17,7 +17,7 @@
+ # along with this program.
+ #
+ # File: wrtdials.tcl
+-# Last change: 14 September 2008
++# Last change: 8 November 2008
+ #
+ # Includes contributions by
+ # - Brian Baulch (baulchb _AT_ onthenet.com.au) marked "BSB contribution"
+@@ -4099,8 +4099,8 @@
+ }
+ break
+ }
++ incr i
+ }
+- incr i
+ }
+ }
+ if { $wh == "WP" } {