aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/vamps/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/multimedia/vamps/Makefile b/multimedia/vamps/Makefile
index 194eb28d789c..40c750fa9e24 100644
--- a/multimedia/vamps/Makefile
+++ b/multimedia/vamps/Makefile
@@ -10,9 +10,9 @@ MASTER_SITES= SF/${PORTNAME}/Vamps/${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= High performance tool to transcode DVD videos to a smaller size
-LIB_DEPENDS= dvdread.4:${PORTSDIR}/multimedia/libdvdread
+LIB_DEPENDS= libdvdread.so:${PORTSDIR}/multimedia/libdvdread
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -DHAVE_BUILTIN_EXPECT \
-I${LOCALBASE}/include \
@@ -26,10 +26,8 @@ PROGRAM_FILES= \
PLIST_FILES= ${PROGRAM_FILES:H:S,^,bin/,}
-NO_STAGE= yes
do-install:
-.for program in ${PROGRAM_FILES}
- @${INSTALL_PROGRAM} ${WRKSRC}/${program} ${PREFIX}/bin/${program:H}
-.endfor
+ cd ${WRKSRC}; \
+ ${INSTALL_PROGRAM} ${PROGRAM_FILES} ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>