aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/leatherman/Makefile5
-rw-r--r--devel/leatherman/distinfo6
-rw-r--r--devel/leatherman/files/patch-cmake_leatherman.cmake.in (renamed from devel/leatherman/files/patch-cmake_leatherman.cmake)9
-rw-r--r--devel/leatherman/pkg-plist2
4 files changed, 14 insertions, 8 deletions
diff --git a/devel/leatherman/Makefile b/devel/leatherman/Makefile
index a01db82b026a..3b9137526452 100644
--- a/devel/leatherman/Makefile
+++ b/devel/leatherman/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= leatherman
-PORTVERSION= 0.10.1
+PORTVERSION= 1.0.0
PORTREVISION= 1
CATEGORIES= devel
@@ -19,10 +19,11 @@ BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line op
USE_GITHUB= yes
GH_ACCOUNT= puppetlabs
-USES= cmake
+USES= cmake gettext
USE_RUBY= yes
CMAKE_ARGS= -DLEATHERMAN_SHARED:BOOL=ON
USE_LDCONFIG= yes
+TEST_TARGET= test
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/devel/leatherman/distinfo b/devel/leatherman/distinfo
index 79c7eb1324d9..c30432558591 100644
--- a/devel/leatherman/distinfo
+++ b/devel/leatherman/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483588778
-SHA256 (puppetlabs-leatherman-0.10.1_GH0.tar.gz) = 79b0eded49a02cb8f6ce6260ae39e3f1bdd2dc2c62c02f661308e04c08edb69e
-SIZE (puppetlabs-leatherman-0.10.1_GH0.tar.gz) = 423218
+TIMESTAMP = 1499512611
+SHA256 (puppetlabs-leatherman-1.0.0_GH0.tar.gz) = 4bcb8eaf08429e9e62cc6fcbfc1f216bd2eff800f751dbacabbec7d714ed21a2
+SIZE (puppetlabs-leatherman-1.0.0_GH0.tar.gz) = 423859
diff --git a/devel/leatherman/files/patch-cmake_leatherman.cmake b/devel/leatherman/files/patch-cmake_leatherman.cmake.in
index a4ef0b84cd96..b3b1a10f157e 100644
--- a/devel/leatherman/files/patch-cmake_leatherman.cmake
+++ b/devel/leatherman/files/patch-cmake_leatherman.cmake.in
@@ -1,6 +1,9 @@
---- cmake/leatherman.cmake.orig 2016-12-06 01:37:41 UTC
-+++ cmake/leatherman.cmake
-@@ -78,11 +78,6 @@ macro(leatherman_install)
+
+$FreeBSD$
+
+--- cmake/leatherman.cmake.in.orig
++++ cmake/leatherman.cmake.in
+@@ -83,11 +83,6 @@
RUNTIME DESTINATION bin
LIBRARY DESTINATION lib${LIB_SUFFIX}
ARCHIVE DESTINATION lib${LIB_SUFFIX})
diff --git a/devel/leatherman/pkg-plist b/devel/leatherman/pkg-plist
index 2fece9eedf1e..496dc402afce 100644
--- a/devel/leatherman/pkg-plist
+++ b/devel/leatherman/pkg-plist
@@ -107,3 +107,5 @@ lib/libleatherman_ruby.so
lib/libleatherman_ruby.so.%%PORTVERSION%%
lib/libleatherman_util.so
lib/libleatherman_util.so.%%PORTVERSION%%
+share/locale/fr/LC_MESSAGES/leatherman_locale.mo
+share/locale/fr/LC_MESSAGES/leatherman_logging.mo