aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/nplot/Makefile27
-rw-r--r--graphics/nplot/distinfo3
-rw-r--r--graphics/nplot/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 4f099778c4a4..08913777dcfd 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -601,6 +601,7 @@
SUBDIR += netpbm
SUBDIR += nip2
SUBDIR += nomacs
+ SUBDIR += nplot
SUBDIR += npretty
SUBDIR += nurbs++
SUBDIR += nvidia-texture-tools
diff --git a/graphics/nplot/Makefile b/graphics/nplot/Makefile
new file mode 100644
index 000000000000..4fd6a3b2eda9
--- /dev/null
+++ b/graphics/nplot/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= nplot
+PORTVERSION= 0.9.10
+CATEGORIES= graphics
+MASTER_SITES= http://suyai.innolan.net/
+DISTNAME= nplot-0.9.10.1
+
+MAINTAINER= cs@innolan.dk
+COMMENT= Charting library for .NET
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libgdiplus.so:x11-toolkits/libgdiplus \
+ libcairo.so:graphics/cairo
+RUN_DEPENDS= webfonts>=0:x11-fonts/webfonts
+
+USES= mono
+WRKSRC= ${WRKDIR}/anguist-nplot-bed1ca9c4048
+
+PLIST_FILES= lib/mono/gac/NPlot/0.9.10.1__4eda430eb4395eb1/NPlot.dll
+
+do-install:
+ ${LOCALBASE}/bin/gacutil -root ${STAGEDIR}${PREFIX}/lib/ -gacdir ${STAGEDIR}${PREFIX}/lib -i ${WRKSRC}/bin/NPlot.dll
+
+.include <bsd.port.mk>
diff --git a/graphics/nplot/distinfo b/graphics/nplot/distinfo
new file mode 100644
index 000000000000..3d4763fb9ed3
--- /dev/null
+++ b/graphics/nplot/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470568912
+SHA256 (nplot-0.9.10.1.tar.gz) = 12a6b76594eb34e27a25b575e848b4082afb4ad42630f3180e13893111971ba8
+SIZE (nplot-0.9.10.1.tar.gz) = 107708
diff --git a/graphics/nplot/pkg-descr b/graphics/nplot/pkg-descr
new file mode 100644
index 000000000000..a3941debe6ed
--- /dev/null
+++ b/graphics/nplot/pkg-descr
@@ -0,0 +1,5 @@
+NPlot is a free charting library for .NET. It boasts an elegant,
+flexible API and includes controls for Windows.Forms, ASP.NET
+and a class for creating Bitmaps.
+
+WWW: http://netcontrols.org/nplot/wiki/