aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/vnc2flv/Makefile2
-rw-r--r--devel/libvirt/Makefile2
-rw-r--r--devel/opengrok/Makefile26
-rw-r--r--dns/py-namebench/Makefile6
-rw-r--r--mail/muttils/Makefile6
-rw-r--r--sysutils/daemontools/Makefile38
-rw-r--r--www/axis2/Makefile24
7 files changed, 46 insertions, 58 deletions
diff --git a/deskutils/vnc2flv/Makefile b/deskutils/vnc2flv/Makefile
index 8dd356f31964..63bc473d1364 100644
--- a/deskutils/vnc2flv/Makefile
+++ b/deskutils/vnc2flv/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jgh@FreeBSD.org
COMMENT= Captures a VNC desktop session and saves as a flv
-.if !defined(WITHOUT_X11)
+.if empty(PORT_OPTIONS:MX11)
RUN_DEPENDS+= x11vnc:${PORTSDIR}/net/x11vnc
.endif
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index bfc785f9119e..09474632d006 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -49,7 +49,7 @@ SHLIB_VER= 9
PLIST_SUB= PORTVERSION="-${PORTVERSION}" \
SHLIB_VER=${SHLIB_VER}
-.if !defined(WITHOUT_NLS)
+.if empty(PORT_OPTIONS:MNLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
CONFIGURE_ARGS+= --enable-nls \
diff --git a/devel/opengrok/Makefile b/devel/opengrok/Makefile
index 7f06d4f73d61..5dc92d5bce37 100644
--- a/devel/opengrok/Makefile
+++ b/devel/opengrok/Makefile
@@ -30,9 +30,9 @@ PLIST_SUB= T=${WEBAPP_DIRS:S|^${LOCALBASE}/||} \
CONF_EXT=${CONF_EXT}
CONF_EXT= sample
-OPTIONS= TOMCAT6 "Use Jakarta Tomcat 6" on \
- TOMCAT55 "Use Jakarta Tomcat 5.5" off \
- RESIN3 "Use Resin 3" off
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT5 TOMCAT6 RESIN3
+OPTIONS_DEFAULT= TOMCAT6
.include <bsd.port.pre.mk>
@@ -45,35 +45,25 @@ LIBFILES= ant.jar \
lucene-spellchecker-3.0.2.jar \
swing-layout-0.9.jar
-.if defined(WITH_TOMCAT6)
+.if ${PORT_OPTIONS:MTOMCAT6}
WEBAPP_DIRS= apache-tomcat-6.0
BUILD_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat-6.0/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
.endif
-.if defined(WITH_TOMCAT55)
+.if ${PORT_OPTIONS:MTOMCAT5}
WEBAPP_DIRS= tomcat5.5
BUILD_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
.endif
-.if defined(WITH_RESIN3)
+.if ${PORT_OPTIONS:MRESIN3}
WEBAPP_DIRS= resin3
BUILD_DEPENDS+= ${LOCALBASE}/resin3/lib/resin.jar:${PORTSDIR}/www/resin3
RUN_DEPENDS+= ${LOCALBASE}/resin3/lib/resin.jar:${PORTSDIR}/www/resin3
.endif
-.if ( defined(WITH_TOMCAT6) && ( defined(WITH_TOMCAT55) || defined(WITH_RESIN3)))
-IGNORE= you can only define one application server
-.elif ( defined(WITH_TOMCAT55) && ( defined(WITH_TOMCAT6) || defined(WITH_RESIN3)))
-IGNORE= you can only define one application server
-.elif ( defined(WITH_RESIN) && ( defined(WITH_TOMCAT6) || defined(WITH_TOMCAT55)))
-IGNORE= you can only define one application server
-.elif !defined(WEBAPP_DIRS)
-IGNORE= you need at least one application server
-.endif
-
-check-sanity:
+pre-everything::
.if ${PREFIX}!=${LOCALBASE}
@${ECHO_MSG} "Warning: you changed prefix to ${PREFIX}"
@${ECHO_MSG} "Default installation will not work if you installed"
@@ -100,7 +90,7 @@ do-install:
${MKDIR} ${DATADIR}/lib
${INSTALL_DATA} ${LIBFILES:S,^,${WRKSRC}/lib/lib/,} ${DATADIR}/lib/
${INSTALL_DATA} ${WRKSRC}/lib/opengrok.jar ${DATADIR}/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}/
.endif
diff --git a/dns/py-namebench/Makefile b/dns/py-namebench/Makefile
index 8164d3e88ef8..058072d14926 100644
--- a/dns/py-namebench/Makefile
+++ b/dns/py-namebench/Makefile
@@ -25,7 +25,9 @@ RUN_DEPENDS+= \
${PYTHON_PKGNAMEPREFIX}httplib2>=0.6.0:${PORTSDIR}/www/py-httplib2 \
${PYTHON_PKGNAMEPREFIX}simplejson>=2.1.6:${PORTSDIR}/devel/py-simplejson
-.if !defined(WITHOUT_X11)
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MX11)
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>=2.7.1:${PORTSDIR}/x11-toolkits/py-tkinter
.endif
@@ -45,7 +47,7 @@ post-patch:
${WRKSRC}/libnamebench/util.py
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -o ${DOCOWN} -g ${DOCGRP} -m 555 -d ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/mail/muttils/Makefile b/mail/muttils/Makefile
index 4116795b52e6..ae32c2f48d99 100644
--- a/mail/muttils/Makefile
+++ b/mail/muttils/Makefile
@@ -21,8 +21,14 @@ USE_PYTHON_BUILD= yes
USE_PYTHON_RUN= yes
USE_PYDISTUTILS= yes
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
( cd ${WRKSRC}/contrib && ${INSTALL_DATA} \example-* ${EXAMPLESDIR} )
+.endif
.include <bsd.port.mk>
diff --git a/sysutils/daemontools/Makefile b/sysutils/daemontools/Makefile
index 11cfc01349c2..963177b81971 100644
--- a/sysutils/daemontools/Makefile
+++ b/sysutils/daemontools/Makefile
@@ -21,33 +21,33 @@ LICENSE_NAME= public domain
LICENSE_TEXT= The daemontools-0.76.tar.gz archive is in the public domain as of 2007.12.28.
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-OPTIONS= MAN "Install Gerrit Pape's manual pages" on \
- S_EARLY "Start early, before the normal daemons" off \
- S_NORMAL "Start normally in the usual boot sequence" on \
- SIGQ12 "Add svc support for QUIT, USR1, and USR2 signals" off \
- TESTS "Run the test suite, fails on NFS-mounted workdir" on
+OPTIONS_DEFINE= MAN SIGQ12 TESTS
+MAN_DESC= Install Gerrit Pape's manual pages
+S_EARLY_DESC= Start early, before the normal daemons
+S_NORMAL_DESC= Start normally in the usual boot sequence
+SIGQ12_DESC= Add svc support for QUIT, USR1, and USR2 signals
+TESTS_DESC= Run the test suite, fails on NFS-mounted workdir
+
+OPTIONS_SINGLE= SEQ
+OPTIONS_SINGLE_SEQ= S_EARLY S_NORMAL
+
+OPTIONS_DEFAULT= MAN S_NORMAL TESTS
.include <bsd.port.pre.mk>
-.if defined(WITH_S_EARLY)
-. if defined(WITH_S_NORMAL)
-IGNORE= needs exactly one of S_EARLY and S_NORMAL to be specified
-. else
+. if ${PORT_OPTIONS:MS_EARLY}
SVSCAN_REQUIRE?= SERVERS
SVSCAN_BEFORE?= DAEMON
. endif
-.else
-. if defined(WITH_S_NORMAL)
+
+. if ${PORT_OPTIONS:MS_NORMAL}
SVSCAN_REQUIRE?= LOGIN
SVSCAN_BEFORE?=
-. else
-IGNORE= needs either S_EARLY or S_NORMAL to be specified
. endif
-.endif
SUB_LIST+= SVSCAN_REQUIRE=${SVSCAN_REQUIRE} SVSCAN_BEFORE=${SVSCAN_BEFORE}
-.if !defined(WITHOUT_MAN)
+.if ${PORT_OPTIONS:MMAN}
MANDATE= -20010714
MASTER_SITES+= http://smarden.org/pape/djb/manpages/:1
DISTFILES+= ${DISTNAME}-man${MANDATE}.tar.gz:1
@@ -59,7 +59,7 @@ MAN8= envdir.8 envuidgid.8 fghack.8 multilog.8 pgrphack.8 \
MANCOMPRESSED= no
.endif
-.if defined(WITH_SIGQ12)
+.if ${PORT_OPTIONS:MSIGQ12}
#PATCH_SITES+= http://thedjbway.org/patches/:sigq12
PATCH_SITES+= ${MASTER_SITE_LOCAL:S/%SUBDIR%\//jgh\/sysutils\/daemontools\/:sigq12/} \
http://people.FreeBSD.org/~jgh/ports/sysutils/daemontools/:sigq12
@@ -74,7 +74,7 @@ WRKSRC= ${WRKDIR}/admin/${DISTNAME}/src
ALL_TARGET= it
INSTALL_TARGET= setup check
-.if defined(WITHOUT_TESTS)
+.if ${PORT_OPTIONS:MTESTS}
EXTRA_PATCHES+= ${FILESDIR}/rts-skip.patch
.endif
@@ -92,8 +92,8 @@ do-install:
done) < ${WRKSRC}/../package/commands
post-install:
-.if !defined(WITHOUT_MAN)
- @${INSTALL_MAN} ${WRKDIR}/daemontools-man/*.8 ${MAN8PREFIX}/man/man8/
+.if ${PORT_OPTIONS:MMAN}
+ ${INSTALL_MAN} ${WRKDIR}/daemontools-man/*.8 ${MAN8PREFIX}/man/man8/
.endif
.include <bsd.port.post.mk>
diff --git a/www/axis2/Makefile b/www/axis2/Makefile
index e6981ed3f546..58e496fcb816 100644
--- a/www/axis2/Makefile
+++ b/www/axis2/Makefile
@@ -20,38 +20,30 @@ USE_ZIP= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
-OPTIONS= TOMCAT5 "Enable Tomcat 5.x support" off \
- TOMCAT6 "Enable Tomcat 6.x support" on \
- TOMCAT7 "Enable Tomcat 7.x support" off
+OPTIONS_SINGLE= AS
+OPTIONS_SINGLE_AS= TOMCAT5 TOMCAT6 TOMCAT7
+OPTIONS_DEFAULT= TOMCAT6
.include <bsd.port.options.mk>
-.if defined(WITH_TOMCAT5)
+.if ${PORT_OPTIONS:MTOMCAT5}
APPHOME= ${LOCALBASE}/tomcat5.5
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat55
.endif
-.if defined(WITH_TOMCAT6)
+.if ${PORT_OPTIONS:MTOMCAT6}
APPHOME= ${LOCALBASE}/apache-tomcat-6.0
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat6
.endif
-.if defined(WITH_TOMCAT7)
+.if ${PORT_OPTIONS:MTOMCAT7}
APPHOME= ${LOCALBASE}/apache-tomcat-7.0
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:${PORTSDIR}/www/tomcat7
.endif
-.if ( defined(WITH_TOMCAT5) && defined(WITH_TOMCAT6) || defined(WITH_TOMCAT7) )
-IGNORE= you can only define one application server
-.elif ( defined(WITH_TOMCAT6) && defined(WITH_TOMCAT7) )
-IGNORE= you can only define one application server
-.elif !defined(APPHOME)
-IGNORE= you need at least one application server
-.endif
-
USE_JAVA= yes
JAVA_VERSION= 1.6+
SHAREOWN= www
@@ -60,9 +52,7 @@ PLIST_SUB+= APPHOME=${APPHOME:S|^${PREFIX}/||} \
CONF_EXT=${CONF_EXT}
CONF_EXT= sample
-.if !defined(NOPORTEXAMPLES)
PORTEXAMPLES= *
-.endif
do-install:
( ${MKDIR} ${APPHOME}/webapps/${PORTNAME}/WEB-INF/lib && cd ${WRKSRC}/lib && ${COPYTREE_SHARE} \* ${APPHOME}/webapps/${PORTNAME}/WEB-INF/lib)
@@ -90,7 +80,7 @@ do-install:
${ECHO_MSG} " Preserving local configuration file: ${APPHOME}/webapps/${PORTNAME}/WEB-INF/web.xml"; \
fi;
${INSTALL_DATA} ${WRKSRC}/webapp/WEB-INF/web.xml.${CONF_EXT} ${APPHOME}/webapps/${PORTNAME}/WEB-INF
-.if !defined(NOPORTEXAMPLES)
+.if $(PORT_OPTIONS:MEXAMPLES}
cd ${WRKSRC}/samples && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \;
cd ${WRKSRC}/samples && ${FIND} . -type f -not -name '*.class' -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
.endif