aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-prompt_toolkit/Makefile20
-rw-r--r--devel/py-prompt_toolkit/distinfo2
-rw-r--r--devel/py-prompt_toolkit/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 13afc3607601..053f327d4697 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3826,6 +3826,7 @@
SUBDIR += py-pqueue
SUBDIR += py-prettytable
SUBDIR += py-prioritized_methods
+ SUBDIR += py-prompt_toolkit
SUBDIR += py-protobuf
SUBDIR += py-protocols
SUBDIR += py-protocols-devel
diff --git a/devel/py-prompt_toolkit/Makefile b/devel/py-prompt_toolkit/Makefile
new file mode 100644
index 000000000000..eaea1aaa01bc
--- /dev/null
+++ b/devel/py-prompt_toolkit/Makefile
@@ -0,0 +1,20 @@
+# Created by: Steven Kreuzer <skreuzer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= prompt_toolkit
+PORTVERSION= 0.18
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Library for building powerful interactive command lines in Python
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docopt>=0.6.2:${PORTSDIR}/devel/py-docopt \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.7.3:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=1.6:${PORTSDIR}/textproc/py-pygments
+
+USES= python:2
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-prompt_toolkit/distinfo b/devel/py-prompt_toolkit/distinfo
new file mode 100644
index 000000000000..22dadb5cdcdf
--- /dev/null
+++ b/devel/py-prompt_toolkit/distinfo
@@ -0,0 +1,2 @@
+SHA256 (prompt_toolkit-0.18.tar.gz) = 2dc598e2633a374858a50b19d08d8e4a648294a2048e0423771b86bd380023fb
+SIZE (prompt_toolkit-0.18.tar.gz) = 71634
diff --git a/devel/py-prompt_toolkit/pkg-descr b/devel/py-prompt_toolkit/pkg-descr
new file mode 100644
index 000000000000..c4d6dd67c162
--- /dev/null
+++ b/devel/py-prompt_toolkit/pkg-descr
@@ -0,0 +1,8 @@
+prompt_toolkit is a library for building powerful interactive command lines in
+Python. It ships with a nice interactive Python shell (called ptpython) built
+on top of the library.
+
+prompt_toolkit could be a replacement for readline, but it can be much more
+than that.
+
+WWW: https://github.com/jonathanslenders/python-prompt-toolkit