aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/ocaml-net/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/www/ocaml-net/Makefile b/www/ocaml-net/Makefile
index a3d3363ebd2a..7a2270dc2e0b 100644
--- a/www/ocaml-net/Makefile
+++ b/www/ocaml-net/Makefile
@@ -3,6 +3,7 @@
PORTNAME= net
PORTVERSION= 4.0.3
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://download.camlcity.org/download/
PKGNAMEPREFIX= ocaml-
@@ -44,11 +45,12 @@ OCAML_PKGDIRS= netsys netshm equeue shell netstring rpc-generator \
netstring-pcre netunidata
OCAML_LDLIBS= ${OCAML_PKGDIRS:S/^/${OCAML_SITELIBDIR}\//}
-OPTIONS_DEFINE= NETHTTPD GTK2 APACHE ZIP EXAMPLES DOCS
-OPTIONS_DEFAULT=
+OPTIONS_DEFINE= NETHTTPD GTK2 GNUTLS APACHE ZIP EXAMPLES DOCS
+OPTIONS_DEFAULT= GNUTLS
NETHTTPD_DESC= Integrated HTTP daemon
ZIP_DESC= Compression support
APACHE_DESC= Apache mod connector (experimental)
+GNUTLS_DESC= SSL/TLS support via GnuTLS
CONFIGURE_ARGS+=-disable-gtk \
-enable-pcre
@@ -71,6 +73,13 @@ CONFIGURE_ARGS+= -enable-gtk2
OCAML_PKGDIRS+= equeue-gtk2
.endif
+.if ${PORT_OPTIONS:MGNUTLS}
+USES+= pkgconfig
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= -enable-gnutls
+OCAML_PKGDIRS+= nettls-gnutls
+.endif
+
.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE= 22+
CONFIGURE_ARGS+= -enable-apache -apxs ${APXS} -apache ${HTTPD}