aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/glabels/Makefile4
-rw-r--r--deskutils/glabels/pkg-plist2
-rw-r--r--graphics/inkscape/Makefile5
-rw-r--r--graphics/inkscape/pkg-plist2
-rw-r--r--graphics/sodipodi/Makefile4
-rw-r--r--graphics/sodipodi/pkg-plist2
6 files changed, 14 insertions, 5 deletions
diff --git a/deskutils/glabels/Makefile b/deskutils/glabels/Makefile
index 4f33d4816511..98685856ce16 100644
--- a/deskutils/glabels/Makefile
+++ b/deskutils/glabels/Makefile
@@ -7,6 +7,7 @@
PORTNAME= glabels
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +16,8 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A program to create labels and business cards
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui libgnomeprintui
+USE_GNOME= gnomehack gnomeprefix gnometarget libgnomeui libgnomeprintui \
+ desktopfileutils
USE_GMAKE= yes
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
diff --git a/deskutils/glabels/pkg-plist b/deskutils/glabels/pkg-plist
index 2d3dd325d11b..172b70512482 100644
--- a/deskutils/glabels/pkg-plist
+++ b/deskutils/glabels/pkg-plist
@@ -10,6 +10,7 @@ lib/libglabels.a
lib/libglabels.so
lib/libglabels.so.1
share/gnome/application-registry/glabels.applications
+@exec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/applications/glabels.desktop
share/gnome/glabels/dtd/glabels-2.0.dtd
share/gnome/glabels/glade/object-editor.glade
@@ -71,3 +72,4 @@ share/mime/packages/glabels.xml
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/glabels/glabels-C.omf 2>/dev/null || true
@exec update-mime-database %D/share/mime
@unexec update-mime-database %D/share/mime
+@unexec update-desktop-database > /dev/null || /usr/bin/true
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index c1e64652efd2..8ed9bc7b4071 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -7,7 +7,7 @@
PORTNAME= inkscape
PORTVERSION= 0.38.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,7 +21,8 @@ RUN_DEPENDS= ${SITE_PERL}/XML/XQL.pm:${PORTSDIR}/textproc/p5-XML-XQL
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack lthack intlhack libglade2 libartlgpl2 libgnomeprintui
+USE_GNOME= gnomeprefix gnomehack lthack intlhack libglade2 libartlgpl2 \
+ desktopfileutils libgnomeprintui
USE_REINPLACE= yes
USE_LIBTOOL_VER=13
CONFIGURE_ARGS= --with-popt \
diff --git a/graphics/inkscape/pkg-plist b/graphics/inkscape/pkg-plist
index cb6231cdd2a5..d4d90c29958c 100644
--- a/graphics/inkscape/pkg-plist
+++ b/graphics/inkscape/pkg-plist
@@ -7,6 +7,7 @@ lib/inkscape/extensions/roundhole
lib/inkscape/extensions/svg_dropshadow
lib/inkscape/extensions/txt2svg.pl
share/gnome/applications/inkscape.desktop
+@exec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/inkscape/extensions/roundhole.xpm
share/gnome/inkscape/icons/add.xpm
share/gnome/inkscape/icons/add_xml_element_node.xpm
@@ -231,3 +232,4 @@ share/locale/zh_CN/LC_MESSAGES/inkscape.mo
@dirrm share/gnome/inkscape
@dirrm lib/inkscape/extensions
@dirrm lib/inkscape
+@unexec update-desktop-database > /dev/null || /usr/bin/true
diff --git a/graphics/sodipodi/Makefile b/graphics/sodipodi/Makefile
index 0b1bea9bc7a8..51004c6eea27 100644
--- a/graphics/sodipodi/Makefile
+++ b/graphics/sodipodi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sodipodi
PORTVERSION= 0.34
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libglade2 libartlgpl2
+USE_GNOME= gnomeprefix gnomehack libglade2 libartlgpl2 desktopfileutils
USE_REINPLACE= yes
USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --without-gnome-print \
diff --git a/graphics/sodipodi/pkg-plist b/graphics/sodipodi/pkg-plist
index 8af2b7ff5ef4..ee4f469938a3 100644
--- a/graphics/sodipodi/pkg-plist
+++ b/graphics/sodipodi/pkg-plist
@@ -2,6 +2,7 @@ bin/sodipodi
lib/sodipodi/extensions/ill2svg.pl
lib/sodipodi/modules/libxmleditor.so
share/gnome/applications/sodipodi.desktop
+@exec update-desktop-database > /dev/null || /usr/bin/true
share/gnome/pixmaps/sodipodi.png
share/gnome/sodipodi/about.svg
share/gnome/sodipodi/add.xpm
@@ -219,3 +220,4 @@ share/locale/zh_CN/LC_MESSAGES/sodipodi.mo
@dirrm lib/sodipodi/modules
@dirrm lib/sodipodi/extensions
@dirrm lib/sodipodi
+@unexec update-desktop-database > /dev/null || /usr/bin/true